summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-31 21:46:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-31 21:46:51 +0000
commit47227a70bb8fbda9a1b40528355d4cb567130780 (patch)
treeb53567f1255b4fe7cf8f1222ca03308f5975f469 /app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild
parentFix build for sparc, update patchset, install to /usr/$(get_libdir)/${PN} (diff)
downloadgentoo-2-47227a70bb8fbda9a1b40528355d4cb567130780.tar.gz
gentoo-2-47227a70bb8fbda9a1b40528355d4cb567130780.tar.bz2
gentoo-2-47227a70bb8fbda9a1b40528355d4cb567130780.zip
Version bump. Thanks to Iskren Slavov <iskren.s@gmail.com> for the ebuild
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild')
-rw-r--r--app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild b/app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild
new file mode 100644
index 000000000000..08c0bfb9576a
--- /dev/null
+++ b/app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/acetoneiso/acetoneiso-2.2.2.ebuild,v 1.1 2010/07/31 21:46:51 hwoarang Exp $
+
+EAPI=2
+MY_P=${PN}_${PV}
+
+inherit flag-o-matic qt4-r2
+
+DESCRIPTION="a feature-rich and complete software application to manage CD/DVD images"
+HOMEPAGE="http://www.acetoneteam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/qt-webkit:4
+ x11-libs/qt-xmlpatterns:4
+ media-sound/phonon"
+RDEPEND="${DEPEND}
+ sys-fs/fuseiso"
+
+S=${WORKDIR}/${MY_P}/${PN}
+
+DOCS="AUTHORS CHANGELOG FEATURES README"
+DOCSDIR="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e 's:unrar-nonfree:unrar:g' sources/compress.h locale/*.ts || die
+}
+
+src_configure() {
+ append-flags -I/usr/include/KDE
+ qt4-r2_src_configure
+}