summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-07-12 11:08:48 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-07-12 11:08:48 +0000
commit5ddb28527615889966111edafc0791db7e858552 (patch)
tree194657e647bf57d63b7344258a21450ceabf8451 /app-benchmarks
parentVersion bump (bug #516930 by Sasha Medvedev). (diff)
downloadgentoo-2-5ddb28527615889966111edafc0791db7e858552.tar.gz
gentoo-2-5ddb28527615889966111edafc0791db7e858552.tar.bz2
gentoo-2-5ddb28527615889966111edafc0791db7e858552.zip
Bumped to EAPI=5, fixed compilation issues with 1.7 (bug #514662), fixed installation of documentation (#282219), add /opt/jmeter/bin to PATH via env.d (bug #238564)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/jmeter/ChangeLog12
-rw-r--r--app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild72
2 files changed, 81 insertions, 3 deletions
diff --git a/app-benchmarks/jmeter/ChangeLog b/app-benchmarks/jmeter/ChangeLog
index 415f3722e26d..b811d09112cf 100644
--- a/app-benchmarks/jmeter/ChangeLog
+++ b/app-benchmarks/jmeter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-benchmarks/jmeter
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/jmeter/ChangeLog,v 1.37 2011/12/19 13:06:31 sera Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/jmeter/ChangeLog,v 1.38 2014/07/12 11:08:48 ercpe Exp $
+
+*jmeter-2.0.1-r5 (12 Jul 2014)
+
+ 12 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +jmeter-2.0.1-r5.ebuild:
+ Bumped to EAPI=5, fixed compilation issues with 1.7 (bug #514662), fixed
+ installation of documentation (#282219), add /opt/jmeter/bin to PATH via env.d
+ (bug #238564)
19 Dec 2011; Ralph Sennhauser <sera@gentoo.org> jmeter-2.0.1-r2.ebuild,
jmeter-2.0.1-r3.ebuild, jmeter-2.0.1-r4.ebuild:
@@ -150,4 +157,3 @@
NOTE: This application requires Sun's JDK, and will not work correctly if you
currently have your user environment set to use IBM's JDK, or another.
-
diff --git a/app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild b/app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild
new file mode 100644
index 000000000000..ac2f333dcafe
--- /dev/null
+++ b/app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild,v 1.1 2014/07/12 11:08:48 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Load test and measure performance on HTTP/FTP services and databases."
+HOMEPAGE="http://jmeter.apache.org/"
+SRC_URI="mirror://apache/jakarta/jmeter/source/jakarta-${P}_src.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="beanshell"
+
+COMMON_DEP="
+ beanshell? ( dev-java/bsh )
+ >=dev-java/bsf-2.3
+ =dev-java/junit-3.8*
+ java-virtuals/javamail"
+DEPEND=">=virtual/jdk-1.4
+ doc? ( >=dev-java/velocity-1.4 )
+ dev-java/ant-nodeps
+ sys-apps/sed
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/jakarta-${P}
+
+java_prepare() {
+ sed -i -e 's/%//g' bin/jmeter || die "Unable to sed."
+ cd "${S}/lib" || die
+ # FIXME replace all bundled jars bug #63309
+ # then rm -f *.jar
+ use beanshell && java-pkg_jar-from bsh
+ java-pkg_jar-from bsf-2.3
+ java-pkg_jar-from junit
+ java-pkg_jar-from --virtual javamail
+ java-pkg_filter-compiler jikes
+
+ find "${S}"/src -name "*.java" | xargs sed -i -e 's:\benum\b:enumx:g' || die # fix for bug #514662
+}
+
+src_compile() {
+ local tasks="ant-nodeps"
+ use doc && tasks="${tasks} velocity"
+ ANT_TASKS="${tasks}" eant package $(use_doc docs-all) || die "compile problem"
+}
+
+src_install() {
+ DIROPTIONS="--mode=0775"
+ dodir /opt/${PN}
+ local dest="${D}/opt/${PN}/"
+ cp -pPR bin/ lib/ "${dest}" || die
+ if use doc; then
+ cp -pPR printable_docs "${dest}" || die "Failed to install docs"
+ fi
+ dodoc README
+
+ echo "PATH=\"/opt/${PN}/bin\"" > "${T}/90${PN}" || die
+ doenvd "${T}/90${PN}" || die "failed to install env.d file"
+
+ use doc && dohtml -r docs/*
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples xdocs/demos/*
+}