summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:58:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:58:51 +0000
commit37f1dd28cbb5915044d45c47f6fbeaabbdfcee90 (patch)
tree344d919666090ca7b0ddde260e16099b02538af7 /app-benchmarks
parentBump (diff)
downloadgentoo-2-37f1dd28cbb5915044d45c47f6fbeaabbdfcee90.tar.gz
gentoo-2-37f1dd28cbb5915044d45c47f6fbeaabbdfcee90.tar.bz2
gentoo-2-37f1dd28cbb5915044d45c47f6fbeaabbdfcee90.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/ChangeLog7
-rw-r--r--app-benchmarks/stress/stress-1.0.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-benchmarks/stress/ChangeLog b/app-benchmarks/stress/ChangeLog
index 9300ecbaa665..b43f2fdb8f9f 100644
--- a/app-benchmarks/stress/ChangeLog
+++ b/app-benchmarks/stress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/stress
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.42 2010/01/07 04:01:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.43 2010/02/26 20:58:51 patrick Exp $
+
+*stress-1.0.3 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +stress-1.0.3.ebuild:
+ Bump
07 Jan 2010; Joseph Jezak <josejx@gentoo.org> stress-1.0.1.ebuild:
Marked ppc stable for bug #296473.
diff --git a/app-benchmarks/stress/stress-1.0.3.ebuild b/app-benchmarks/stress/stress-1.0.3.ebuild
new file mode 100644
index 000000000000..5dbfc9012b13
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.3.ebuild,v 1.1 2010/02/26 20:58:51 patrick Exp $
+
+inherit autotools flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system."
+HOMEPAGE="http://weather.ou.edu/~apw/projects/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="sys-apps/help2man"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Force rebuild of the manpage.
+ rm -f doc/stress.1
+
+ # Honour Gentoo CFLAGS.
+ sed -i -e "/CFLAGS/s/-Werror//" \
+ -e "s/CFLAGS/AM_CFLAGS/" \
+ src/Makefile.am || die "sed cflags failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS README
+}