summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-01 15:23:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-01 15:23:37 +0000
commit57983f1530acd9b694ee113b0c5304832733df5c (patch)
tree7e0bc564564f1303dcb80fb1d33f829aea53ebf4 /app-benchmarks/phoronix-test-suite
parentInitial commit. (diff)
downloadgentoo-2-57983f1530acd9b694ee113b0c5304832733df5c.tar.gz
gentoo-2-57983f1530acd9b694ee113b0c5304832733df5c.tar.bz2
gentoo-2-57983f1530acd9b694ee113b0c5304832733df5c.zip
Fixing deps etc., closes #299121, thanks to Francisco Javier
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/phoronix-test-suite')
-rw-r--r--app-benchmarks/phoronix-test-suite/ChangeLog8
-rw-r--r--app-benchmarks/phoronix-test-suite/files/font.patch11
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.4.1-r1.ebuild61
3 files changed, 79 insertions, 1 deletions
diff --git a/app-benchmarks/phoronix-test-suite/ChangeLog b/app-benchmarks/phoronix-test-suite/ChangeLog
index fe3824405096..3e2e554c5f32 100644
--- a/app-benchmarks/phoronix-test-suite/ChangeLog
+++ b/app-benchmarks/phoronix-test-suite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/phoronix-test-suite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.5 2010/02/27 00:33:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.6 2010/03/01 15:23:36 patrick Exp $
+
+*phoronix-test-suite-2.4.1-r1 (01 Mar 2010)
+
+ 01 Mar 2010; Patrick Lauer <patrick@gentoo.org>
+ +phoronix-test-suite-2.4.1-r1.ebuild, +files/font.patch:
+ Fixing deps etc., closes #299121, thanks to Francisco Javier
*phoronix-test-suite-2.4.1 (27 Feb 2010)
diff --git a/app-benchmarks/phoronix-test-suite/files/font.patch b/app-benchmarks/phoronix-test-suite/files/font.patch
new file mode 100644
index 000000000000..a87ff8d90390
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/files/font.patch
@@ -0,0 +1,11 @@
+--- pts-core/objects/pts_Graph/pts_Graph.php.old 2009-11-11 17:39:37.000000000 +0100
++++ pts-core/objects/pts_Graph/pts_Graph.php 2009-12-30 12:46:27.816567436 +0100
+@@ -121,7 +121,7 @@
+ }
+ }
+
+- $this->graph_font = $font_type;
++ $this->graph_font = $default_font;
+ }
+ public function requestRenderer($renderer)
+ {
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.4.1-r1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..a69a96e02dbb
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.4.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.4.1-r1.ebuild,v 1.1 2010/03/01 15:23:36 patrick Exp $
+
+EAPI=2
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gd gtk"
+
+DEPEND=""
+RDEPEND="dev-lang/php:5[cli,gd,posix,pcntl,truetype,pcre]
+ app-arch/unzip
+ ps? ( dev-php5/pecl-ps )
+ gtk? ( dev-php5/php-gtk )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/font.patch
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r {pts,pts-core}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG
+ dohtml README.html
+
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ fperms a+x /usr/share/${PN}/pts/test-resources/*/*.sh
+ fperms a+x /usr/share/${PN}/pts/base-test-resources/*/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/modules/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/test-libraries/*.sh
+ fperms a+x /usr/share/${PN}/pts/distro-scripts/install-gentoo-packages.sh
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ dodir /etc/php/cli-php5
+ cp /etc/php/cli-php5/php.ini "${D}/etc/php/cli-php5/php.ini"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}/etc/php/cli-php5/php.ini"
+
+}