summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-13 02:13:25 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-13 02:13:25 +0000
commitf2bfab8bd03b37d0a715651263d85d9a086025eb (patch)
treeb89e2740c6f2dd77b877b109134b05764273b4ed /app-benchmarks/iozone
parentuse_enable fixup (Manifest recommit) (diff)
downloadgentoo-2-f2bfab8bd03b37d0a715651263d85d9a086025eb.tar.gz
gentoo-2-f2bfab8bd03b37d0a715651263d85d9a086025eb.tar.bz2
gentoo-2-f2bfab8bd03b37d0a715651263d85d9a086025eb.zip
version bump bug #53521
Diffstat (limited to 'app-benchmarks/iozone')
-rw-r--r--app-benchmarks/iozone/ChangeLog7
-rw-r--r--app-benchmarks/iozone/Manifest4
-rw-r--r--app-benchmarks/iozone/files/digest-iozone-3.2181
-rw-r--r--app-benchmarks/iozone/iozone-3.218.ebuild92
4 files changed, 102 insertions, 2 deletions
diff --git a/app-benchmarks/iozone/ChangeLog b/app-benchmarks/iozone/ChangeLog
index 224766e49cfe..158a025c2de3 100644
--- a/app-benchmarks/iozone/ChangeLog
+++ b/app-benchmarks/iozone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/iozone
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.2 2004/05/13 08:20:50 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.3 2004/06/13 02:13:25 dragonheart Exp $
+
+*iozone-3.218 (13 Jun 2004)
+
+ 13 Jun 2004; Daniel Black <dragonheart@gentoo.org> +iozone-3.218.ebuild:
+ version bump notified by Daniel Webert <daniel_webert@web.de> in bug #53521
13 May 2004; David Holm <dholm@gentoo.org> iozone-3.217.ebuild:
Added to ~ppc.
diff --git a/app-benchmarks/iozone/Manifest b/app-benchmarks/iozone/Manifest
index b72f6164dbe1..c25c637d707d 100644
--- a/app-benchmarks/iozone/Manifest
+++ b/app-benchmarks/iozone/Manifest
@@ -1,4 +1,6 @@
-MD5 08abcf2ffbd74731718d9681caa7a308 ChangeLog 499
MD5 1f77c61c1da9868e68331f7f0bc36804 iozone-3.217.ebuild 985
+MD5 1f77c61c1da9868e68331f7f0bc36804 iozone-3.218.ebuild 985
MD5 6d796b061ed1c1337ef157a5f74dab35 metadata.xml 403
+MD5 08abcf2ffbd74731718d9681caa7a308 ChangeLog 499
MD5 e656883c1b06fd737e3f145ee18fb5b5 files/digest-iozone-3.217 61
+MD5 d8d6924bd76a53cd2df1c261ae63b02f files/digest-iozone-3.218 61
diff --git a/app-benchmarks/iozone/files/digest-iozone-3.218 b/app-benchmarks/iozone/files/digest-iozone-3.218
new file mode 100644
index 000000000000..bdac2c99732e
--- /dev/null
+++ b/app-benchmarks/iozone/files/digest-iozone-3.218
@@ -0,0 +1 @@
+MD5 605b0754ff7584e4d2cec30a62062807 iozone3_218.tar 1423360
diff --git a/app-benchmarks/iozone/iozone-3.218.ebuild b/app-benchmarks/iozone/iozone-3.218.ebuild
new file mode 100644
index 000000000000..8e14a37475ba
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.218.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.218.ebuild,v 1.1 2004/06/13 02:13:25 dragonheart Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Filesystem benchmarking program."
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+LICENSE="freedist"
+SLOT="0"
+
+# TODO
+# -> linux-arm (32bit) <-
+# -> linux-AMD64 (64bit) <-
+# -> linux-ia64 (64bit) <-
+# -> linux-powerpc (32bit) <-
+# -> linux-sparc (32bit) <-
+# -> linux-S390 (32bit) <-
+# -> linux-S390X (64bit) <-
+#
+# -> macosx (32bit) <-
+# -> netbsd (32bit) <-
+# -> openbsd (32bit) <-
+# -> openbsd-threads (32bit) <-
+#
+#
+# ~arm ~amd64 ~ia64 ~sparc ~s390 alpha(?)
+
+KEYWORDS="~x86 ~ppc"
+
+
+DEPEND="sys-devel/gcc
+ >=sys-apps/sed-4
+ virtual/glibc"
+
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}
+
+src_compile() {
+
+ cd src/current
+
+ # Options FIX
+ sed -i -e "s:[/a-z]*cc.*-c.*-Dunix:${CC} ${CFLAGS} -Dunix -c:g" \
+ -e "s:[/a-z]*cc.*-Dunix:${CC} ${CFLAGS} -Dunix:g" makefile
+
+ case ${ARCH} in
+ x86|alpha)
+ PLATFORM="linux"
+ ;;
+ ppc)
+ PLATFORM="linux-powerpc"
+ ;;
+ amd64)
+ PLATFORM="linux-AMD64"
+ ;;
+ s390)
+ PLATFORM="linux-S390"
+ ;;
+ *)
+ PLATFORM="linux-${ARCH}"
+ ;;
+ esac
+
+ emake ${PLATFORM} || die "Compile failed"
+}
+
+src_install() {
+ dosbin src/current/iozone
+ dodoc docs/I*
+ dodoc docs/Run_rules.doc
+ dodoc src/current/Changes.txt
+ doman docs/iozone.1
+
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ cd src/current
+ doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+
+ prepall
+}
+
+src_test() {
+
+ cd ${T}
+ ${S}/src/current/iozone testfile || die "self test failed"
+
+}