summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-05-13 07:48:58 +0000
committerFabian Groffen <grobian@gentoo.org>2006-05-13 07:48:58 +0000
commit427db61dd38c2b299e4963ea526338ebc1060855 (patch)
tree934e0fe2821c95842218af85caae1ddc2ae36a25 /app-backup
parentOld version does not work with TCL8.3 or newer, please use the 3.3 series. (diff)
downloadgentoo-2-427db61dd38c2b299e4963ea526338ebc1060855.tar.gz
gentoo-2-427db61dd38c2b299e4963ea526338ebc1060855.tar.bz2
gentoo-2-427db61dd38c2b299e4963ea526338ebc1060855.zip
Added quotes around variables, added 'die' in front of error messages, fixed sed scripts to fix bug #133120
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bobs/ChangeLog6
-rw-r--r--app-backup/bobs/bobs-0.6.2.ebuild30
2 files changed, 20 insertions, 16 deletions
diff --git a/app-backup/bobs/ChangeLog b/app-backup/bobs/ChangeLog
index 3e4eec055992..f906e09b7479 100644
--- a/app-backup/bobs/ChangeLog
+++ b/app-backup/bobs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-backup/bobs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/ChangeLog,v 1.1 2006/05/11 16:50:44 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/ChangeLog,v 1.2 2006/05/13 07:48:58 grobian Exp $
+
+ 13 May 2006; Fabian Groffen <grobian@gentoo.org> bobs-0.6.2.ebuild:
+ Added quotes around variables, added 'die' in front of error messages, fixed
+ sed scripts to fix bug #133120
*bobs-0.6.2 (11 May 2006)
diff --git a/app-backup/bobs/bobs-0.6.2.ebuild b/app-backup/bobs/bobs-0.6.2.ebuild
index a761341d24f8..87cfa14ccc5a 100644
--- a/app-backup/bobs/bobs-0.6.2.ebuild
+++ b/app-backup/bobs/bobs-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/bobs-0.6.2.ebuild,v 1.1 2006/05/11 16:50:44 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/bobs-0.6.2.ebuild,v 1.2 2006/05/13 07:48:58 grobian Exp $
inherit webapp eutils
@@ -24,24 +24,24 @@ src_unpack() {
# Original configure looks for httpd process. Hardwire to apache2...
sed -e "s:\$(ps -C httpd:\$(ps -C apache2:" \
- -i 'configure' || "Autodetect of Apache user failed"
+ -i 'configure' || die "Autodetect of Apache user failed"
# Slightly nasty fixup for some problems in the orig Makefile
# Otherwise it doesn't respect that prefix given to "make install"
sed -e "s:\$(myBOBSDATA):\$(DESTDIR)\$(myBOBSDATA):" \
- -i 'Makefile.am' || "Makefile bodge failed"
- sed -e "s:\$(top_srcdir)/mkinstalldirs\\$(myWEBDIR):\$(top_srcdir)/mkinstalldirs \$(DESTDIR)\$(myWEBDIR):" \
- -i 'inc/servers/Makefile.am' || "Makefile bodge failed"
- sed -e "s:chown -R \$(myHTTPDUSER) \$(myWEBDIR):chown -R \$(myHTTPDUSER)\\$(DESTDIR)\$(myWEBDIR):" \
- -i 'inc/servers/Makefile.am' || "Makefile bodge failed"
+ -i 'Makefile.am' || die "Makefile bodge 1 failed"
+ sed -e "s:\$(top_srcdir)/mkinstalldirs \$(myWEBDIR):\$(top_srcdir)/mkinstalldirs \$(DESTDIR)\$(myWEBDIR):" \
+ -i 'inc/servers/Makefile.am' || die "Makefile bodge 2 failed"
+ sed -e "s:chown -R \$(myHTTPDUSER) \$(myWEBDIR):chown -R \$(myHTTPDUSER) \$(DESTDIR)\$(myWEBDIR):" \
+ -i 'inc/servers/Makefile.am' || die "Makefile bodge failed"
# Modify the webdir to match the webapp format
sed -e "s:myWEBDIR=\$with_webdir/bobs:myWEBDIR=\$with_webdir:" \
- -i 'configure' || "configure bodge failed"
+ -i 'configure' || die "configure bodge failed"
}
src_compile() {
./configure \
--with-webdir=/usr/share/webapps/${PN}/${PV}/htdocs \
- || die "econf failed"
+ || die "configure failed"
emake || die "emake failed"
}
@@ -49,24 +49,24 @@ src_compile() {
src_install() {
webapp_src_preinst
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
keepdir /var/bobsdata/current/process/session
keepdir /var/bobsdata/current/process/cmd
keepdir /var/bobsdata/current/process/mounts
- webapp_configfile ${MY_HTDOCSDIR}/inc/excludes/default.excludelist
- webapp_configfile ${MY_HTDOCSDIR}/inc/config.php
- webapp_configfile ${MY_HTDOCSDIR}/inc/servers/testserver.share.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/inc/excludes/default.excludelist
+ webapp_configfile "${MY_HTDOCSDIR}"/inc/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/inc/servers/testserver.share.ini
dodir /var/bobsdata/incoming
dodir /var/bobsdata/incremental
# Why doesn't this next line work?
- chown -R root:apache ${D}/var/bobsdata/
+ chown -R root:apache "${D}"/var/bobsdata/
einfo "/var/bobsdata MUST be accessible to the apache user"
dodoc README INSTALL TODO
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}