summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2009-09-09 07:45:18 +0000
committerWolfram Schlich <wschlich@gentoo.org>2009-09-09 07:45:18 +0000
commit71e7bdd183f26b1e6f58c805ef6248111e8406ed (patch)
treeb971b8bf60da95701c168882ee00b0a2714f0d14 /app-backup/bacula
parentVersion bump. Ebuild improvements by Colin Macdonald, further refined by MATS... (diff)
downloadgentoo-2-71e7bdd183f26b1e6f58c805ef6248111e8406ed.tar.gz
gentoo-2-71e7bdd183f26b1e6f58c805ef6248111e8406ed.tar.bz2
gentoo-2-71e7bdd183f26b1e6f58c805ef6248111e8406ed.zip
version bump, (also) fixes bugs #280048, #272282, #265647, #258187, #257016, #254743, #235515
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-backup/bacula')
-rw-r--r--app-backup/bacula/ChangeLog13
-rw-r--r--app-backup/bacula/bacula-3.0.2.ebuild483
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-default-configs.patch127
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-dir-conf15
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-dir-init25
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-fd-conf8
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-fd-init22
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-gnomesu2gksu.diff48
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-sd-conf11
-rw-r--r--app-backup/bacula/files/3.0.2/bacula-sd-init22
10 files changed, 773 insertions, 1 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index 4545de6411c5..180c05b2c383 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-backup/bacula
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.74 2009/08/19 13:47:56 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.75 2009/09/09 07:45:18 wschlich Exp $
+
+*bacula-3.0.2 (09 Sep 2009)
+
+ 09 Sep 2009; Wolfram Schlich <wschlich@gentoo.org>
+ +files/3.0.2/bacula-default-configs.patch, +files/3.0.2/bacula-dir-conf,
+ +files/3.0.2/bacula-dir-init, +files/3.0.2/bacula-fd-conf,
+ +files/3.0.2/bacula-fd-init, +files/3.0.2/bacula-gnomesu2gksu.diff,
+ +files/3.0.2/bacula-sd-conf, +files/3.0.2/bacula-sd-init,
+ +bacula-3.0.2.ebuild:
+ version bump, (also) fixes bugs #280048, #272282, #265647, #258187, #257016,
+ #254743, #235515
19 Aug 2009; Petteri Räty <betelgeuse@gentoo.org> bacula-2.4.4.ebuild:
Migrate to EAPI 2 in order to get rid of built_with_use.
diff --git a/app-backup/bacula/bacula-3.0.2.ebuild b/app-backup/bacula/bacula-3.0.2.ebuild
new file mode 100644
index 000000000000..1572d8be347c
--- /dev/null
+++ b/app-backup/bacula/bacula-3.0.2.ebuild
@@ -0,0 +1,483 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-3.0.2.ebuild,v 1.1 2009/09/09 07:45:18 wschlich Exp $
+
+EAPI="2"
+inherit eutils
+
+IUSE="bacula-clientonly bacula-console bacula-nodir bacula-nosd gnome ipv6 logwatch mysql postgres python qt4 readline sqlite +sqlite3 ssl static tcpd wxwindows X"
+# bacula-web bimagemgr brestore bweb
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+
+MY_PV=${PV/_beta/-b}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+#DOC_VER="${MY_PV}"
+#DOC_SRC_URI="mirror://sourceforge/bacula/${PN}-docs-${DOC_VER}.tar.bz2"
+#GUI_VER="${PV}"
+#GUI_SRC_URI="mirror://sourceforge/bacula/${PN}-gui-${GUI_VER}.tar.gz"
+SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
+# doc? ( ${DOC_SRC_URI} )
+# bacula-web? ( ${GUI_SRC_URI} )
+# bimagemgr? ( ${GUI_SRC_URI} )
+# brestore? ( ${GUI_SRC_URI} )
+# bweb? ( ${GUI_SRC_URI} )
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=sys-libs/zlib-1.1.4
+ dev-libs/gmp
+ !bacula-clientonly? (
+ postgres? ( >=virtual/postgresql-server-7.4 )
+ mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( >=dev-db/sqlite-3.0.0 )
+ virtual/mta
+ )
+ bacula-console? (
+ wxwindows? ( =x11-libs/wxGTK-2.6* )
+ qt4? (
+ || ( x11-libs/qt-svg:4 =x11-libs/qt-4.3* )
+ >=x11-libs/qwt-5
+ )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ x11-libs/gksu
+ )
+ )
+ ssl? ( dev-libs/openssl )
+ logwatch? ( sys-apps/logwatch )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ python? ( dev-lang/python[threads] )"
+# doc? (
+# virtual/ghostscript
+# dev-tex/latex2html[png]
+# app-text/dvipdfm
+# )
+RDEPEND="${DEPEND}
+ !bacula-clientonly? (
+ sys-block/mtx
+ app-arch/mt-st
+ )"
+
+pkg_setup() {
+ local dbnum
+ declare -i dbnum=0
+ if ! useq bacula-clientonly; then
+ if useq mysql; then
+ export mydbtype='mysql'
+ let dbnum++
+ fi
+ if useq postgres; then
+ export mydbtype='postgresql'
+ let dbnum++
+ fi
+ if useq sqlite; then
+ export mydbtype='sqlite'
+ let dbnum++
+ fi
+ if useq sqlite3; then
+ export mydbtype='sqlite3'
+ let dbnum++
+ fi
+ if [[ "${dbnum}" -lt 1 ]]; then
+ eerror
+ eerror "To use ${P} it is required to set a database in the USE flags."
+ eerror "Supported databases are mysql, postgresql, sqlite, sqlite3"
+ eerror
+ die "No database type selected."
+ elif [[ "${dbnum}" -gt 1 ]]; then
+ eerror
+ eerror "You have set ${P} to use multiple database types."
+ eerror "I don't know which to set as the default!"
+ eerror "You can use /etc/portage/package.use to set per-package USE flags"
+ eerror "Set it so only one database type, mysql, postgres, sqlite, sqlite3"
+ eerror
+ die "Multiple database types selected."
+ fi
+ fi
+
+ # create the daemon group and user
+ if [ -z "$(egetent group bacula)" ]; then
+ enewgroup bacula
+ einfo
+ einfo "The group 'bacula' has been created. Any users you add to this"
+ einfo "group have access to files created by the daemons."
+ einfo
+ fi
+ if ! useq bacula-clientonly; then
+ if [ -z "$(egetent passwd bacula)" ]; then
+ enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
+ einfo
+ einfo "The user 'bacula' has been created. Please see the bacula manual"
+ einfo "for information about running bacula as a non-root user."
+ einfo
+ fi
+ fi
+}
+
+src_prepare() {
+ # adjusts default configuration files for several binaries
+ # to /etc/bacula/<config> instead of ./<config>
+ pushd src && epatch "${FILESDIR}/${PV}/${PN}"-default-configs.patch && popd
+
+ # replaces (deprecated) gnomesu with gksu in the gnome menu files
+ useq bacula-console && useq gnome && epatch "${FILESDIR}/${PV}/${PN}"-gnomesu2gksu.diff
+
+ # apply upstream patches
+ #epatch "${FILESDIR}"/${PV}/${PV}-foo.patch
+}
+
+src_configure() {
+ local myconf=''
+
+ if useq bacula-clientonly; then
+ myconf="${myconf} \
+ $(use_enable bacula-clientonly client-only) \
+ $(use_enable static static-fd)"
+ else
+ myconf="${myconf} \
+ --with-${mydbtype} \
+ $(use_enable static static-tools) \
+ $(use_enable static static-fd) \
+ $(use_enable !bacula-nodir build-dird) \
+ $(use_enable !bacula-nosd build-stored)"
+ if ! useq bacula-nodir; then
+ myconf="${myconf} $(use_enable static static-dir)"
+ fi
+ if ! useq bacula-nosd; then
+ myconf="${myconf} $(use_enable static static-sd)"
+ fi
+ case "${mydbtype}" in
+ sqlite) ;;
+ *) myconf="${myconf} --enable-batch-insert" ;;
+ esac
+ fi
+
+ if useq bacula-console; then
+ if useq qt4 && has_version '<x11-libs/qwt-5'; then
+ eerror "x11-libs/qwt found in a version < 5, thus the"
+ eerror "compilation of 'bat' would fail (see"
+ eerror "http://bugs.gentoo.org/188477#c11 for details)."
+ eerror "please either unmerge <x11-libs/qwt-5 or disable"
+ eerror "the qt4 USE flag to disable building 'bat'."
+ die "incompatible slotted qwt version found"
+ fi
+ myconf="${myconf} \
+ $(use_with X x) \
+ $(use_enable gnome) \
+ $(use_enable gnome tray-monitor) \
+ $(use_enable wxwindows bwx-console) \
+ $(use_enable qt4 bat) \
+ $(use_enable static static-cons)"
+ fi
+
+ myconf="${myconf} \
+ $(use_with python) \
+ $(use_enable readline) \
+ $(use_with readline readline /usr) \
+ $(use_with ssl openssl) \
+ $(use_enable ipv6) \
+ $(use_with tcpd tcp-wrappers)"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lock/subsys \
+ --with-working-dir=/var/lib/bacula \
+ --with-scriptdir=/usr/libexec/bacula \
+ --with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=root \
+ --with-sd-group=bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula \
+ --enable-smartalloc \
+ --host=${CHOST} \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ # build various GUIs from bacula-gui tarball
+# if useq bacula-web || useq bimagemgr || useq brestore || useq bweb; then
+# pushd "${WORKDIR}/${PN}-gui-${GUI_VER}"
+# local myconf_gui=''
+# if useq bimagemgr; then
+# ## TODO FIXME: webapp-config? !apache?
+# myconf_gui="${myconf_gui} \
+# --with-bimagemgr-cgidir=/var/www/localhost/cgi-bin \
+# --with-bimagemgr-docdir=/var/www/localhost/htdocs \
+# --with-bimagemgr-binowner=root \
+# --with-bimagemgr-bingroup=root \
+# --with-bimagemgr-dataowner=apache \
+# --with-bimagemgr-datagroup=apache \
+# "
+# fi
+# ./configure \
+# --with-bacula="${S}" \
+# ${myconf} \
+# || die "configure for bacula-gui failed"
+# ## TODO FIXME: install files (see bacula-gui.spec)
+# if useq bacula-web; then
+# : install
+# fi
+# if useq bimagemgr; then
+# : install
+# fi
+# if useq brestore; then
+# : install
+# fi
+# if useq bweb; then
+# : install
+# fi
+# popd
+# fi
+
+ # build docs from bacula-docs tarball
+# if useq doc; then
+# pushd "${WORKDIR}/${PN}-docs-${DOC_VER}"
+# ./configure \
+# --with-bacula="${S}" \
+# || die "configure for bacula-docs failed"
+# emake -j1 || die "emake for bacula-docs failed"
+# popd
+# fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # install bat when enabled (for some reason ./configure doesn't pick this up)
+ if useq bacula-console && useq qt4; then
+ dosbin "${S}"/src/qt-console/.libs/bat
+ fi
+
+ # remove some scripts we don't need at all
+ rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
+
+ # rename statically linked apps
+ if useq static; then
+ pushd "${D}"/usr/sbin
+ mv static-bacula-fd bacula-fd
+ mv static-bconsole bconsole
+ if ! useq bacula-clientonly; then
+ mv static-bacula-dir bacula-dir
+ mv static-bacula-sd bacula-sd
+ fi
+ if useq bacula-console && useq gnome; then
+ mv static-gnome-console gnome-console
+ fi
+ if useq bacula-console && useq qt4; then
+ mv static-bat bat
+ fi
+ popd
+ fi
+
+ # gnome-console menu entries using gksu
+ if useq bacula-console && useq gnome; then
+ emake DESTDIR="${D}" install-menu-xsu \
+ || die "Failed to install gnome menu files"
+ fi
+
+ # extra files which 'make install' doesn't cover
+ if ! useq bacula-clientonly; then
+ # the database update scripts
+ diropts -m0750
+ insinto /usr/libexec/bacula/updatedb
+ insopts -m0754
+ doins "${S}"/updatedb/*
+ fperms 0640 /usr/libexec/bacula/updatedb/README
+
+ # the logrotate configuration
+ # (now unconditional wrt bug #258187)
+ diropts -m0755
+ insinto /etc/logrotate.d
+ insopts -m0644
+ newins "${S}"/scripts/logrotate bacula
+
+ # the logwatch scripts
+ if useq logwatch; then
+ diropts -m0750
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ cd "${S}"/scripts/logwatch
+ emake DESTDIR="${D}" install || die "Failed to install logwatch scripts"
+ cd "${S}"
+ fi
+ fi
+
+ # remove unwanted files
+ if ! use bacula-console; then
+ rm -vf "${D}"/etc/bacula/bconsole.conf
+ rm -vf "${D}"/usr/sbin/bconsole
+ rm -vf "${D}"/usr/libexec/bacula/bconsole
+ fi
+ if ! ( use bacula-console && use gnome ); then
+ rm -vf "${D}"/usr/share/man/man1/bacula-bgnome-console.1*
+ rm -vf "${D}"/usr/libexec/bacula/gconsole
+ fi
+ if ! ( use bacula-console && use wxwindows ); then
+ rm -vf "${D}"/usr/share/man/man1/bacula-bwxconsole.1*
+ fi
+ if use bacula-clientonly; then
+ rm -vf "${D}"/usr/share/man/man1/bat.1*
+ rm -vf "${D}"/usr/share/man/man1/bacula-tray-monitor.1*
+ fi
+ if use bacula-clientonly || use bacula-nodir; then
+ rm -vf "${D}"/usr/share/man/man8/bacula-dir.8*
+ rm -vf "${D}"/usr/share/man/man8/dbcheck.8*
+ rm -vf "${D}"/usr/share/man/man1/bsmtp.1*
+ rm -vf "${D}"/usr/libexec/bacula/create_*_database
+ rm -vf "${D}"/usr/libexec/bacula/drop_*_database
+ rm -vf "${D}"/usr/libexec/bacula/make_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/update_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/drop_*_tables
+ rm -vf "${D}"/usr/libexec/bacula/grant_*_privileges
+ rm -vf "${D}"/usr/libexec/bacula/*_catalog_backup
+ fi
+ if use bacula-clientonly || use bacula-nosd; then
+ rm -vf "${D}"/usr/share/man/man8/bacula-sd.8*
+ rm -vf "${D}"/usr/share/man/man8/bcopy.8*
+ rm -vf "${D}"/usr/share/man/man8/bextract.8*
+ rm -vf "${D}"/usr/share/man/man8/bls.8*
+ rm -vf "${D}"/usr/share/man/man8/bscan.8*
+ rm -vf "${D}"/usr/share/man/man8/btape.8*
+ rm -vf "${D}"/usr/libexec/bacula/disk-changer
+ rm -vf "${D}"/usr/libexec/bacula/mtx-changer
+ rm -vf "${D}"/usr/libexec/bacula/dvd-handler
+ fi
+
+ # documentation
+ for d in "${S}"/{ChangeLog,LICENSE,README,ReleaseNotes,SUPPORT,kernstodo,projects}; do
+ dodoc "${d}"
+ done
+# if useq doc; then
+# for i in catalog concepts console developers install problems utility; do
+# dodoc "${WORKDIR}/${PN}-docs-${DOC_VER}"/manuals/en/${i}/${i}.pdf
+# done
+# fi
+
+ # setup init scripts
+ myscripts="bacula-fd"
+ if ! useq bacula-clientonly; then
+ if ! useq bacula-nodir; then
+ myscripts="${myscripts} bacula-dir"
+ fi
+ if ! useq bacula-nosd; then
+ myscripts="${myscripts} bacula-sd"
+ fi
+ fi
+ for script in ${myscripts}; do
+ # copy over init script and config to a temporary location
+ # so we can modify them as needed
+ cp "${FILESDIR}/${PV}/${script}"-conf "${T}/${script}".conf || die "failed to copy ${script}-conf"
+ cp "${FILESDIR}/${PV}/${script}"-init "${T}/${script}".init || die "failed to copy ${script}-init"
+ # set database dependancy for the director init scripts
+ case "${script}" in
+ bacula-dir)
+ case "${mydbtype}" in
+ sqlite*)
+ # sqlite + sqlite3 databases don't have daemons
+ sed -i -e 's/need "%database%"/:/g' "${T}/${script}".init
+ ;;
+ *)
+ # all other databases have daemons
+ sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".init
+ ;;
+ esac
+ ;;
+ *)
+ ;;
+ esac
+ # install init script and config
+ newinitd "${T}/${script}".init "${script}"
+ newconfd "${T}/${script}".conf "${script}"
+ done
+
+ # make sure the working directory exists
+ diropts -m0750
+ keepdir /var/lib/bacula
+
+ # make sure bacula group can execute bacula libexec scripts
+ fowners -R root:bacula /usr/libexec/bacula
+}
+
+pkg_postinst() {
+ if useq bacula-clientonly; then
+ fowners root:bacula /var/lib/bacula
+ else
+ fowners bacula:bacula /var/lib/bacula
+ fi
+
+ if ! useq bacula-clientonly && ! useq bacula-nodir; then
+ einfo
+ einfo "If this is a new install, you must create the ${mydbtype} databases with:"
+ einfo " /usr/libexec/bacula/create_${mydbtype}_database"
+ einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
+ einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
+ einfo
+ einfo "If you're upgrading from a major release, you must upgrade your bacula catalog database."
+ einfo "Please read the manual chapter for how to upgrade your database."
+ einfo "You can find database upgrade scripts in /usr/libexec/bacula/updatedb."
+ einfo
+ fi
+
+ ewarn
+ ewarn "*** ATTENTION! IMPORTANT! ATTENTION! IMPORTANT! ATTENTION! IMPORTANT! ***"
+ ewarn
+ ewarn "The bundled catalog backup script (/usr/libexec/bacula/make_catalog_backup)"
+ ewarn "is INSECURE. The script needs to be called with the database access password"
+ ewarn "as a command line parameter, thus, the password can be seen from any other"
+ ewarn "user on the system (if not using some non-default hardened/patched kernel"
+ ewarn "with /proc restrictions)!"
+ ewarn
+ ewarn "Our advice is to NOT USE the bundled script at all, but instead use something"
+ ewarn "like this in your catalog backup job definition (example using MySQL as the"
+ ewarn "catalog database):"
+ ewarn
+ ewarn "RunBeforeJob = \"mysqldump --defaults-file=/etc/bacula/my.cnf --opt -f -r /var/lib/bacula/bacula.sql bacula\""
+ ewarn "RunAfterJob = \"rm -f /var/lib/bacula/bacula.sql\""
+ ewarn
+ ewarn "This requires you to put all database access parameters (like user, host and"
+ ewarn "password) into a dedicated file (/etc/bacula/my.cnf in this example) which"
+ ewarn "can (and should!) be secured by simple filesystem access permissions."
+ ewarn
+ ewarn "See also:"
+ ewarn "http://www.bacula.org/en/rel-manual/Bacula_Security_Issues.html"
+ ewarn "http://www.bacula.org/en/rel-manual/Catalog_Maintenance.html#BackingUpBaculaSecurityConsiderations"
+ ewarn
+ ewarn "*** ATTENTION! IMPORTANT! ATTENTION! IMPORTANT! ATTENTION! IMPORTANT! ***"
+ ewarn
+ ebeep 10
+ epause 20
+
+ ewarn
+ ewarn "*** NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! ***"
+ ewarn
+ ewarn "Support for the bacula all-in-one init script has been removed from"
+ ewarn "this release -- if you were previously using the all-in-one init"
+ ewarn "script, please switch to using the individual init scripts now:"
+ ewarn
+ ewarn "- bacula-dir: bacula director (for the central bacula server)"
+ ewarn "- bacula-fd: bacula file daemon (for hosts to be backed up)"
+ ewarn "- bacula-sd: bacula storage daemon (for hosts storing the backup data)"
+ ewarn
+ ewarn "*** NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! ***"
+ ewarn
+ ebeep 5
+ epause 10
+}
diff --git a/app-backup/bacula/files/3.0.2/bacula-default-configs.patch b/app-backup/bacula/files/3.0.2/bacula-default-configs.patch
new file mode 100644
index 000000000000..3157b9736ea2
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-default-configs.patch
@@ -0,0 +1,127 @@
+--- console/console.c 2008-08-11 23:50:20.000000000 +0200
++++ console/console.c 2008-06-09 11:25:27.000000000 +0200
+@@ -105,7 +105,7 @@
+ static int execcmd(FILE *input, BSOCK *UA_sock);
+
+
+-#define CONFIG_FILE "bconsole.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bconsole.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- dird/dird.c 2008-08-11 23:49:40.000000000 +0200
++++ dird/dird.c 2008-06-07 16:46:43.000000000 +0200
+@@ -85,7 +85,7 @@
+ extern URES res_all;
+ #endif
+
+-#define CONFIG_FILE "bacula-dir.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bacula-dir.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- filed/filed.c 2008-08-11 23:51:18.000000000 +0200
++++ filed/filed.c 2008-06-07 16:46:43.000000000 +0200
+@@ -50,7 +50,7 @@
+ void *start_heap;
+
+
+-#define CONFIG_FILE "bacula-fd.conf" /* default config file */
++#define CONFIG_FILE "/etc/bacula/bacula-fd.conf" /* default config file */
+
+ char *configfile = NULL;
+ static bool foreground = false;
+--- gnome2-console/console.c 2008-08-11 23:50:45.000000000 +0200
++++ gnome2-console/console.c 2008-06-07 16:46:43.000000000 +0200
+@@ -93,7 +93,7 @@
+ static guint initial;
+ static int numdir = 0;
+
+-#define CONFIG_FILE "./bgnome-console.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bgnome-console.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- stored/bcopy.c 2008-08-11 23:54:48.000000000 +0200
++++ stored/bcopy.c 2008-06-07 16:46:43.000000000 +0200
+@@ -61,7 +61,7 @@
+ static SESSION_LABEL sessrec;
+
+ static CONFIG *config;
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false; /* proceed inspite of I/O errors */
+--- stored/bextract.c 2008-08-11 23:45:44.000000000 +0200
++++ stored/bextract.c 2008-06-07 16:46:43.000000000 +0200
+@@ -69,5 +69,5 @@
+ static CONFIG *config;
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bls.c 2008-08-11 23:46:05.000000000 +0200
++++ stored/bls.c 2008-06-07 16:46:43.000000000 +0200
+@@ -60,7 +60,7 @@
+ static uint32_t num_files = 0;
+ static ATTR *attr;
+ static CONFIG *config;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bscan.c 2008-08-11 23:46:26.000000000 +0200
++++ stored/bscan.c 2008-06-18 21:29:26.000000000 +0200
+@@ -106,4 +106,4 @@
+ static CONFIG *config;
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+--- stored/btape.c 2008-08-11 23:46:59.000000000 +0200
++++ stored/btape.c 2008-06-07 16:46:43.000000000 +0200
+@@ -105,6 +105,6 @@
+ /* Static variables */
+ static CONFIG *config;
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+
+ #define MAX_CMD_ARGS 30
+--- stored/stored.c 2008-08-11 23:54:32.000000000 +0200
++++ stored/stored.c 2008-06-23 11:58:34.000000000 +0200
+@@ -52,7 +52,7 @@
+
+ extern "C" void *device_initialization(void *arg);
+
+-#define CONFIG_FILE "bacula-sd.conf" /* Default config file */
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf" /* Default config file */
+
+ /* Global variables exported */
+ char OK_msg[] = "3000 OK\n";
+--- tray-monitor/tray-monitor.c 2008-08-11 23:49:13.000000000 +0200
++++ tray-monitor/tray-monitor.c 2008-06-07 16:46:43.000000000 +0200
+@@ -104,7 +104,7 @@
+
+ PangoFontDescription *font_desc = NULL;
+
+-#define CONFIG_FILE "./tray-monitor.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/tray-monitor.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- qt-console/main.cpp 2009-05-14 06:41:48.000000000 -0400
++++ qt-console/main.cpp.new 2009-07-21 23:29:37.848322986 -0400
+@@ -49,7 +49,7 @@
+
+ extern bool parse_bat_config(CONFIG *config, const char *configfile, int exit_code);
+
+-#define CONFIG_FILE "bat.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bat.conf" /* default configuration file */
+
+ /* Static variables */
+ static CONFIG *config;
diff --git a/app-backup/bacula/files/3.0.2/bacula-dir-conf b/app-backup/bacula/files/3.0.2/bacula-dir-conf
new file mode 100644
index 000000000000..e7bcacf572d9
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-dir-conf
@@ -0,0 +1,15 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-dir-conf,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-dir
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+LOCAL_DB=1
+
+# Options for the director daemon.
+# The DIR can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/3.0.2/bacula-dir-init b/app-backup/bacula/files/3.0.2/bacula-dir-init
new file mode 100644
index 000000000000..f329f2e0e620
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-dir-init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-dir-init,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+depend() {
+ need net
+ if [ "${LOCAL_DB}" -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns bacula-fd bacula-sd
+}
+
+start() {
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/3.0.2/bacula-fd-conf b/app-backup/bacula/files/3.0.2/bacula-fd-conf
new file mode 100644
index 000000000000..fe9540b77f0b
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-fd-conf
@@ -0,0 +1,8 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-fd-conf,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file daemon.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/app-backup/bacula/files/3.0.2/bacula-fd-init b/app-backup/bacula/files/3.0.2/bacula-fd-init
new file mode 100644
index 000000000000..c75e4fd5a3ef
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-fd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-fd-init,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/3.0.2/bacula-gnomesu2gksu.diff b/app-backup/bacula/files/3.0.2/bacula-gnomesu2gksu.diff
new file mode 100644
index 000000000000..8f17daa8db9b
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-gnomesu2gksu.diff
@@ -0,0 +1,48 @@
+diff -urN bacula-2.2.4.orig/scripts/bacula.desktop.gnome1.xsu.in bacula-2.2.4/scripts/bacula.desktop.gnome1.xsu.in
+--- bacula-2.2.4.orig/scripts/bacula.desktop.gnome1.xsu.in 2008-04-18 19:06:43.000000000 +0200
++++ bacula-2.2.4/scripts/bacula.desktop.gnome1.xsu.in 2008-10-10 23:34:42.000000000 +0200
+@@ -2,7 +2,7 @@
+ Name=Bacula Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/bacula.png
+-Exec=gnomesu -t "Query" -c "@sbindir@/bgnome-console -c @sysconfdir@/bgnome-console.conf" -d -e -m "In order to run the bacula console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Console needs to be run with superuser privileges' "@sbindir@/bgnome-console -c @sysconfdir@/bgnome-console.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+diff -urN bacula-2.2.4.orig/scripts/bacula.desktop.gnome2.xsu.in bacula-2.2.4/scripts/bacula.desktop.gnome2.xsu.in
+--- bacula-2.2.4.orig/scripts/bacula.desktop.gnome2.xsu.in 2008-04-18 19:06:43.000000000 +0200
++++ bacula-2.2.4/scripts/bacula.desktop.gnome2.xsu.in 2008-10-10 23:32:44.000000000 +0200
+@@ -2,7 +2,7 @@
+ Name=Bacula Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/bacula.png
+-Exec=gnomesu -t "Query" -c "@sbindir@/bgnome-console -c @sysconfdir@/bgnome-console.conf" -d -e -m "In order to run the bacula console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Console needs to be run with superuser privileges' "@sbindir@/bgnome-console -c @sysconfdir@/bgnome-console.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+diff -urN bacula-2.2.4.orig/scripts/bat.desktop.xsu.in bacula-2.2.4/scripts/bat.desktop.xsu.in
+--- bacula-2.2.4.orig/scripts/bat.desktop.xsu.in 2008-04-29 15:48:18.000000000 +0200
++++ bacula-2.2.4/scripts/bat.desktop.xsu.in 2008-10-10 23:33:57.000000000 +0200
+@@ -2,7 +2,7 @@
+ Name=Bacula Administration Tool
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/bat_icon.png
+-Exec=gnomesu -t "Query" -c "@sbindir@/bat -c @sysconfdir@/bat.conf" -d -e -m "In order to run the bacula console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Administration Tool needs to be run with superuser privileges' "@sbindir@/bat -c @sysconfdir@/bat.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+diff -urN bacula-2.2.4.orig/scripts/wxconsole.desktop.xsu.in bacula-2.2.4/scripts/wxconsole.desktop.xsu.in
+--- bacula-2.2.4.orig/scripts/wxconsole.desktop.xsu.in 2008-04-29 15:11:37.000000000 +0200
++++ bacula-2.2.4/scripts/wxconsole.desktop.xsu.in 2008-10-10 23:34:06.000000000 +0200
+@@ -2,7 +2,7 @@
+ Name=Bacula WX Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/wxwin16x16.xpm
+-Exec=gnomesu -t "Query" -c "@sbindir@/bwx-console -c @sysconfdir@/bwx-console.conf" -d -e -m "In order to run the bacula wx console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula WX Console needs to be run with superuser privileges' "@sbindir@/bwx-console -c @sysconfdir@/bwx-console.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
diff --git a/app-backup/bacula/files/3.0.2/bacula-sd-conf b/app-backup/bacula/files/3.0.2/bacula-sd-conf
new file mode 100644
index 000000000000..ecc700206e1b
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-sd-conf
@@ -0,0 +1,11 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-sd-conf,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/app-backup/bacula/files/3.0.2/bacula-sd-init b/app-backup/bacula/files/3.0.2/bacula-sd-init
new file mode 100644
index 000000000000..714479cf93a3
--- /dev/null
+++ b/app-backup/bacula/files/3.0.2/bacula-sd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/3.0.2/bacula-sd-init,v 1.1 2009/09/09 07:45:17 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ eend $?
+}