summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-10 03:09:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-10 03:09:16 +0000
commitc8583dee105eefe6247ca13e62011502fcf04c94 (patch)
treefb263d854f60921d186110471bf06702bf17ba55 /app-arch
parentstable on alpha (diff)
downloadgentoo-2-c8583dee105eefe6247ca13e62011502fcf04c94.tar.gz
gentoo-2-c8583dee105eefe6247ca13e62011502fcf04c94.tar.bz2
gentoo-2-c8583dee105eefe6247ca13e62011502fcf04c94.zip
Add patch by Peter Beutner to fix handling of symlinks #80246 by Yuri Karaban.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cpio/ChangeLog8
-rw-r--r--app-arch/cpio/cpio-2.6-r2.ebuild41
-rw-r--r--app-arch/cpio/files/2.6-lstat.patch28
-rw-r--r--app-arch/cpio/files/digest-cpio-2.6-r21
4 files changed, 77 insertions, 1 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 83e5603907c0..7fa468998bff 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/cpio
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.17 2005/02/06 19:38:07 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.18 2005/02/10 03:09:16 vapier Exp $
+
+*cpio-2.6-r2 (09 Feb 2005)
+
+ 09 Feb 2005; Mike Frysinger <vapier@gentoo.org> +files/2.6-lstat.patch,
+ +cpio-2.6-r2.ebuild:
+ Add patch by Peter Beutner to fix handling of symlinks #80246 by Yuri Karaban.
06 Feb 2005; Joshua Kinard <kumba@gentoo.org> cpio-2.6-r1.ebuild:
Marked stable on mips.
diff --git a/app-arch/cpio/cpio-2.6-r2.ebuild b/app-arch/cpio/cpio-2.6-r2.ebuild
new file mode 100644
index 000000000000..3e9812c26566
--- /dev/null
+++ b/app-arch/cpio/cpio-2.6-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r2.ebuild,v 1.1 2005/02/10 03:09:16 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A file archival tool which can also read and write tar files"
+HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
+SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-rili-big-files.patch #68520
+ epatch "${FILESDIR}"/${PV}-isnumber.patch #74929
+ epatch "${FILESDIR}"/${PV}-umask.patch #79844
+ epatch "${FILESDIR}"/${PV}-lstat.patch #80246
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --bindir=/bin \
+ --with-rmt=/usr/sbin/rmt \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README INSTALL
+ rm -f "${D}"/usr/share/man/man1/mt.1
+ rmdir "${D}"/usr/libexec
+}
diff --git a/app-arch/cpio/files/2.6-lstat.patch b/app-arch/cpio/files/2.6-lstat.patch
new file mode 100644
index 000000000000..e9478d6af357
--- /dev/null
+++ b/app-arch/cpio/files/2.6-lstat.patch
@@ -0,0 +1,28 @@
+cpio is acting as if always invoked with -L (copy the file that a symlink
+points to, rather the symlink itself)
+reason: missing check for lstat function in configure script
+see: http://lists.gnu.org/archive/html/bug-cpio/2005-01/msg00003.html
+ http://bugs.gentoo.org/show_bug.cgi?id=80246
+
+--- cpio-2.6-orig/config.h.in
++++ cpio-2.6/config.h.in
+@@ -310,6 +310,9 @@
+ /* Define to 1 if you have the <unistd.h> header file. */
+ #undef HAVE_UNISTD_H
+
++/* Define to 1 if you have the `lstat' function. */
++#undef HAVE_LSTAT
++
+ /* Define to 1 if you have the <utime.h> header file. */
+ #undef HAVE_UTIME_H
+
+--- cpio-2.6-orig/configure
++++ cpio-2.6/configure
+@@ -1321,6 +1321,7 @@
+ gl_func_list="$gl_func_list iswprint"
+ gl_func_list="$gl_func_list mbsinit"
+ gl_header_list="$gl_header_list unistd.h"
++gl_func_list="$gl_func_list lstat"
+
+
+
diff --git a/app-arch/cpio/files/digest-cpio-2.6-r2 b/app-arch/cpio/files/digest-cpio-2.6-r2
new file mode 100644
index 000000000000..822d7f4e46f3
--- /dev/null
+++ b/app-arch/cpio/files/digest-cpio-2.6-r2
@@ -0,0 +1 @@
+MD5 25e0e8725bc60ed3460c9cde92752674 cpio-2.6.tar.bz2 448452