summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaarten Thibaut <murphy@gentoo.org>2002-04-19 23:17:27 +0000
committerMaarten Thibaut <murphy@gentoo.org>2002-04-19 23:17:27 +0000
commit9b3c7705fb2224e6104f52bf3f5d803a3ee4aa4c (patch)
tree558fcfef8edd902b556b15cb45a4f3df137f1280 /app-arch
parentFixing sparc support (diff)
downloadgentoo-2-9b3c7705fb2224e6104f52bf3f5d803a3ee4aa4c.tar.gz
gentoo-2-9b3c7705fb2224e6104f52bf3f5d803a3ee4aa4c.tar.bz2
gentoo-2-9b3c7705fb2224e6104f52bf3f5d803a3ee4aa4c.zip
Fixing sparc and other ports issue
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/files/digest-unzip-5.42-r11
-rw-r--r--app-arch/unzip/unzip-5.42-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/unzip/files/digest-unzip-5.42-r1 b/app-arch/unzip/files/digest-unzip-5.42-r1
new file mode 100644
index 000000000000..44a34ee9acf9
--- /dev/null
+++ b/app-arch/unzip/files/digest-unzip-5.42-r1
@@ -0,0 +1 @@
+MD5 4fc23bb7f3fb00ef6af35c5e77ede016 unzip542.tar.gz 1070770
diff --git a/app-arch/unzip/unzip-5.42-r1.ebuild b/app-arch/unzip/unzip-5.42-r1.ebuild
new file mode 100644
index 000000000000..2922bb79ba06
--- /dev/null
+++ b/app-arch/unzip/unzip-5.42-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.42-r1.ebuild,v 1.1 2002/04/19 23:17:27 murphy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Unzipper for pkzip-compressed files"
+SRC_URI="http://soft.ivanovo.ru/Linux/unzip542.tar.gz"
+
+HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ cp unix/Makefile unix/Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
+
+ case $ARCH in
+ i?.86) TARGET=linux ;;
+ *) TARGET=linux_noasm ;;
+ esac
+
+ try make -f unix/Makefile $TARGET
+
+}
+
+src_install() {
+
+ dobin unzip funzip unzipsfx unix/zipgrep
+ doman man/*.1
+ dodoc BUGS COPYING History* LICENSE README ToDo WHERE
+
+
+}
+
+
+