summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-10-17 13:46:28 +0000
committerPeter Volkov <pva@gentoo.org>2006-10-17 13:46:28 +0000
commit57eb520305ba02c739ddc3cda8828588ace8f7b6 (patch)
tree89fd73ec2d87b4aea77bc4113b1095de679e2c44 /app-arch
parentCleaned-up older versions. Added media-libs/imlib2 X support check. See bug #... (diff)
downloadgentoo-2-57eb520305ba02c739ddc3cda8828588ace8f7b6.tar.gz
gentoo-2-57eb520305ba02c739ddc3cda8828588ace8f7b6.tar.bz2
gentoo-2-57eb520305ba02c739ddc3cda8828588ace8f7b6.zip
Hopefully bug #151025 is fixed. Also removed herd tag from metadata.xml because we do not need to add herd tag if package does not belong to any herd.
(Portage version: 2.1.1)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/ChangeLog11
-rw-r--r--app-arch/rpm/files/digest-rpm-4.4.6-r23
-rw-r--r--app-arch/rpm/files/rpm-4.4.6-stupidness.patch108
-rw-r--r--app-arch/rpm/metadata.xml1
-rw-r--r--app-arch/rpm/rpm-4.4.6-r2.ebuild92
5 files changed, 167 insertions, 48 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 7d8d3cb98232..5b3c29509bc4 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.68 2006/10/16 03:18:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.69 2006/10/17 13:46:28 pva Exp $
+
+*rpm-4.4.6-r2 (17 Oct 2006)
+
+ 17 Oct 2006; Peter Volkov <pva@gentoo.org>
+ files/rpm-4.4.6-stupidness.patch, metadata.xml, -rpm-4.4.6-r1.ebuild,
+ +rpm-4.4.6-r2.ebuild:
+ Hopefully bug #151025 is fixed. Also removed herd tag from metadata.xml
+ because we do not need to add herd tag if package does not belong to any
+ herd.
*rpm-4.4.6-r1 (16 Oct 2006)
diff --git a/app-arch/rpm/files/digest-rpm-4.4.6-r2 b/app-arch/rpm/files/digest-rpm-4.4.6-r2
new file mode 100644
index 000000000000..8dae251f56e0
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-4.4.6-r2
@@ -0,0 +1,3 @@
+MD5 baa6f371446c65b4080d1cd1f194a7ae rpm-4.4.6.tar.gz 17157249
+RMD160 6b433d20a63fb2542244ae62eff0a8b5fe290439 rpm-4.4.6.tar.gz 17157249
+SHA256 1e1da50af2b9dfe34c79315eae7520e7e57087671e17ce26107d779ae2b0b595 rpm-4.4.6.tar.gz 17157249
diff --git a/app-arch/rpm/files/rpm-4.4.6-stupidness.patch b/app-arch/rpm/files/rpm-4.4.6-stupidness.patch
index 72828dbe41e3..f1f497edb57f 100644
--- a/app-arch/rpm/files/rpm-4.4.6-stupidness.patch
+++ b/app-arch/rpm/files/rpm-4.4.6-stupidness.patch
@@ -1,7 +1,21 @@
-Try and disable over-engineering in the rpm build system.
-
---- configure.ac
-+++ configure.ac
+diff -Naur rpm-4.4.6.orig/build/Makefile.am rpm-4.4.6/build/Makefile.am
+--- rpm-4.4.6.orig/build/Makefile.am 2005-09-16 19:43:35.000000000 +0400
++++ rpm-4.4.6/build/Makefile.am 2006-10-17 17:02:39.000000000 +0400
+@@ -24,10 +24,7 @@
+ pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h
+ noinst_HEADERS = buildio.h
+
+-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
+-
+-usrlibdir = $(libdir)@MARK64@
+-usrlib_LTLIBRARIES = librpmbuild.la
++lib_LTLIBRARIES = librpmbuild.la
+ librpmbuild_la_SOURCES = \
+ build.c expression.c files.c misc.c names.c pack.c \
+ parseBuildInstallClean.c parseChangelog.c parseDescription.c \
+diff -Naur rpm-4.4.6.orig/configure.ac rpm-4.4.6/configure.ac
+--- rpm-4.4.6.orig/configure.ac 2006-10-17 17:02:14.000000000 +0400
++++ rpm-4.4.6/configure.ac 2006-10-17 17:03:12.000000000 +0400
@@ -117,7 +117,7 @@
dnl
with_selinuxval=no
@@ -37,17 +51,42 @@ Try and disable over-engineering in the rpm build system.
AC_SUBST(MARK64)
# For some systems we know that we have ld_version scripts.
-@@ -1363,7 +1363,7 @@
+@@ -1368,13 +1358,16 @@
+ else
+ usrprefix=$prefix
+ fi
++
++test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
++
+ LOCALEDIR="`echo ${usrprefix}/share/locale`"
+ AC_DEFINE_UNQUOTED(LOCALEDIR, "$LOCALEDIR",
+ [Full path to rpm locale directory (usually /usr/share/locale)])
AC_SUBST(LOCALEDIR)
LIBDIR="`echo $libdir | sed 's-/lib$-/%{_lib}-'`"
AC_SUBST(LIBDIR)
-RPMCONFIGDIR="`echo ${usrprefix}/lib/rpm`"
-+RPMCONFIGDIR="`echo ${libdir}/rpm`"
++RPMCONFIGDIR="`eval eval echo ${libdir}/rpm`"
AC_DEFINE_UNQUOTED(RPMCONFIGDIR, "$RPMCONFIGDIR",
[Full path to rpm global configuration directory (usually /usr/lib/rpm)])
AC_SUBST(RPMCONFIGDIR)
---- python/Makefile.am
-+++ python/Makefile.am
+diff -Naur rpm-4.4.6.orig/lib/Makefile.am rpm-4.4.6/lib/Makefile.am
+--- rpm-4.4.6.orig/lib/Makefile.am 2006-04-06 23:37:07.000000000 +0400
++++ rpm-4.4.6/lib/Makefile.am 2006-10-17 17:02:39.000000000 +0400
+@@ -29,10 +29,7 @@
+ mylibs = librpm.la
+ LIBS =
+
+-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
+-
+-usrlibdir = $(libdir)@MARK64@
+-usrlib_LTLIBRARIES = librpm.la
++lib_LTLIBRARIES = librpm.la
+ librpm_la_SOURCES = \
+ cpio.c depends.c formats.c fs.c fsm.c getdate.c \
+ manifest.c misc.c package.c \
+diff -Naur rpm-4.4.6.orig/python/Makefile.am rpm-4.4.6/python/Makefile.am
+--- rpm-4.4.6.orig/python/Makefile.am 2006-02-12 20:16:50.000000000 +0300
++++ rpm-4.4.6/python/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -4,8 +4,8 @@
LINT = splint
@@ -59,8 +98,9 @@ Try and disable over-engineering in the rpm build system.
SUBDIRS = rpm
---- python/rpm/Makefile.am
-+++ python/rpm/Makefile.am
+diff -Naur rpm-4.4.6.orig/python/rpm/Makefile.am rpm-4.4.6/python/rpm/Makefile.am
+--- rpm-4.4.6.orig/python/rpm/Makefile.am 2004-10-20 01:33:22.000000000 +0400
++++ rpm-4.4.6/python/rpm/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -4,8 +4,8 @@
PYVER = @WITH_PYTHON_VERSION@
@@ -72,36 +112,9 @@ Try and disable over-engineering in the rpm build system.
EXTRA_DIST = \
__init__.py
---- lib/Makefile.am
-+++ lib/Makefile.am
-@@ -29,10 +29,7 @@
- mylibs = librpm.la
- LIBS =
-
--LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
--
--usrlibdir = $(libdir)@MARK64@
--usrlib_LTLIBRARIES = librpm.la
-+lib_LTLIBRARIES = librpm.la
- librpm_la_SOURCES = \
- cpio.c depends.c formats.c fs.c fsm.c getdate.c \
- manifest.c misc.c package.c \
---- build/Makefile.am
-+++ build/Makefile.am
-@@ -24,10 +24,7 @@
- pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h
- noinst_HEADERS = buildio.h
-
--LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
--
--usrlibdir = $(libdir)@MARK64@
--usrlib_LTLIBRARIES = librpmbuild.la
-+lib_LTLIBRARIES = librpmbuild.la
- librpmbuild_la_SOURCES = \
- build.c expression.c files.c misc.c names.c pack.c \
- parseBuildInstallClean.c parseChangelog.c parseDescription.c \
---- rpmdb/Makefile.am
-+++ rpmdb/Makefile.am
+diff -Naur rpm-4.4.6.orig/rpmdb/Makefile.am rpm-4.4.6/rpmdb/Makefile.am
+--- rpm-4.4.6.orig/rpmdb/Makefile.am 2006-03-25 03:40:36.000000000 +0300
++++ rpm-4.4.6/rpmdb/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -41,11 +41,7 @@
# XXX watchout, ../db3/libdb.la created by this Makefile may surprise
libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la
@@ -115,8 +128,9 @@ Try and disable over-engineering in the rpm build system.
librpmdb_la_SOURCES = \
dbconfig.c fprint.c \
hdrNVR.c header.c header_internal.c legacy.c merge.c \
---- rpmio/Makefile.am
-+++ rpmio/Makefile.am
+diff -Naur rpm-4.4.6.orig/rpmio/Makefile.am rpm-4.4.6/rpmio/Makefile.am
+--- rpm-4.4.6.orig/rpmio/Makefile.am 2006-04-01 14:30:16.000000000 +0400
++++ rpm-4.4.6/rpmio/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -26,10 +26,7 @@
BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs)
@@ -129,8 +143,9 @@ Try and disable over-engineering in the rpm build system.
librpmio_la_SOURCES = \
argv.c digest.c fts.c macro.c rmd128.c rmd160.c rpmdav.c \
rpmhook.c rpmio.c rpmlog.c rpmlua.c rpmmalloc.c \
---- scripts/Makefile.am
-+++ scripts/Makefile.am
+diff -Naur rpm-4.4.6.orig/scripts/Makefile.am rpm-4.4.6/scripts/Makefile.am
+--- rpm-4.4.6.orig/scripts/Makefile.am 2005-11-14 16:29:48.000000000 +0300
++++ rpm-4.4.6/scripts/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -25,7 +25,7 @@
all:
@@ -140,8 +155,9 @@ Try and disable over-engineering in the rpm build system.
config_SCRIPTS = \
brp-compress brp-python-bytecompile brp-java-gcjcompile brp-redhat \
brp-strip brp-strip-comment-note brp-nobuildrootpath \
---- tools/Makefile.am
-+++ tools/Makefile.am
+diff -Naur rpm-4.4.6.orig/tools/Makefile.am rpm-4.4.6/tools/Makefile.am
+--- rpm-4.4.6.orig/tools/Makefile.am 2005-11-17 23:18:01.000000000 +0300
++++ rpm-4.4.6/tools/Makefile.am 2006-10-17 17:02:39.000000000 +0400
@@ -49,10 +49,6 @@
#rpmdeps_LDFLAGS = $(staticLDFLAGS)
rpmdeps_LDADD = $(top_builddir)/build/librpmbuild.la
diff --git a/app-arch/rpm/metadata.xml b/app-arch/rpm/metadata.xml
index 54494c4bb860..d9cd2cad66c2 100644
--- a/app-arch/rpm/metadata.xml
+++ b/app-arch/rpm/metadata.xml
@@ -1,7 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
<maintainer>
<email>maintainer-needed@gentoo.org</email>
</maintainer>
diff --git a/app-arch/rpm/rpm-4.4.6-r2.ebuild b/app-arch/rpm/rpm-4.4.6-r2.ebuild
new file mode 100644
index 000000000000..6889d564169d
--- /dev/null
+++ b/app-arch/rpm/rpm-4.4.6-r2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r2.ebuild,v 1.1 2006/10/17 13:46:28 pva Exp $
+
+inherit eutils autotools distutils perl-module
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm.org/"
+SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls python perl doc sqlite"
+
+RDEPEND="=sys-libs/db-3.2*
+ >=sys-libs/zlib-1.1.3
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-libs/beecrypt-3.1.0-r1
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( >=dev-lang/perl-5.8.8 )
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3.3.5 )
+ net-misc/neon"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-stupidness.patch
+
+ # the following are additional libraries that might be packaged with
+ # the rpm sources. grep for "test -d" in configure.ac
+ cp file/src/{file,patchlevel}.h tools/
+ rm -rf beecrypt elfutils neon popt sqlite zlib intl file
+
+ sed -i -e "s:intl ::" Makefile.am
+ sed -i -e "s:intl/Makefile ::" configure.ac
+ AT_NO_RECURSIVE="yes" eautoreconf
+ # TODO Get rid of internal copies of file, lua, db and db3
+}
+
+src_compile() {
+ python_version
+ econf \
+ --enable-posixmutexes \
+ --without-javaglue \
+ --without-selinux \
+ $(use_with python python ${PYVER}) \
+ $(use_with doc apidocs) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}"/bin/rpm "${D}"/usr/bin
+ rmdir "${D}"/bin
+
+ use nls || rm -rf "${D}"/usr/share/man/??
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CHANGES CREDITS GROUPS README* RPM*
+ use doc && dohtml -r apidocs/html/*
+
+ # Fix perllocal.pod file collision
+ use perl && fixlocalpod
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${ROOT}"/usr/bin/rpm --rebuilddb --root=${ROOT}
+ else
+ einfo "No RPM database found... Creating database..."
+ "${ROOT}"/usr/bin/rpm --initdb --root=${ROOT}
+ fi
+
+ distutils_pkg_postinst
+}