summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-06 01:15:23 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-06 01:15:23 +0000
commit0dd763f66ab81f7215dcd11608f75937bf32d3eb (patch)
treefc42293bb8642c73a46544ff89f21875ed2c94ac /app-arch
parentVersion Bump. Remove old versions. (diff)
downloadgentoo-2-0dd763f66ab81f7215dcd11608f75937bf32d3eb.tar.gz
gentoo-2-0dd763f66ab81f7215dcd11608f75937bf32d3eb.tar.bz2
gentoo-2-0dd763f66ab81f7215dcd11608f75937bf32d3eb.zip
Version bump.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/ChangeLog9
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.113
-rw-r--r--app-arch/gzip/gzip-1.3.11.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 0f04bc4e110e..94a1d4883156 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/gzip
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.74 2006/12/31 11:17:56 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.75 2007/02/06 01:15:23 vapier Exp $
+
+*gzip-1.3.11 (06 Feb 2007)
+
+ 06 Feb 2007; Mike Frysinger <vapier@gentoo.org> +gzip-1.3.11.ebuild:
+ Version bump.
*gzip-1.3.10 (31 Dec 2006)
diff --git a/app-arch/gzip/files/digest-gzip-1.3.11 b/app-arch/gzip/files/digest-gzip-1.3.11
new file mode 100644
index 000000000000..aef70cc8bc07
--- /dev/null
+++ b/app-arch/gzip/files/digest-gzip-1.3.11
@@ -0,0 +1,3 @@
+MD5 a41a6a4b11f941cb7fc13df320f3af5f gzip-1.3.11.tar.gz 431721
+RMD160 7bb4566728bf5836547a8de3b5cdf02ef4e60887 gzip-1.3.11.tar.gz 431721
+SHA256 d185067bf198bc6213402a76b95fbffe9772a592b006f58bf8b89b4b5511cd56 gzip-1.3.11.tar.gz 431721
diff --git a/app-arch/gzip/gzip-1.3.11.ebuild b/app-arch/gzip/gzip-1.3.11.ebuild
new file mode 100644
index 000000000000..cbec7fead8cf
--- /dev/null
+++ b/app-arch/gzip/gzip-1.3.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.11.ebuild,v 1.1 2007/02/06 01:15:23 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
+ mirror://gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static pic"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
+ dosym /bin/gunzip /usr/bin/gunzip || die
+}