summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-11 21:05:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-11 21:05:45 +0000
commit007abe9a96d3cd8bca8c3436ba88b16ce8ff6e43 (patch)
tree7e8fa935b056c257399d5ba95c6788fc016497e6 /app-arch
parentFix yacc command line (#247717). (diff)
downloadgentoo-2-007abe9a96d3cd8bca8c3436ba88b16ce8ff6e43.tar.gz
gentoo-2-007abe9a96d3cd8bca8c3436ba88b16ce8ff6e43.tar.bz2
gentoo-2-007abe9a96d3cd8bca8c3436ba88b16ce8ff6e43.zip
GCC4.3 compile fix per bug #250603. Repoman cleanup.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/hardlink++/ChangeLog8
-rw-r--r--app-arch/hardlink++/files/hardlink++-0.02-gcc-43-compile-fix.patch11
-rw-r--r--app-arch/hardlink++/hardlink++-0.02.ebuild9
3 files changed, 22 insertions, 6 deletions
diff --git a/app-arch/hardlink++/ChangeLog b/app-arch/hardlink++/ChangeLog
index 525a8acd8c05..4b7eef40e585 100644
--- a/app-arch/hardlink++/ChangeLog
+++ b/app-arch/hardlink++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/hardlink++
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/ChangeLog,v 1.4 2007/02/08 20:58:36 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/ChangeLog,v 1.5 2008/12/11 21:05:44 robbat2 Exp $
+
+ 11 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/hardlink++-0.02-gcc-43-compile-fix.patch, hardlink++-0.02.ebuild:
+ GCC4.3 compile fix per bug #250603. Repoman cleanup.
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-arch/hardlink++/files/hardlink++-0.02-gcc-43-compile-fix.patch b/app-arch/hardlink++/files/hardlink++-0.02-gcc-43-compile-fix.patch
new file mode 100644
index 000000000000..09615f017f65
--- /dev/null
+++ b/app-arch/hardlink++/files/hardlink++-0.02-gcc-43-compile-fix.patch
@@ -0,0 +1,11 @@
+diff -Nuar hardlink++-0.02/hardlink.h
+--- hardlink++-0.02.orig/hardlink.h 2008-12-11 12:57:24.563543862 -0800
++++ hardlink++-0.02/hardlink.h 2008-12-11 13:02:56.091753425 -0800
+@@ -39,6 +39,7 @@
+
+ // C includes
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <dirent.h>
+ #include <sys/stat.h>
+
diff --git a/app-arch/hardlink++/hardlink++-0.02.ebuild b/app-arch/hardlink++/hardlink++-0.02.ebuild
index 7abd5bdd5be9..68cd3a73ac9e 100644
--- a/app-arch/hardlink++/hardlink++-0.02.ebuild
+++ b/app-arch/hardlink++/hardlink++-0.02.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/hardlink++-0.02.ebuild,v 1.3 2005/10/17 00:11:59 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/hardlink++-0.02.ebuild,v 1.4 2008/12/11 21:05:44 robbat2 Exp $
inherit eutils
DESCRIPTION="Save disk space by hardlinking identical files."
@@ -15,8 +15,9 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-gcc34-optimize-help.patch || die
- epatch ${FILESDIR}/${P}-sane-makefile.patch || die
+ epatch "${FILESDIR}"/${P}-gcc34-optimize-help.patch || die
+ epatch "${FILESDIR}"/${P}-sane-makefile.patch || die
+ epatch "${FILESDIR}"/${P}-gcc-43-compile-fix.patch || die
}
src_compile() {