summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-18 20:43:23 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-18 20:43:23 +0000
commit7cb8836716a3c180789dae4cee1b705a81fb25bc (patch)
tree26dcfc5f6b4b4b9105caca04de4cbabf26cb365b /app-arch/zopfli
parentVersion bump. Remove old. Drop ~sparc-fbsd keyword. (diff)
downloadgentoo-2-7cb8836716a3c180789dae4cee1b705a81fb25bc.tar.gz
gentoo-2-7cb8836716a3c180789dae4cee1b705a81fb25bc.tar.bz2
gentoo-2-7cb8836716a3c180789dae4cee1b705a81fb25bc.zip
New ebuild for app-arch/zopfli, a compression library programmed in C to perform very good, but slow, deflate or zlib compression. Proxied commit for Alex Xu, which will proxy maintain this package; fixes bug #481492.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-arch/zopfli')
-rw-r--r--app-arch/zopfli/ChangeLog12
-rw-r--r--app-arch/zopfli/metadata.xml11
-rw-r--r--app-arch/zopfli/zopfli-1.0.0.ebuild34
-rw-r--r--app-arch/zopfli/zopfli-1.0.0_p20130508.ebuild47
4 files changed, 104 insertions, 0 deletions
diff --git a/app-arch/zopfli/ChangeLog b/app-arch/zopfli/ChangeLog
new file mode 100644
index 000000000000..a33af913c07b
--- /dev/null
+++ b/app-arch/zopfli/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-arch/zopfli
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/ChangeLog,v 1.1 2013/09/18 20:43:23 tomwij Exp $
+
+*zopfli-1.0.0_p20130508 (18 Sep 2013)
+*zopfli-1.0.0 (18 Sep 2013)
+
+ 18 Sep 2013; Tom Wijsman <TomWij@gentoo.org> +metadata.xml,
+ +zopfli-1.0.0.ebuild, +zopfli-1.0.0_p20130508.ebuild:
+ New ebuild for app-arch/zopfli, a compression library programmed in C to
+ perform very good, but slow, deflate or zlib compression. Proxied commit for
+ Alex Xu, which will proxy maintain this package; fixes bug #481492.
diff --git a/app-arch/zopfli/metadata.xml b/app-arch/zopfli/metadata.xml
new file mode 100644
index 000000000000..68ea4231c910
--- /dev/null
+++ b/app-arch/zopfli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ <description>Proxied maintainer</description>
+</maintainer>
+<herd>proxy-maintainers</herd>
+<longdescription>Compression library programmed in C to perform very good, but slow, deflate or zlib compression.</longdescription>
+</pkgmetadata>
diff --git a/app-arch/zopfli/zopfli-1.0.0.ebuild b/app-arch/zopfli/zopfli-1.0.0.ebuild
new file mode 100644
index 000000000000..8f515669d252
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/zopfli-1.0.0.ebuild,v 1.1 2013/09/18 20:43:23 tomwij Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compression library programmed in C to perform very good, but slow, deflate or zlib compression."
+HOMEPAGE="https://code.google.com/p/zopfli/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-arch/unzip"
+
+src_compile() {
+ # Show what we run for a more verbose build log.
+ local command="$(tc-getCC) src/${PN}/*.c -o ${PN} \
+ -W -Wall -Wextra -ansi -pedantic -lm ${CFLAGS} ${LDFLAGS}"
+
+ echo ${command} ; ${command} || die "Compilation failed."
+}
+
+src_install() {
+ dobin ${PN}
+
+ dodoc README CONTRIBUTORS
+
+ insinto /usr/include/${PN}/
+ doins src/${PN}/*.h
+}
diff --git a/app-arch/zopfli/zopfli-1.0.0_p20130508.ebuild b/app-arch/zopfli/zopfli-1.0.0_p20130508.ebuild
new file mode 100644
index 000000000000..cff5607a4251
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.0_p20130508.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/zopfli-1.0.0_p20130508.ebuild,v 1.1 2013/09/18 20:43:23 tomwij Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+COMMIT="c54dc204ef4278f949a965dc90e693799b6aae41"
+SONAME="1"
+
+DESCRIPTION="Compression library programmed in C to perform very good, but slow, deflate or zlib compression."
+HOMEPAGE="https://code.google.com/p/zopfli/"
+SRC_URI="https://${PN}.googlecode.com/archive/${COMMIT}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0/${SONAME}"
+KEYWORDS="~amd64"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}-${COMMIT:0:12}"
+
+src_compile() {
+ local target
+ for target in lib${PN} ${PN} ${PN}png; do
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS="-W -Wall -Wextra -ansi -pedantic -lm ${CFLAGS}" \
+ CXXFLAGS="-W -Wall -Wextra -ansi -pedantic ${CXXFLAGS}" \
+ ${target}
+ done
+}
+
+src_install() {
+ dobin ${PN} ${PN}png
+
+ dodoc CONTRIBUTORS README README.${PN}png
+
+ dolib lib${PN}.so.*
+ dosym lib${PN}.so.* /usr/$(get_libdir)/lib${PN}.so
+ dosym lib${PN}.so.* /usr/$(get_libdir)/lib${PN}.so.${SONAME}
+
+ insinto /usr/include/${PN}/
+ doins src/${PN}/*.h
+}