summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-24 12:44:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-24 12:44:49 +0000
commit494b834f78b9bca00e9441dda43e19f1d60d68e1 (patch)
tree0c634707f0d40430cbad1e8374f88ae68733682a /app-arch/xarchiver
parentAdd support for weak blockers, fix eselect compatibility. Cleanse older vers... (diff)
downloadgentoo-2-494b834f78b9bca00e9441dda43e19f1d60d68e1.tar.gz
gentoo-2-494b834f78b9bca00e9441dda43e19f1d60d68e1.tar.bz2
gentoo-2-494b834f78b9bca00e9441dda43e19f1d60d68e1.zip
Escape path(s) for drag and drop wrt #262519 by Jaromír Cápík and Zsolt Fabok
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/ChangeLog12
-rw-r--r--app-arch/xarchiver/files/xarchiver-0.5.2-drag-n-drop_escaped_path.patch15
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.2-r3.ebuild55
3 files changed, 80 insertions, 2 deletions
diff --git a/app-arch/xarchiver/ChangeLog b/app-arch/xarchiver/ChangeLog
index 5fe913031208..dbd22b010dd1 100644
--- a/app-arch/xarchiver/ChangeLog
+++ b/app-arch/xarchiver/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/xarchiver
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/ChangeLog,v 1.31 2011/01/25 18:07:17 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/ChangeLog,v 1.32 2012/01/24 12:44:49 ssuominen Exp $
+
+*xarchiver-0.5.2-r3 (24 Jan 2012)
+
+ 24 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xarchiver-0.5.2-r3.ebuild,
+ +files/xarchiver-0.5.2-drag-n-drop_escaped_path.patch:
+ Escape path(s) for drag and drop wrt #262519 by Jaromír Cápík and Zsolt
+ Fabok
25 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> xarchiver-0.5.2-r2.ebuild:
ppc64 stable wrt #349022
diff --git a/app-arch/xarchiver/files/xarchiver-0.5.2-drag-n-drop_escaped_path.patch b/app-arch/xarchiver/files/xarchiver-0.5.2-drag-n-drop_escaped_path.patch
new file mode 100644
index 000000000000..ff0d928b935c
--- /dev/null
+++ b/app-arch/xarchiver/files/xarchiver-0.5.2-drag-n-drop_escaped_path.patch
@@ -0,0 +1,15 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=5187
+http://bugs.gentoo.org/show_bug.cgi?id=262519
+
+--- src/window.c
++++ src/window.c
+@@ -1724,6 +1724,9 @@
+ gtk_tree_selection_selected_foreach (selection,(GtkTreeSelectionForeachFunc) xa_concat_selected_filenames,&names);
+ archive->full_path = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON (extract_window->extract_full));
+ archive->overwrite = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON (extract_window->overwrite_check));
++ gchar *unescaped_extraction_path = archive->extraction_path;
++ archive->extraction_path = xa_escape_filename(unescaped_extraction_path, "$'`\"\\!?* ()[]&|:;<>#");
++ g_free(unescaped_extraction_path);
+ (*archive->extract) (archive,names);
+
+ g_list_foreach (row_list,(GFunc) gtk_tree_path_free,NULL);
diff --git a/app-arch/xarchiver/xarchiver-0.5.2-r3.ebuild b/app-arch/xarchiver/xarchiver-0.5.2-r3.ebuild
new file mode 100644
index 000000000000..6ab4b444adc9
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.2-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/xarchiver-0.5.2-r3.ebuild,v 1.1 2012/01/24 12:44:49 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="a GTK+ based and advanced archive manager that can be used with Thunar"
+HOMEPAGE="http://xarchiver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.10:2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-stack-smash.patch
+ "${FILESDIR}"/${P}-add_xz_support.patch
+ "${FILESDIR}"/${P}-drag-n-drop_escaped_path.patch
+ )
+
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/COPYING/d' doc/Makefile.in || die
+ xfconf_src_prepare
+}
+
+src_install() {
+ xfconf_src_install DOCDIR="${ED}/usr/share/doc/${PF}"
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ elog "You need external programs for some formats, including"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/unarj app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}