summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-09 10:01:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-09 10:01:59 +0000
commit84efe8a7f66b8a84d57876c25d5aa8b5616e131c (patch)
tree912cfc3ed4b102fb47e8c4b6213da39c0a774088 /app-arch/unzip
parent*** empty log message *** (diff)
downloadgentoo-2-84efe8a7f66b8a84d57876c25d5aa8b5616e131c.tar.gz
gentoo-2-84efe8a7f66b8a84d57876c25d5aa8b5616e131c.tar.bz2
gentoo-2-84efe8a7f66b8a84d57876c25d5aa8b5616e131c.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/files/digest-unzip-5.41-r21
-rw-r--r--app-arch/unzip/unzip-5.41-r2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/unzip/files/digest-unzip-5.41-r2 b/app-arch/unzip/files/digest-unzip-5.41-r2
new file mode 100644
index 000000000000..4b17b6c9dd99
--- /dev/null
+++ b/app-arch/unzip/files/digest-unzip-5.41-r2
@@ -0,0 +1 @@
+MD5 d5fb7ca068da949765abb8c6bc71666e unzip541.tar.gz
diff --git a/app-arch/unzip/unzip-5.41-r2.ebuild b/app-arch/unzip/unzip-5.41-r2.ebuild
new file mode 100644
index 000000000000..a01a6f0214f2
--- /dev/null
+++ b/app-arch/unzip/unzip-5.41-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.41-r2.ebuild,v 1.1 2001/02/09 10:01:59 achim Exp $
+
+A=unzip541.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Unzipper for pkzip-compressed files"
+SRC_URI="ftp://ftp.freesoftware.com/pub/infozip/src/${A}"
+HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cp unix/Makefile unix/Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
+
+ try make -f unix/Makefile linux
+
+}
+
+src_install() {
+
+ dobin unzip funzip unzipsfx unix/zipgrep
+ doman man/*.1
+ dodoc BUGS COPYING History* LICENSE README ToDo WHERE
+
+
+}
+
+
+