summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-27 03:23:28 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-27 03:23:28 +0000
commit7f709363a6e0b13992078317326d88239eb5ef84 (patch)
tree356049cd9af09054ab3118cfe8d3e2b1fefa9b5c /app-arch/tar
parentFix homepage, bug #252367 by Thomas Pani. Tweak metadata.xml a bit (diff)
downloadgentoo-2-7f709363a6e0b13992078317326d88239eb5ef84.tar.gz
gentoo-2-7f709363a6e0b13992078317326d88239eb5ef84.tar.bz2
gentoo-2-7f709363a6e0b13992078317326d88239eb5ef84.zip
old
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/files/tar-1.19-gnu-inline.patch139
-rw-r--r--app-arch/tar/files/tar-1.19-update-flag.patch102
-rw-r--r--app-arch/tar/tar-1.19-r1.ebuild69
3 files changed, 0 insertions, 310 deletions
diff --git a/app-arch/tar/files/tar-1.19-gnu-inline.patch b/app-arch/tar/files/tar-1.19-gnu-inline.patch
deleted file mode 100644
index 0057b8da4f69..000000000000
--- a/app-arch/tar/files/tar-1.19-gnu-inline.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-http://bugs.gentoo.org/198817
-
-from upstream gnulib for "extern inline" changes
-
-diff --git a/lib/argp-fmtstream.h b/lib/argp-fmtstream.h
-index 93fa651..50f1387 100644
---- a/lib/argp-fmtstream.h
-+++ b/lib/argp-fmtstream.h
-@@ -1,5 +1,5 @@
- /* Word-wrapping and line-truncating streams.
-- Copyright (C) 1997, 2006 Free Software Foundation, Inc.
-+ Copyright (C) 1997, 2006-2007 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Written by Miles Bader <miles@gnu.ai.mit.edu>.
-
-@@ -134,6 +134,7 @@ extern ssize_t argp_fmtstream_printf (argp_fmtstream_t __fs,
- const char *__fmt, ...)
- __attribute__ ((__format__ (printf, 2, 3)));
-
-+#if _LIBC || !defined __OPTIMIZE__
- extern int __argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
- extern int argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
-
-@@ -144,6 +145,7 @@ extern size_t __argp_fmtstream_write (argp_fmtstream_t __fs,
- const char *__str, size_t __len);
- extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
- const char *__str, size_t __len);
-+#endif
-
- /* Access macros for various bits of state. */
- #define argp_fmtstream_lmargin(__fs) ((__fs)->lmargin)
-@@ -153,6 +155,7 @@ extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
- #define __argp_fmtstream_rmargin argp_fmtstream_rmargin
- #define __argp_fmtstream_wmargin argp_fmtstream_wmargin
-
-+#if _LIBC || !defined __OPTIMIZE__
- /* Set __FS's left margin to LMARGIN and return the old value. */
- extern size_t argp_fmtstream_set_lmargin (argp_fmtstream_t __fs,
- size_t __lmargin);
-@@ -174,6 +177,7 @@ extern size_t __argp_fmtstream_set_wmargin (argp_fmtstream_t __fs,
- /* Return the column number of the current output point in __FS. */
- extern size_t argp_fmtstream_point (argp_fmtstream_t __fs);
- extern size_t __argp_fmtstream_point (argp_fmtstream_t __fs);
-+#endif
-
- /* Internal routines. */
- extern void _argp_fmtstream_update (argp_fmtstream_t __fs);
-@@ -197,7 +201,28 @@ extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
- #endif
-
- #ifndef ARGP_FS_EI
--#define ARGP_FS_EI extern inline
-+# ifdef __GNUC__
-+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
-+ inline semantics, unless -fgnu89-inline is used. It defines a macro
-+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
-+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
-+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
-+ semantics but warns, unless -fgnu89-inline is used:
-+ warning: C99 inline functions are not supported; using GNU89
-+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
-+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
-+# if defined __GNUC_STDC_INLINE__
-+# define ARGP_FS_EI inline
-+# elif defined __GNUC_GNU_INLINE__
-+# define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
-+# else
-+# define ARGP_FS_EI extern inline
-+# endif
-+# else
-+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
-+ the compiler supports 'inline' at all. */
-+# define ARGP_FS_EI inline
-+# endif
- #endif
-
- ARGP_FS_EI size_t
-diff --git a/lib/argp.h b/lib/argp.h
-index fb11de6..aa76eb4 100644
---- a/lib/argp.h
-+++ b/lib/argp.h
-@@ -520,9 +520,11 @@ extern void __argp_state_help (const struct argp_state *__restrict __state,
- FILE *__restrict __stream,
- unsigned int __flags);
-
-+#if _LIBC || !defined __USE_EXTERN_INLINES
- /* Possibly output the standard usage message for ARGP to stderr and exit. */
- extern void argp_usage (const struct argp_state *__state);
- extern void __argp_usage (const struct argp_state *__state);
-+#endif
-
- /* If appropriate, print the printf string FMT and following args, preceded
- by the program name and `:', to stderr, and followed by a `Try ... --help'
-@@ -551,6 +553,7 @@ extern void __argp_failure (const struct argp_state *__restrict __state,
- const char *__restrict __fmt, ...)
- __attribute__ ((__format__ (__printf__, 4, 5)));
-
-+#if _LIBC || !defined __USE_EXTERN_INLINES
- /* Returns true if the option OPT is a valid short option. */
- extern int _option_is_short (const struct argp_option *__opt) __THROW;
- extern int __option_is_short (const struct argp_option *__opt) __THROW;
-@@ -559,6 +562,7 @@ extern int __option_is_short (const struct argp_option *__opt) __THROW;
- options array. */
- extern int _option_is_end (const struct argp_option *__opt) __THROW;
- extern int __option_is_end (const struct argp_option *__opt) __THROW;
-+#endif
-
- /* Return the input field for ARGP in the parser corresponding to STATE; used
- by the help routines. */
-@@ -579,7 +583,28 @@ extern void *__argp_input (const struct argp *__restrict __argp,
- # endif
-
- # ifndef ARGP_EI
--# define ARGP_EI extern __inline__
-+# ifdef __GNUC__
-+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
-+ inline semantics, unless -fgnu89-inline is used. It defines a macro
-+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
-+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
-+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
-+ semantics but warns, unless -fgnu89-inline is used:
-+ warning: C99 inline functions are not supported; using GNU89
-+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
-+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
-+# if defined __GNUC_STDC_INLINE__
-+# define ARGP_EI __inline__
-+# elif defined __GNUC_GNU_INLINE__
-+# define ARGP_EI extern __inline__ __attribute__ ((__gnu_inline__))
-+# else
-+# define ARGP_EI extern __inline__
-+# endif
-+# else
-+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
-+ the compiler supports 'inline' at all. */
-+# define ARGP_EI inline
-+# endif
- # endif
-
- ARGP_EI void
diff --git a/app-arch/tar/files/tar-1.19-update-flag.patch b/app-arch/tar/files/tar-1.19-update-flag.patch
deleted file mode 100644
index 09f6df947951..000000000000
--- a/app-arch/tar/files/tar-1.19-update-flag.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-http://bugs.gentoo.org/200315
-
-2007-12-05 Sergey Poznyakoff <gray@gnu.org.ua>
-
- * src/buffer.c (check_compressed_archive): Do not bail out if the
- file is too short, set boolean flag, passed as an argument
- instead. This fixes a bug introduced on 2007-08-24. See also
- tests/shortupd.at.
-
-Index: src/buffer.c
-===================================================================
-RCS file: /cvsroot/tar/tar/src/buffer.c,v
-retrieving revision 1.115
-retrieving revision 1.116
-diff -u -p -r1.115 -r1.116
---- src/buffer.c 31 Oct 2007 13:10:55 -0000 1.115
-+++ src/buffer.c 5 Dec 2007 09:45:22 -0000 1.116
-@@ -229,19 +229,21 @@ static struct zip_magic const magic[] =
-
- /* Check if the file ARCHIVE is a compressed archive. */
- enum compress_type
--check_compressed_archive ()
-+check_compressed_archive (bool *pshort)
- {
- struct zip_magic const *p;
- bool sfr;
-- bool short_file = false;
-+ bool temp;
-+
-+ if (!pshort)
-+ pshort = &temp;
-
- /* Prepare global data needed for find_next_block: */
- record_end = record_start; /* set up for 1st record = # 0 */
- sfr = read_full_records;
- read_full_records = true; /* Suppress fatal error on reading a partial
- record */
-- if (find_next_block () == 0)
-- short_file = true;
-+ *pshort = find_next_block () == 0;
-
- /* Restore global values */
- read_full_records = sfr;
-@@ -254,9 +256,6 @@ check_compressed_archive ()
- if (memcmp (record_start->buffer, p->magic, p->length) == 0)
- return p->type;
-
-- if (short_file)
-- ERROR ((0, 0, _("This does not look like a tar archive")));
--
- return ct_none;
- }
-
-@@ -273,11 +272,16 @@ open_compressed_archive ()
-
- if (!multi_volume_option)
- {
-- enum compress_type type = check_compressed_archive ();
-+ bool shortfile;
-+ enum compress_type type = check_compressed_archive (&shortfile);
-
- if (type == ct_none)
-- return archive;
--
-+ {
-+ if (shortfile)
-+ ERROR ((0, 0, _("This does not look like a tar archive")));
-+ return archive;
-+ }
-+
- /* FD is not needed any more */
- rmtclose (archive);
-
-@@ -502,15 +506,18 @@ _open_archive (enum access_mode wanted_a
- {
- case ACCESS_READ:
- {
-+ bool shortfile;
- enum compress_type type;
-
- archive = STDIN_FILENO;
-
-- type = check_compressed_archive ();
-+ type = check_compressed_archive (&shortfile);
- if (type != ct_none)
- FATAL_ERROR ((0, 0,
- _("Archive is compressed. Use %s option"),
- compress_option (type)));
-+ if (shortfile)
-+ ERROR ((0, 0, _("This does not look like a tar archive")));
- }
- break;
-
-@@ -554,7 +561,7 @@ _open_archive (enum access_mode wanted_a
- O_RDWR | O_CREAT | O_BINARY,
- MODE_RW, rsh_command_option);
-
-- if (check_compressed_archive () != ct_none)
-+ if (check_compressed_archive (NULL) != ct_none)
- FATAL_ERROR ((0, 0,
- _("Cannot update compressed archives")));
- break;
diff --git a/app-arch/tar/tar-1.19-r1.ebuild b/app-arch/tar/tar-1.19-r1.ebuild
deleted file mode 100644
index d109196660a4..000000000000
--- a/app-arch/tar/tar-1.19-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.19-r1.ebuild,v 1.7 2008/02/27 10:46:09 coldwind Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="http://www.gnu.org/software/tar/"
-SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
- ftp://alpha.gnu.org/gnu/tar/${P}.tar.bz2
- mirror://gnu/tar/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls static userland_GNU"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.10.35 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gnu-inline.patch #198817
- epatch "${FILESDIR}"/${P}-update-flag.patch #200315
-
- if ! use userland_GNU ; then
- sed -i \
- -e 's:/backup\.sh:/gbackup.sh:' \
- scripts/{backup,dump-remind,restore}.in \
- || die "sed non-GNU"
- fi
-}
-
-src_compile() {
- local myconf
- use static && append-ldflags -static
- use userland_GNU || myconf="--program-prefix=g"
- # Work around bug in sandbox #67051
- gl_cv_func_chown_follows_symlink=yes \
- econf \
- --enable-backup-scripts \
- --bindir=/bin \
- --libexecdir=/usr/sbin \
- $(use_enable nls) \
- ${myconf} || die
- emake || die "emake failed"
-}
-
-src_install() {
- local p=""
- use userland_GNU || p=g
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- if [[ -z ${p} ]] ; then
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt || die
- fi
-
- dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
- newman "${FILESDIR}"/tar.1 ${p}tar.1
- mv "${D}"/usr/sbin/${p}backup{,-tar}
- mv "${D}"/usr/sbin/${p}restore{,-tar}
-
- rm -f "${D}"/usr/$(get_libdir)/charset.alias
-}