summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-11-24 16:18:39 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-11-24 16:18:39 +0000
commit4fc1177da54599bcef61265b452ca6d77219083a (patch)
treec98cedc8453f4c2586ead8e07cbd6b87eb47ccd0 /app-arch/tar
parentunmask tar, passes all tests with sandbox 2.4 (diff)
downloadgentoo-2-4fc1177da54599bcef61265b452ca6d77219083a.tar.gz
gentoo-2-4fc1177da54599bcef61265b452ca6d77219083a.tar.bz2
gentoo-2-4fc1177da54599bcef61265b452ca6d77219083a.zip
Merge diffs from Gentoo Prefix tree. Keywords, EAPI3, use of EPREFIX/ED, modify rmt script. Signed off in bug 344807
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog7
-rw-r--r--app-arch/tar/files/rmt2
-rw-r--r--app-arch/tar/tar-1.25.ebuild24
3 files changed, 22 insertions, 11 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index ff824b2c5534..f99f53a026b2 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/tar
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.159 2010/11/08 20:57:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.160 2010/11/24 16:18:39 darkside Exp $
+
+ 24 Nov 2010; Jeremy Olexa <darkside@gentoo.org> tar-1.25.ebuild,
+ files/rmt:
+ Merge diffs from Gentoo Prefix tree. Keywords, EAPI3, use of EPREFIX/ED,
+ modify rmt script. Signed off in bug 344807
*tar-1.25 (08 Nov 2010)
diff --git a/app-arch/tar/files/rmt b/app-arch/tar/files/rmt
index 4ad3e40ea24f..15ed6aa91fad 100644
--- a/app-arch/tar/files/rmt
+++ b/app-arch/tar/files/rmt
@@ -5,4 +5,4 @@
# utilities that expect to find (and execute) rmt in the /etc directory
# on remote systems.
#
-exec /usr/sbin/rmt "$@"
+exec rmt "$@"
diff --git a/app-arch/tar/tar-1.25.ebuild b/app-arch/tar/tar-1.25.ebuild
index bb78c7e8d4c9..20c46ebb2b47 100644
--- a/app-arch/tar/tar-1.25.ebuild
+++ b/app-arch/tar/tar-1.25.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.25.ebuild,v 1.1 2010/11/08 20:57:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.25.ebuild,v 1.2 2010/11/24 16:18:39 darkside Exp $
-EAPI="2"
+EAPI="3"
inherit flag-o-matic
@@ -14,7 +14,7 @@ SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static userland_GNU"
RDEPEND=""
@@ -39,8 +39,8 @@ src_configure() {
FORCE_UNSAFE_CONFIGURE=1 \
econf \
--enable-backup-scripts \
- --bindir=/bin \
- --libexecdir=/usr/sbin \
+ --bindir="${EPREFIX}"/bin \
+ --libexecdir="${EPREFIX}"/usr/sbin \
$(use_enable nls) \
${myconf}
}
@@ -57,10 +57,16 @@ src_install() {
doexe "${FILESDIR}"/rmt || die
fi
+ # autoconf looks for gtar before tar (in configure scripts), hence
+ # in Prefix it is important that it is there, otherwise, a gtar from
+ # the host system (FreeBSD, Solaris, Darwin) will be found instead
+ # of the Prefix provided (GNU) tar
+ if use prefix ; then
+ dosym tar /bin/gtar
+ fi
+
dodoc AUTHORS ChangeLog* NEWS README* THANKS
newman "${FILESDIR}"/tar.1 ${p}tar.1
- mv "${D}"/usr/sbin/${p}backup{,-tar}
- mv "${D}"/usr/sbin/${p}restore{,-tar}
-
- rm -f "${D}"/usr/$(get_libdir)/charset.alias
+ mv "${ED}"/usr/sbin/${p}backup{,-tar}
+ mv "${ED}"/usr/sbin/${p}restore{,-tar}
}