summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-06 02:57:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-06 02:57:10 +0000
commitaffecf43a9cbd924fae2c5a9cdc009ae76b0303f (patch)
tree4e87d47649d92e75364c7dcab9c802a42e681f4e /app-arch/lzma
parentUpdate blocker to allow newer versions of app-arch/lzma #218459. (diff)
downloadgentoo-2-affecf43a9cbd924fae2c5a9cdc009ae76b0303f.tar.gz
gentoo-2-affecf43a9cbd924fae2c5a9cdc009ae76b0303f.tar.bz2
gentoo-2-affecf43a9cbd924fae2c5a9cdc009ae76b0303f.zip
Version bump.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/ChangeLog9
-rw-r--r--app-arch/lzma/lzma-9.20.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/app-arch/lzma/ChangeLog b/app-arch/lzma/ChangeLog
index 200498334dee..419a9c06ac14 100644
--- a/app-arch/lzma/ChangeLog
+++ b/app-arch/lzma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lzma
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.15 2010/01/01 19:33:33 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.16 2011/01/06 02:57:10 vapier Exp $
+
+*lzma-9.20 (06 Jan 2011)
+
+ 06 Jan 2011; Mike Frysinger <vapier@gentoo.org> +lzma-9.20.ebuild:
+ Version bump.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> lzma-4.65.ebuild:
Transfer Prefix keywords
diff --git a/app-arch/lzma/lzma-9.20.ebuild b/app-arch/lzma/lzma-9.20.ebuild
new file mode 100644
index 000000000000..8db841c21920
--- /dev/null
+++ b/app-arch/lzma/lzma-9.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-9.20.ebuild,v 1.1 2011/01/06 02:57:10 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Bundles/LzmaCon
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon || die
+ dodoc lzma.txt history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt Methods.txt
+}
+
+pkg_postinst() {
+ einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
+}