summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2007-10-13 01:11:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2007-10-13 01:11:51 +0000
commit594077dd484ba31ee261c8ff4fc45eac8b8cfab9 (patch)
treeca9d14bba70dc75d2b3850fb1656ecaee918d91d /app-arch/ipkg-utils
parentwhitespace (diff)
downloadgentoo-2-594077dd484ba31ee261c8ff4fc45eac8b8cfab9.tar.gz
gentoo-2-594077dd484ba31ee261c8ff4fc45eac8b8cfab9.tar.bz2
gentoo-2-594077dd484ba31ee261c8ff4fc45eac8b8cfab9.zip
Small fixes for current tar compatibility. Thanks to Philipp Wehrheim for reporting and James for patching
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-arch/ipkg-utils')
-rw-r--r--app-arch/ipkg-utils/ChangeLog12
-rw-r--r--app-arch/ipkg-utils/files/digest-ipkg-utils-1.7-r1 (renamed from app-arch/ipkg-utils/files/digest-ipkg-utils-1.7)0
-rw-r--r--app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831-r1 (renamed from app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831)0
-rw-r--r--app-arch/ipkg-utils/files/ipkg-utils-tar_call_fixes.patch28
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7-r1.ebuild (renamed from app-arch/ipkg-utils/ipkg-utils-1.7.ebuild)8
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.050831-r1.ebuild (renamed from app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild)8
6 files changed, 49 insertions, 7 deletions
diff --git a/app-arch/ipkg-utils/ChangeLog b/app-arch/ipkg-utils/ChangeLog
index 420934cbc277..87ea27359ac7 100644
--- a/app-arch/ipkg-utils/ChangeLog
+++ b/app-arch/ipkg-utils/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-arch/ipkg-utils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.9 2007/01/23 15:40:07 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.10 2007/10/13 01:11:50 seemant Exp $
+
+*ipkg-utils-1.7.050831-r1 (13 Oct 2007)
+*ipkg-utils-1.7-r1 (13 Oct 2007)
+
+ 13 Oct 2007; Seemant Kulleen <seemant@gentoo.org>
+ +files/ipkg-utils-tar_call_fixes.patch, -ipkg-utils-1.7.ebuild,
+ +ipkg-utils-1.7-r1.ebuild, -ipkg-utils-1.7.050831.ebuild,
+ +ipkg-utils-1.7.050831-r1.ebuild:
+ Small fixes for current tar compatibility. Thanks to Philipp Wehrheim for
+ reporting and James for patching
23 Jan 2007; Marius Mauch <genone@gentoo.org> ipkg-utils-1.7.ebuild,
ipkg-utils-1.7.050831.ebuild:
diff --git a/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7 b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7-r1
index 2295067c2555..2295067c2555 100644
--- a/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7
+++ b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7-r1
diff --git a/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831 b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831-r1
index 050fe1b78d8e..050fe1b78d8e 100644
--- a/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831
+++ b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831-r1
diff --git a/app-arch/ipkg-utils/files/ipkg-utils-tar_call_fixes.patch b/app-arch/ipkg-utils/files/ipkg-utils-tar_call_fixes.patch
new file mode 100644
index 000000000000..da1e02b4fddb
--- /dev/null
+++ b/app-arch/ipkg-utils/files/ipkg-utils-tar_call_fixes.patch
@@ -0,0 +1,28 @@
+Index: ipkg-utils-050831/ipkg.py
+===================================================================
+--- ipkg-utils-050831/ipkg.py {cset c946c633-8984-433c-8beb-a6cf3926b0af}
++++ ipkg-utils-050831/ipkg.py {local clone}
+@@ -152,9 +152,9 @@ class Package:
+ self.filename = os.path.basename(fn)
+ ## sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
+ if self.isdeb:
+- control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - '*control'","r")
++ control = os.popen("ar p "+fn+" control.tar.gz | gtar xfzO - --wildcards '*control'","r")
+ else:
+- control = os.popen("tar xfzO "+fn+" '*control.tar.gz' | tar xfzO - '*control'","r")
++ control = os.popen("gtar xfzO "+fn+" --wildcards '*control.tar.gz' | gtar xfzO - --wildcards '*control'","r")
+ line = control.readline()
+ while 1:
+ if not line: break
+@@ -181,7 +181,7 @@ class Package:
+ if self.isdeb:
+ data = os.popen("ar p "+fn+" data.tar.gz | tar tfz -","r")
+ else:
+- data = os.popen("tar xfzO "+fn+" '*data.tar.gz' | tar tfz -","r")
++ data = os.popen("gtar xfzO "+fn+" --wildcards '*data.tar.gz' | gtar tfz -","r")
+ while 1:
+ line = data.readline()
+ if not line: break
+# Checksums: MD5
+# 3b32292e44cc49af1d6c599fd8a44fb8 ipkg.py
+# a103926695d45fe3c6d08a841ed6cd99 ipkg.py [diff]
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7-r1.ebuild
index 30a1295e3300..a6c5a37d0c85 100644
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild,v 1.8 2007/01/23 15:40:07 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7-r1.ebuild,v 1.1 2007/10/13 01:11:50 seemant Exp $
inherit distutils eutils toolchain-funcs
@@ -21,7 +21,9 @@ RDEPEND="dev-lang/python
DEPEND="${RDEPEND}"
src_unpack() {
- unpack ${A}; cd ${S}
+ unpack "${A}"; cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-tar_call_fixes.patch
sed '/python setup.py build/d' -i Makefile
@@ -38,5 +40,5 @@ src_compile() {
src_install() {
distutils_src_install
- use minimal && rm ${D}/usr/bin/ipkg-upload
+ use minimal && rm "${D}"/usr/bin/ipkg-upload
}
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r1.ebuild
index 4e3ef3279547..de6564b17f63 100644
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild,v 1.3 2007/01/23 15:40:07 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r1.ebuild,v 1.1 2007/10/13 01:11:50 seemant Exp $
inherit distutils eutils toolchain-funcs versionator
@@ -24,7 +24,9 @@ RDEPEND="dev-lang/python
DEPEND="${RDEPEND}"
src_unpack() {
- unpack ${A}; cd ${S}
+ unpack "${A}"; cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-tar_call_fixes.patch
sed '/python setup.py build/d' -i Makefile
@@ -41,7 +43,7 @@ src_compile() {
src_install() {
distutils_src_install
- use minimal && rm ${D}/usr/bin/ipkg-upload
+ use minimal && rm "${D}"/usr/bin/ipkg-upload
}
pkg_postinst() {