summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-07 16:22:06 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-07 16:22:06 +0000
commit0a1746b3d587fd15c30fcb587d72568e6942f4d8 (patch)
treeca8216f270f3b6c0b01c57ff6bacba18a06696e1 /app-arch/cabextract
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-0a1746b3d587fd15c30fcb587d72568e6942f4d8.tar.gz
gentoo-2-0a1746b3d587fd15c30fcb587d72568e6942f4d8.tar.bz2
gentoo-2-0a1746b3d587fd15c30fcb587d72568e6942f4d8.zip
Added a patch to configure from FreeBSD to build cabextract on ppc-macos.
Diffstat (limited to 'app-arch/cabextract')
-rw-r--r--app-arch/cabextract/ChangeLog6
-rw-r--r--app-arch/cabextract/cabextract-1.1.ebuild14
-rw-r--r--app-arch/cabextract/files/cabextract-configure.patch120
3 files changed, 137 insertions, 3 deletions
diff --git a/app-arch/cabextract/ChangeLog b/app-arch/cabextract/ChangeLog
index d84780b2e13a..307f81463192 100644
--- a/app-arch/cabextract/ChangeLog
+++ b/app-arch/cabextract/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/cabextract
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.24 2004/11/07 09:18:41 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.25 2004/11/07 16:22:06 usata Exp $
+
+ 08 Nov 2004; Mamoru KOMACHI <usata@gentoo.org>
+ +files/cabextract-configure.patch, cabextract-1.1.ebuild:
+ Added a patch to configure from FreeBSD to build cabextract on ppc-macos.
07 Nov 2004; Joshua Kinard <kumba@gentoo.org> cabextract-1.1.ebuild:
Marked stable on mips.
diff --git a/app-arch/cabextract/cabextract-1.1.ebuild b/app-arch/cabextract/cabextract-1.1.ebuild
index 0e291b95fb98..8139198d0d6b 100644
--- a/app-arch/cabextract/cabextract-1.1.ebuild
+++ b/app-arch/cabextract/cabextract-1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.1.ebuild,v 1.7 2004/11/07 09:18:41 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.1.ebuild,v 1.8 2004/11/07 16:22:06 usata Exp $
+
+inherit eutils
DESCRIPTION="Extracts files from Microsoft .cab files"
HOMEPAGE="http://www.kyz.uklinux.net/cabextract.php"
@@ -8,11 +10,19 @@ SRC_URI="http://www.kyz.uklinux.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc64 s390 sparc x86 ~ppc-macos"
IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if [ "${USERLAND}" == "BSD" ] ; then
+ epatch ${FILESDIR}/${PN}-configure.patch
+ fi
+}
+
src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
diff --git a/app-arch/cabextract/files/cabextract-configure.patch b/app-arch/cabextract/files/cabextract-configure.patch
new file mode 100644
index 000000000000..b83d42091ef8
--- /dev/null
+++ b/app-arch/cabextract/files/cabextract-configure.patch
@@ -0,0 +1,120 @@
+--- configure.orig Mon Oct 18 17:10:34 2004
++++ configure Mon Oct 18 22:42:46 2004
+@@ -6609,117 +6650,6 @@
+
+
+
+-for ac_func in mempcpy
+-do
+-as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+-echo "$as_me:$LINENO: checking for $ac_func" >&5
+-echo $ECHO_N "checking for $ac_func... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_var+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-/* Define $ac_func to an innocuous variant, in case <limits.h> declares $ac_func.
+- For example, HP-UX 11i <limits.h> declares gettimeofday. */
+-#define $ac_func innocuous_$ac_func
+-
+-/* System header to define __stub macros and hopefully few prototypes,
+- which can conflict with char $ac_func (); below.
+- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
+- <limits.h> exists even on freestanding compilers. */
+-
+-#ifdef __STDC__
+-# include <limits.h>
+-#else
+-# include <assert.h>
+-#endif
+-
+-#undef $ac_func
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-{
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char $ac_func ();
+-/* The GNU C library defines this for functions which it implements
+- to always fail with ENOSYS. Some functions are actually named
+- something starting with __ and the normal name is an alias. */
+-#if defined (__stub_$ac_func) || defined (__stub___$ac_func)
+-choke me
+-#else
+-char (*f) () = $ac_func;
+-#endif
+-#ifdef __cplusplus
+-}
+-#endif
+-
+-int
+-main ()
+-{
+-return f != $ac_func;
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- eval "$as_ac_var=yes"
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-eval "$as_ac_var=no"
+-fi
+-rm -f conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
+-if test `eval echo '${'$as_ac_var'}'` = yes; then
+- cat >>confdefs.h <<_ACEOF
+-#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
+-_ACEOF
+-
+-else
+- case $LIBOBJS in
+- "$ac_func.$ac_objext" | \
+- *" $ac_func.$ac_objext" | \
+- "$ac_func.$ac_objext "* | \
+- *" $ac_func.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS $ac_func.$ac_objext" ;;
+-esac
+-
+-fi
+-done
+-
+-
+-
+ ac_config_files="$ac_config_files Makefile cabextract.spec"
+
+ cat >confcache <<\_ACEOF