summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-04-30 11:44:51 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-04-30 11:44:51 +0000
commit6b65651f901336a17f54f7142993e696b59addd4 (patch)
tree355d72798d928de74a51b3afd0b5981e49e0caea /app-antivirus
parentDigest fix (diff)
downloadgentoo-2-6b65651f901336a17f54f7142993e696b59addd4.tar.gz
gentoo-2-6b65651f901336a17f54f7142993e696b59addd4.tar.bz2
gentoo-2-6b65651f901336a17f54f7142993e696b59addd4.zip
Version bump. Closees bug #129702 reported by Vieri <rentorbuy@yahoo.com>.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.88.2.ebuild112
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.882
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.88.23
4 files changed, 123 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index c9df9ec87456..0c930a77c0c1 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.140 2006/04/07 18:04:05 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.141 2006/04/30 11:44:51 ticho Exp $
+
+*clamav-0.88.2 (30 Apr 2006)
+
+ 30 Apr 2006; Andrej Kacian <ticho@gentoo.org> +clamav-0.88.2.ebuild:
+ Version bump. Closees bug #129702 reported by Vieri <rentorbuy@yahoo.com>.
07 Apr 2006; Mark Loeser <halcy0n@gentoo.org> clamav-0.88.1.ebuild:
Stable on x86; bug #128963
diff --git a/app-antivirus/clamav/clamav-0.88.2.ebuild b/app-antivirus/clamav/clamav-0.88.2.ebuild
new file mode 100644
index 000000000000..ab64b8b47c10
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.88.2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.88.2.ebuild,v 1.1 2006/04/30 11:44:51 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt milter selinux mailwrapper"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( mail-mta/sendmail )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions how to setup the clamav-milter type:"
+ echo " zless /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.88 b/app-antivirus/clamav/files/digest-clamav-0.88
index 3e6e7496744b..629a41b27493 100644
--- a/app-antivirus/clamav/files/digest-clamav-0.88
+++ b/app-antivirus/clamav/files/digest-clamav-0.88
@@ -1 +1,3 @@
MD5 5d23205673c32e2b1b6db95000e6da74 clamav-0.88.tar.gz 4564473
+RMD160 9ca758b665fcf51e42316a88198ea5c13dc3c407 clamav-0.88.tar.gz 4564473
+SHA256 7912be29d13dae676691fbad7fa5fc1518eb3b8b45f8d147097908533ca1f8db clamav-0.88.tar.gz 4564473
diff --git a/app-antivirus/clamav/files/digest-clamav-0.88.2 b/app-antivirus/clamav/files/digest-clamav-0.88.2
new file mode 100644
index 000000000000..0e5049125bdc
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.88.2
@@ -0,0 +1,3 @@
+MD5 f0a1c610a1fb70bd748a08bea69c736c clamav-0.88.2.tar.gz 6016832
+RMD160 db6960b315d7c0aec289e3820363f0a6f9c41daf clamav-0.88.2.tar.gz 6016832
+SHA256 b50874f10b09ce45d6753b641836b472dd60b9e73d789fe4ec89b34f7c3d33ba clamav-0.88.2.tar.gz 6016832