summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-29 16:48:49 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-29 16:48:49 +0000
commitec3edb79b7c5a04b9fb4fe6989a7d2065f294b3e (patch)
tree4eb8887384aa030a6f0aa3856da7d58cd72532d6 /app-admin
parentHOMEPAGE fix #9902 (diff)
downloadgentoo-2-ec3edb79b7c5a04b9fb4fe6989a7d2065f294b3e.tar.gz
gentoo-2-ec3edb79b7c5a04b9fb4fe6989a7d2065f294b3e.tar.bz2
gentoo-2-ec3edb79b7c5a04b9fb4fe6989a7d2065f294b3e.zip
Added a fix for compiling. See bug #8567
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/watchdog/ChangeLog8
-rw-r--r--app-admin/watchdog/files/sundries.diff20
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild10
3 files changed, 34 insertions, 4 deletions
diff --git a/app-admin/watchdog/ChangeLog b/app-admin/watchdog/ChangeLog
index eb782d4599c0..a9126c7b1d5f 100644
--- a/app-admin/watchdog/ChangeLog
+++ b/app-admin/watchdog/ChangeLog
@@ -1,14 +1,16 @@
# ChangeLog for app-admin/watchdog
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/ChangeLog,v 1.2 2002/07/31 03:16:02 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/ChangeLog,v 1.3 2002/10/29 16:48:49 raker Exp $
*watchdog-5.2 (Mar 3, 2002)
+
+ 29 Oct 2002; Nick Hadaway <raker@gentoo.org> watchdog-5.2.ebuild,
+ files/sundries.diff :
+ Added a diff to fix compiling problems. See bug #8567
30 Jul 2002; Calum Selkirk <cselkirk@gentoo.org> watchdog-5.2.ebuild :
-
Added -ppc to KEYWORDS. Added DEPEND and RDEPEND.
3 Mar 2002; Arcady Genkin <agenkin@thpoon.com> watchdog-5.2.ebuild :
-
This is the first version of this package, submitted by
Leknor@Leknor.com (William A. McArthur, Jr.).
diff --git a/app-admin/watchdog/files/sundries.diff b/app-admin/watchdog/files/sundries.diff
new file mode 100644
index 000000000000..e018571a4d00
--- /dev/null
+++ b/app-admin/watchdog/files/sundries.diff
@@ -0,0 +1,20 @@
+diff -urN watchdog-5.2/include/sundries.h watchdog-5.2-modified/include/sundries.h
+--- watchdog-5.2/include/sundries.h 1998-09-10 10:19:11.000000000 -0500
++++ watchdog-5.2-modified/include/sundries.h 2002-10-29 10:30:49.000000000 -0600
+@@ -46,16 +46,7 @@
+ char *xstrconcat3 (const char *, const char *, const char *);
+ char *xstrconcat4 (const char *, const char *, const char *, const char *);
+
+-/* Here is some serious cruft. */
+-#ifdef __GNUC__
+-#if defined(__GNUC_MINOR__) && __GNUC__ == 2 && __GNUC_MINOR__ >= 5
+ void die (int errcode, const char *fmt, ...) __attribute__ ((noreturn));
+-#else /* GNUC < 2.5 */
+-void volatile die (int errcode, const char *fmt, ...);
+-#endif /* GNUC < 2.5 */
+-#else /* !__GNUC__ */
+-void die (int errcode, const char *fmt, ...);
+-#endif /* !__GNUC__ */
+
+ #ifdef HAVE_NFS
+ int nfsmount (const char *spec, const char *node, int *flags,
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index 9914eb3f6262..6db3cbaec830 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.9 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.10 2002/10/29 16:48:49 raker Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="A software watchdog."
@@ -12,6 +12,14 @@ LICENSE="GPL-2"
KEYWORDS="x86 -ppc"
DEPEND="virtual/glibc"
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/sundries.diff || die "patch failed"
+
+}
+
src_compile() {
# Two configure switches have been added to use /etc/watchdog
econf \