summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-03-20 22:48:42 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-03-20 22:48:42 +0000
commit9d41efe545f08c19e05a6dbfbfa6411574ddae3c (patch)
tree2ff4a2ad577085a8d6335c519e03945164d1d614 /app-admin
parentamd64 stable (diff)
downloadgentoo-2-9d41efe545f08c19e05a6dbfbfa6411574ddae3c.tar.gz
gentoo-2-9d41efe545f08c19e05a6dbfbfa6411574ddae3c.tar.bz2
gentoo-2-9d41efe545f08c19e05a6dbfbfa6411574ddae3c.zip
Version bumped, bug #214085.
Removed old versions. (Portage version: 2.1.4.4)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog9
-rw-r--r--app-admin/puppet/puppet-0.24.1.ebuild111
-rw-r--r--app-admin/puppet/puppet-0.24.3.ebuild (renamed from app-admin/puppet/puppet-0.24.2.ebuild)4
3 files changed, 10 insertions, 114 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 45d92e250ee8..0f61dcd79b80 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.11 2008/03/05 16:15:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.12 2008/03/20 22:48:42 matsuu Exp $
+
+*puppet-0.24.3 (20 Mar 2008)
+
+ 20 Mar 2008; MATSUU Takuto <matsuu@gentoo.org> -puppet-0.24.1.ebuild,
+ -puppet-0.24.2.ebuild, +puppet-0.24.3.ebuild:
+ Version bumped, bug #214085.
+ Removed old versions.
*puppet-0.24.2 (05 Mar 2008)
diff --git a/app-admin/puppet/puppet-0.24.1.ebuild b/app-admin/puppet/puppet-0.24.1.ebuild
deleted file mode 100644
index 8dc0af61b3fd..000000000000
--- a/app-admin/puppet/puppet-0.24.1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.1.ebuild,v 1.1 2008/01/07 14:46:41 matsuu Exp $
-
-inherit elisp-common eutils ruby
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
-SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="emacs"
-KEYWORDS="~x86 ~amd64"
-
-DEPEND="emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}
- >=dev-ruby/facter-1.3.5
- >=app-portage/eix-0.9.4"
-
-USE_RUBY="ruby18"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- built_with_use virtual/ruby ipv6 || \
- die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
-
- enewgroup puppet || die "Problem creating group puppet"
- enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- DESTDIR="${D}" ruby_einstall "$@" || die
- DESTDIR="${D}" erubydoc
-
- # Installation of init scripts and configuration
- doinitd conf/gentoo/init.d/puppetmaster
- doconfd conf/gentoo/conf.d/puppetmaster
- doinitd conf/gentoo/init.d/puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- keepdir /etc/puppet/manifests
- insinto /etc/puppet
- doins conf/gentoo/puppet/*
-
- # Location of log and data files
- keepdir /var/run/puppet
- keepdir /var/log/puppet
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/*.vim
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto $(dirname ${f})
- dodoc ${f}
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${ROOT}/etc/puppet/puppetd.conf" -o \
- -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
- -f "${ROOT}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
- use emacs && elisp-site-regen
-}
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-0.24.2.ebuild b/app-admin/puppet/puppet-0.24.3.ebuild
index 76b1be2820e4..6130f773901d 100644
--- a/app-admin/puppet/puppet-0.24.2.ebuild
+++ b/app-admin/puppet/puppet-0.24.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.2.ebuild,v 1.1 2008/03/05 16:15:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.3.ebuild,v 1.1 2008/03/20 22:48:42 matsuu Exp $
inherit elisp-common eutils ruby
@@ -34,7 +34,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-0.24.2-gentoo.patch
}
src_compile() {