summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-22 11:26:48 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-22 11:26:48 +0000
commit8565740af651d6ad0b810025f5246b3d688222a5 (patch)
tree14ca81a967271dcde1d4d6746537952e9f5244b7 /app-admin
parentuse flags for conki (diff)
downloadgentoo-2-8565740af651d6ad0b810025f5246b3d688222a5.tar.gz
gentoo-2-8565740af651d6ad0b810025f5246b3d688222a5.tar.bz2
gentoo-2-8565740af651d6ad0b810025f5246b3d688222a5.zip
initial import of conky (patched version of torsmo)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/conky/ChangeLog11
-rw-r--r--app-admin/conky/Manifest3
-rw-r--r--app-admin/conky/conky-1.0.ebuild52
-rw-r--r--app-admin/conky/files/digest-conky-1.01
-rw-r--r--app-admin/conky/metadata.xml14
5 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
new file mode 100644
index 000000000000..8c1ebd7d104c
--- /dev/null
+++ b/app-admin/conky/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-admin/conky
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.1 2005/06/22 11:26:48 dragonheart Exp $
+
+*conky-1.0 (22 Jun 2005)
+
+ 22 Jun 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +conky-1.0.ebuild:
+ Initial ebuild thanks to Brenden Matthews based on torsmo with all current
+ patches.
+
diff --git a/app-admin/conky/Manifest b/app-admin/conky/Manifest
new file mode 100644
index 000000000000..62834bebf50c
--- /dev/null
+++ b/app-admin/conky/Manifest
@@ -0,0 +1,3 @@
+MD5 40eeca0a6637ba69d8315ae56c1290a5 conky-1.0.ebuild 1371
+MD5 c523644170dfb059ad9924c752d9e3b2 metadata.xml 541
+MD5 a5bba8ea4e2dc8761199eb5a38449eed files/digest-conky-1.0 61
diff --git a/app-admin/conky/conky-1.0.ebuild b/app-admin/conky/conky-1.0.ebuild
new file mode 100644
index 000000000000..f39d614ff005
--- /dev/null
+++ b/app-admin/conky/conky-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.0.ebuild,v 1.1 2005/06/22 11:26:48 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="minimalist system monitor for X based on torsmo"
+HOMEPAGE="http://conky.rty.ca"
+SRC_URI="http://conky.rty.ca/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="truetype seti"
+
+RDEPEND="virtual/libc
+ virtual/x11
+ truetype? ( >=media-libs/freetype-2 )
+ seti? ( sci-astronomy/setiathome )"
+
+DEPEND="truetype? ( >=media-libs/freetype-2 )
+ virtual/x11
+ >=sys-devel/automake-1.4
+ sys-devel/autoconf
+ sys-apps/grep
+ sys-apps/sed
+ sys-devel/gcc"
+
+
+src_compile() {
+ econf \
+ `use_enable truetype xft` \
+ `use_enable seti` || die "econf failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "make install failed"
+ dodoc ChangeLog AUTHORS README conkyrc.sample
+}
+
+pkg_postinst() {
+ einfo 'default configuration file is "~/.conkyrc"'
+ einfo "you can find a sample configuration file in"
+ einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
+ einfo
+ einfo "Comment out temperature info lines if you have no kernel"
+ einfo "support for it."
+ einfo
+ ewarn "Conky doesn't work with window managers that"
+ ewarn "take control over root window such as Gnome's nautilus."
+}
diff --git a/app-admin/conky/files/digest-conky-1.0 b/app-admin/conky/files/digest-conky-1.0
new file mode 100644
index 000000000000..75a3a78711f1
--- /dev/null
+++ b/app-admin/conky/files/digest-conky-1.0
@@ -0,0 +1 @@
+MD5 7b662ba95c6cea1345353889b80b61ee conky-1.0.tar.bz2 70711
diff --git a/app-admin/conky/metadata.xml b/app-admin/conky/metadata.xml
new file mode 100644
index 000000000000..a97e82b08892
--- /dev/null
+++ b/app-admin/conky/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>A user ebuild that I felt obliged to include. Please take over if you want it</description>
+</maintainer>
+<longdescription>
+Conky is a system monitor that sits in the corner of your desktop.
+It is a fork of Torsmo that seems to have got very slow with patching.
+</longdescription>
+</pkgmetadata>