summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-06-01 09:41:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-06-01 09:41:33 +0000
commit6c55daa5b58535d35bdeb54259dc0509546d3dc4 (patch)
treea43c89ed203ef2f818cd05db7877e4bc836f7192 /app-admin
parentStable on alpha wrt Bug #132213. (diff)
downloadgentoo-2-6c55daa5b58535d35bdeb54259dc0509546d3dc4.tar.gz
gentoo-2-6c55daa5b58535d35bdeb54259dc0509546d3dc4.tar.bz2
gentoo-2-6c55daa5b58535d35bdeb54259dc0509546d3dc4.zip
Remove profiles for non-existent versions of gcc from /etc/eselect/compiler when we first install eselect-compiler.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-compiler/ChangeLog11
-rw-r--r--app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild133
-rw-r--r--app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r43
3 files changed, 146 insertions, 1 deletions
diff --git a/app-admin/eselect-compiler/ChangeLog b/app-admin/eselect-compiler/ChangeLog
index 996f1a037cb2..1a71021bb221 100644
--- a/app-admin/eselect-compiler/ChangeLog
+++ b/app-admin/eselect-compiler/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/eselect-compiler
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/ChangeLog,v 1.16 2006/06/01 09:24:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/ChangeLog,v 1.17 2006/06/01 09:41:33 eradicator Exp $
+
+*eselect-compiler-2.0.0_rc1-r4 (01 Jun 2006)
+
+ 01 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ -eselect-compiler-2.0.0_rc1-r2.ebuild,
+ -eselect-compiler-2.0.0_rc1-r3.ebuild,
+ +eselect-compiler-2.0.0_rc1-r4.ebuild:
+ Remove profiles for non-existent versions of gcc from /etc/eselect/compiler
+ when we first install eselect-compiler.
*eselect-compiler-2.0.0_rc1-r3 (01 Jun 2006)
diff --git a/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild
new file mode 100644
index 000000000000..31c2fe3e1d40
--- /dev/null
+++ b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild,v 1.1 2006/06/01 09:41:33 eradicator Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to configure the active toolchain compiler"
+HOMEPAGE="http://www.gentoo.org/"
+
+MY_PN="compiler-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI=" http://dev.gentoo.org/~eradicator/toolchain/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hardened"
+
+RDEPEND=">=app-admin/eselect-1.0_rc1"
+
+# We want to verify that compiler profiles exist for our toolchain
+pkg_setup() {
+ local abi
+ for abi in $(get_all_abis) ; do
+ local ctarget=$(get_abi_CHOST ${abi})
+ if ! grep -q "^[[:space:]]*ctarget=${ctarget}$" ${ROOT}/etc/eselect/compiler/*.conf ; then
+ eerror "We weren't able to find a valid eselect compiler profile for ${abi}."
+ eerror "Please do the following to re-emerge gcc, then retry emerging"
+ eerror "eselect-compiler:"
+ eerror "# emerge -v --oneshot sys-devel/gcc"
+
+ die "Missing eselect-compiler profile for ${abi}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ # Some toolchain.eclass installed confs had some bugs that need fixing
+ sed -i 's:chost:ctarget:g' ${ROOT}/etc/eselect/compiler/*
+ sed -i 's:spec=:specs=:g' ${ROOT}/etc/eselect/compiler/*
+
+ # Activate the profiles
+ if [[ ! -f "${ROOT}/etc/eselect/compiler/selection.conf" ]] ; then
+ ewarn "This looks like the first time you are installing eselect-compiler. We are"
+ ewarn "activating toolchain profiles for the CTARGETs needed by your portage"
+ ewarn "profile You should have profiles installed from compilers that you emerged"
+ ewarn "after October, 2005. If a compiler you have installed is missing an"
+ ewarn "eselect-compiler profile, you can either re-emerge the compiler, create the"
+ ewarn "profile yourself, or you can migrate profiles from gcc-config-1.x by doing:"
+ ewarn "# eselect compiler migrate"
+ ewarn
+ ewarn "Note that if you use the migration tool, your current profiles will be"
+ ewarn "replaced, so you should backup the data in /etc/eselect/compiler first."
+ echo
+ einfo "The following profiles have been activated. If an incorrect profile is"
+ einfo "chosen or an error is reported, please use 'eselect compiler set' to"
+ einfo "manually choose it"
+
+ # First we need to clean out /etc/eselect/compiler as there may
+ # be some profiles in there which were not unmerged with gcc.
+ local item
+ for item in $(grep "^[[:space:]]*binpath=" ${ROOT}/etc/eselect/compiler/*.conf | sed 's/:.*binpath=/:/') ; do
+ local file=${item%:*}
+ local binpath=${item#*:}
+ [[ -d ${binpath} ]] || rm ${file}
+ done
+
+ local abi
+ for abi in $(get_all_abis) ; do
+ local ctarget=$(get_abi_CHOST ${abi})
+ local extra_options=""
+
+ if [[ ${abi} == ${DEFAULT_ABI} ]] ; then
+ extra_options="-n"
+ fi
+
+ local spec
+ if use hardened ; then
+ spec="hardened"
+ else
+ spec="vanilla"
+ fi
+
+ local isset=0
+ local tuple
+ for tuple in "${CHOST}" "${CTARGET}" "${ctarget}" ; do
+ local version
+ for version in "$(gcc-fullversion)" ; do
+ local profile
+ for profile in "${abi}-${spec}" "${spec}" "${abi}-default" "default" "${abi}-vanilla" "vanilla" ; do
+ if eselect compiler set ${tuple}-${version}/${profile} ${extra_options} &> /dev/null ; then
+ einfo "${abi}: ${tuple}-${version}/${profile}"
+
+ isset=1
+ break
+ fi
+ done
+ [[ ${isset} == 1 ]] && break
+ done
+ [[ ${isset} == 1 ]] && break
+ done
+
+ if [[ ${isset} == 0 ]] ; then
+ eerror "${abi}: Unable to determine an appropriate profile. Please set manually."
+ fi
+ done
+ else
+ eselect compiler update
+ fi
+
+ if rm -f ${ROOT}/etc/env.d/05gcc* &> /dev/null ; then
+ echo
+ ewarn "You should source /etc/profile in your open shells."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-inherit.patch
+}
+
+src_install() {
+ dodoc README
+ make DESTDIR="${D}" install || die
+
+ doenvd ${FILESDIR}/25eselect-compiler
+
+ # This is installed by sys-devel/gcc-config
+ rm ${D}/usr/bin/gcc-config
+}
diff --git a/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r4 b/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r4
new file mode 100644
index 000000000000..e5670a7296b1
--- /dev/null
+++ b/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r4
@@ -0,0 +1,3 @@
+MD5 b67d2f339f159da455d19c49e4868d9c compiler-config-2.0.0_rc1.tar.gz 117180
+RMD160 dbcd8120139c75f40ae2405746ab2a5f26e810b4 compiler-config-2.0.0_rc1.tar.gz 117180
+SHA256 a911a7b0a1184c576500df8530e77823f976dce387001c581ba89ac8edfe30c2 compiler-config-2.0.0_rc1.tar.gz 117180