summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-12-02 20:11:13 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-12-02 20:11:13 +0000
commit5c670ca1dc4d5334a344f8172cb52ae73ca1947a (patch)
tree67c1c60a0dd24f629c2b7f259244bb0452970ff4 /app-admin
parentAdd ocfs/ocfs2 to PRUNEFS #249590 by Oleg Gawriloff. (diff)
downloadgentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.tar.gz
gentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.tar.bz2
gentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.zip
app-admin/setools: New upstream bugfix release for libsepol 2.x additional features.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/setools/ChangeLog9
-rw-r--r--app-admin/setools/setools-2.4.ebuild26
-rw-r--r--app-admin/setools/setools-3.3.1.ebuild69
-rw-r--r--app-admin/setools/setools-3.3.5.ebuild (renamed from app-admin/setools/setools-3.3.3.ebuild)4
4 files changed, 21 insertions, 87 deletions
diff --git a/app-admin/setools/ChangeLog b/app-admin/setools/ChangeLog
index 972cb1193541..0eec2174a40d 100644
--- a/app-admin/setools/ChangeLog
+++ b/app-admin/setools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/setools
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.56 2008/03/31 23:25:48 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.57 2008/12/02 20:11:13 pebenito Exp $
+
+*setools-3.3.5 (02 Dec 2008)
+
+ 02 Dec 2008; Chris PeBenito <pebenito@gentoo.org> setools-2.4.ebuild,
+ -setools-3.3.1.ebuild, -setools-3.3.3.ebuild, +setools-3.3.5.ebuild:
+ New upstream bugfix release for libsepol 2.x additional features.
+ Cleanup old ebuilds.
*setools-3.3.4 (31 Mar 2008)
diff --git a/app-admin/setools/setools-2.4.ebuild b/app-admin/setools/setools-2.4.ebuild
index b70262a47bf9..d945609818ea 100644
--- a/app-admin/setools/setools-2.4.ebuild
+++ b/app-admin/setools/setools-2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-2.4.ebuild,v 1.3 2006/09/12 23:50:11 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-2.4.ebuild,v 1.4 2008/12/02 20:11:13 pebenito Exp $
inherit eutils
@@ -35,30 +35,28 @@ RDEPEND="dev-libs/libxml2
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/apol_tcl_fc.c.diff
+ epatch "${FILESDIR}/apol_tcl_fc.c.diff"
# enable debug if requested
- useq debug && sed -i -e '/^DEBUG/s/0/1/' ${S}/Makefile
+ useq debug && sed -i -e '/^DEBUG/s/0/1/' "${S}/Makefile"
# dont do findcon, replcon, searchcon, or indexcon if USE=-selinux
if ! useq selinux; then
- sed -i -e '/^USE_LIBSELINUX/s/1/0/' ${S}/Makefile
+ sed -i -e '/^USE_LIBSELINUX/s/1/0/' "${S}/Makefile"
sed -i -e '/^SE_CMDS/s/replcon//' \
-e '/^SE_CMDS/s/findcon//' \
-e '/^SE_CMDS/s/searchcon//' \
- -e '/^SE_CMDS/s/indexcon//' ${S}/secmds/Makefile
+ -e '/^SE_CMDS/s/indexcon//' "${S}/secmds/Makefile"
# sechecker won't compile w/o libselinux
- sed -i -e '/^all-nogui/s/sechecker//' ${S}/Makefile
- sed -i -r -e '/^install-sechecker/!s/install-sechecker//' ${S}/Makefile
+ sed -i -e '/^all-nogui/s/sechecker//' "${S}/Makefile"
+ sed -i -r -e '/^install-sechecker/!s/install-sechecker//' "${S}/Makefile"
fi
}
src_compile() {
- cd ${S}
-
if useq X; then
make all || die
else
@@ -67,15 +65,13 @@ src_compile() {
}
src_install() {
- cd ${S}
-
# some of the Makefiles are broken, and will fail
# if ${D}/usr/bin is nonexistant
dodir /usr/bin
if use X; then
- make DESTDIR=${D} install || die "install failed."
+ make DESTDIR="${D}" install || die "install failed."
else
- make DESTDIR=${D} install-nogui || die "install failed."
+ make DESTDIR="${D}" install-nogui || die "install failed."
fi
}
diff --git a/app-admin/setools/setools-3.3.1.ebuild b/app-admin/setools/setools-3.3.1.ebuild
deleted file mode 100644
index 2b9c17b08dda..000000000000
--- a/app-admin/setools/setools-3.3.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-3.3.1.ebuild,v 1.1 2007/08/27 02:50:31 pebenito Exp $
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="SELinux policy tools"
-HOMEPAGE="http://www.tresys.com/selinux/selinux_policy_tools.shtml"
-SRC_URI="http://oss.tresys.com/projects/setools/chrome/site/dists/${PN}-${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X debug java python"
-
-DEPEND=">=sys-libs/libsepol-1.16.3
- sys-libs/libselinux
- sys-devel/bison
- sys-devel/flex
- >=dev-db/sqlite-3.2
- dev-libs/libxml2
- dev-util/pkgconfig
- java? (
- >=dev-lang/swig-1.3.28
- >=virtual/jdk-1.4
- )
- python? (
- >=dev-lang/python-2.4
- >=dev-lang/swig-1.3.28
- )
- X? (
- >=dev-lang/tk-8.4.9
- >=gnome-base/libglade-2.0
- >=x11-libs/gtk+-2.8
- )"
-
-RDEPEND=">=sys-libs/libsepol-1.16.3
- sys-libs/libselinux
- >=dev-db/sqlite-3.2
- dev-libs/libxml2
- java? ( >=virtual/jre-1.4 )
- python? ( >=dev-lang/python-2.4 )
- X? (
- >=dev-lang/tk-8.4.9
- >=dev-tcltk/bwidget-1.8
- >=gnome-base/libglade-2.0
- >=x11-libs/gtk+-2.8
- )"
-
-src_compile() {
- cd ${S}
-
- econf \
- --with-java-prefix=${JAVA_HOME} \
- --disable-selinux-check \
- --disable-bwidget-check \
- $(use_enable python swig-python) \
- $(use_enable java swig-java) \
- $(use_enable X swig-tcl) \
- $(use_enable X gui) \
- $(use_enable debug)
-
- emake || die
-}
-
-src_install() {
- cd ${S}
- make DESTDIR=${D} install || die "install failed."
-}
diff --git a/app-admin/setools/setools-3.3.3.ebuild b/app-admin/setools/setools-3.3.5.ebuild
index b45fb75e8269..d7c51842f2da 100644
--- a/app-admin/setools/setools-3.3.3.ebuild
+++ b/app-admin/setools/setools-3.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-3.3.3.ebuild,v 1.1 2008/02/26 16:07:50 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-3.3.5.ebuild,v 1.1 2008/12/02 20:11:13 pebenito Exp $
inherit java-pkg-opt-2
@@ -58,7 +58,7 @@ src_compile() {
$(use_enable X gui) \
$(use_enable debug)
- emake || die
+ make || die
}
src_install() {