summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-07 21:41:35 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-07 21:41:35 +0000
commit5c1db5da14e25f9cfe87fd31eea45d2786b43348 (patch)
tree01aab8ba4e991f4d9c0c0510dbfcfbe5b77dd7ca /app-admin
parentStable for HPPA too. (diff)
downloadgentoo-2-5c1db5da14e25f9cfe87fd31eea45d2786b43348.tar.gz
gentoo-2-5c1db5da14e25f9cfe87fd31eea45d2786b43348.tar.bz2
gentoo-2-5c1db5da14e25f9cfe87fd31eea45d2786b43348.zip
version bump
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.6.ebuild92
-rw-r--r--app-admin/apache-tools/files/digest-apache-tools-2.2.63
3 files changed, 102 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 163cfd33bd41..d915e25fd049 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.15 2007/09/04 18:35:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.16 2007/09/07 21:41:34 hollow Exp $
+
+*apache-tools-2.2.6 (07 Sep 2007)
+
+ 07 Sep 2007; Benedikt Böhm <hollow@gentoo.org>
+ +apache-tools-2.2.6.ebuild:
+ version bump
04 Sep 2007; Raúl Porcel <armin76@gentoo.org>
apache-tools-2.2.4-r4.ebuild:
diff --git a/app-admin/apache-tools/apache-tools-2.2.6.ebuild b/app-admin/apache-tools/apache-tools-2.2.6.ebuild
new file mode 100644
index 000000000000..5fa7e2afc774
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.6.ebuild,v 1.1 2007/09/07 21:41:34 hollow Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags -Wl,--no-as-needed
+
+ if use ssl ; then
+ myconf="${myconf} --with-ssl=/usr --enable-ssl"
+ append-flags -DHAVE_OPENSSL -DUSE_SSL -I/usr/include/openssl
+ append-ldflags -lssl
+ fi
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+
+ econf \
+ --sbindir=/usr/sbin \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/files/digest-apache-tools-2.2.6 b/app-admin/apache-tools/files/digest-apache-tools-2.2.6
new file mode 100644
index 000000000000..c8d86da16d22
--- /dev/null
+++ b/app-admin/apache-tools/files/digest-apache-tools-2.2.6
@@ -0,0 +1,3 @@
+MD5 203bea91715064f0c787f6499d33a377 httpd-2.2.6.tar.bz2 4717066
+RMD160 5ae895c6898213e1e3b7e7b02cdfcbe5b36a108f httpd-2.2.6.tar.bz2 4717066
+SHA256 f27cd9df50a2acd9df8f37520f62f6ce51758689d425ead5883e75ff5ed6548c httpd-2.2.6.tar.bz2 4717066