summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-08-31 10:12:51 +0000
committerAli Polatel <hawking@gentoo.org>2008-08-31 10:12:51 +0000
commit3a4a9899fabdc85765ed72dd922b3d5ca0418ff8 (patch)
tree57a24c78ede2d6e5cac6148159fcd929903a066f /app-admin
parentVersion bump. Keyword ~amd64. Drop old. (diff)
downloadgentoo-2-3a4a9899fabdc85765ed72dd922b3d5ca0418ff8.tar.gz
gentoo-2-3a4a9899fabdc85765ed72dd922b3d5ca0418ff8.tar.bz2
gentoo-2-3a4a9899fabdc85765ed72dd922b3d5ca0418ff8.zip
Version bump.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sshguard/ChangeLog7
-rw-r--r--app-admin/sshguard/sshguard-1.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-admin/sshguard/ChangeLog b/app-admin/sshguard/ChangeLog
index c01dd63934c6..39a2a0ea18a8 100644
--- a/app-admin/sshguard/ChangeLog
+++ b/app-admin/sshguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sshguard
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.7 2008/07/18 23:16:24 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.8 2008/08/31 10:12:51 hawking Exp $
+
+*sshguard-1.1 (31 Aug 2008)
+
+ 31 Aug 2008; Ali Polatel <hawking@gentoo.org> +sshguard-1.1.ebuild:
+ Version bump.
18 Jul 2008; Dawid Węgliński <cla@gentoo.org> sshguard-1.0.ebuild:
amd64 stable (bug #225235)
diff --git a/app-admin/sshguard/sshguard-1.1.ebuild b/app-admin/sshguard/sshguard-1.1.ebuild
new file mode 100644
index 000000000000..8200c16395e3
--- /dev/null
+++ b/app-admin/sshguard/sshguard-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.1.ebuild,v 1.1 2008/08/31 10:12:51 hawking Exp $
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="ipfilter kernel_FreeBSD kernel_linux"
+
+DEPEND="kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( !ipfilter? ( sys-freebsd/freebsd-pf ) )"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_compile() {
+ local myconf
+ if use kernel_linux; then
+ myconf="--with-firewall=iptables"
+ elif use kernel_FreeBSD; then
+ use ipfilter && myconf="--with-firewall=ipfw" \
+ || myconf="--with-firewall=pf"
+ fi
+
+ econf ${myconf}
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README Changes || die "dodoc failed"
+ dodoc examples/* || die "dodoc failed"
+}