summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-09 18:53:34 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-09 18:53:34 +0000
commit0cca8aa883174a3297ef0cdd984bdf6f1d585c4a (patch)
tree8027193a929749dabebb594a1de04f7946d7abc3 /app-admin
parentBump to 2.1 (diff)
downloadgentoo-2-0cca8aa883174a3297ef0cdd984bdf6f1d585c4a.tar.gz
gentoo-2-0cca8aa883174a3297ef0cdd984bdf6f1d585c4a.tar.bz2
gentoo-2-0cca8aa883174a3297ef0cdd984bdf6f1d585c4a.zip
tests work now (with patch)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ChangeLog6
-rw-r--r--app-admin/ansible/ansible-1.4.1.ebuild7
-rw-r--r--app-admin/ansible/files/tests-ansible-1.4.1.patch13
3 files changed, 21 insertions, 5 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index adfd8e4a8212..457a042323d4 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.29 2013/12/09 17:20:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.30 2013/12/09 18:53:34 prometheanfire Exp $
+
+ 09 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +files/tests-ansible-1.4.1.patch, ansible-1.4.1.ebuild:
+ tests work now (with patch)
*ansible-1.4.1 (09 Dec 2013)
diff --git a/app-admin/ansible/ansible-1.4.1.ebuild b/app-admin/ansible/ansible-1.4.1.ebuild
index 7e878b642037..1e4007df0169 100644
--- a/app-admin/ansible/ansible-1.4.1.ebuild
+++ b/app-admin/ansible/ansible-1.4.1.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.1.ebuild,v 1.1 2013/12/09 17:20:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.1.ebuild,v 1.2 2013/12/09 18:53:34 prometheanfire Exp $
EAPI="5"
-#tests restricted due to bug https://github.com/ansible/ansible/issues/5224
-RESTRICT="test"
-
PYTHON_COMPAT=( python{2_6,2_7} )
inherit distutils-r1 readme.gentoo
@@ -37,6 +34,8 @@ Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
You have to create ansible hosts file!\n
More info on http://ansible.cc/docs/gettingstarted.html"
+PATCHES=( "${FILESDIR}/tests-${P}.patch" )
+
python_prepare_all() {
distutils-r1_python_prepare_all
# Skip tests which need ssh access
diff --git a/app-admin/ansible/files/tests-ansible-1.4.1.patch b/app-admin/ansible/files/tests-ansible-1.4.1.patch
new file mode 100644
index 000000000000..f3a0f3807f07
--- /dev/null
+++ b/app-admin/ansible/files/tests-ansible-1.4.1.patch
@@ -0,0 +1,13 @@
+--- test/TestUtils.py.orig 2013-12-09 13:39:23.585258424 -0500
++++ test/TestUtils.py 2013-12-09 13:39:40.524257467 -0500
+@@ -10,6 +10,10 @@
+ import ansible.utils
+ import ansible.utils.template as template2
+
++import sys
++reload(sys)
++sys.setdefaultencoding("utf8")
++
+ class TestUtils(unittest.TestCase):
+
+ #####################################