summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-23 03:03:23 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-23 03:03:23 +0000
commit0c76bf7bd4f5c5bee750ddb1f3b0c214748b4b14 (patch)
treebdb1b19354f6be614d46ca0c9095134e7a70c244 /app-admin/ulogd
parentbump for bug # 116741 (diff)
downloadgentoo-2-0c76bf7bd4f5c5bee750ddb1f3b0c214748b4b14.tar.gz
gentoo-2-0c76bf7bd4f5c5bee750ddb1f3b0c214748b4b14.tar.bz2
gentoo-2-0c76bf7bd4f5c5bee750ddb1f3b0c214748b4b14.zip
patch the configure.in thanks to code from steven debock and bug # 144154
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-admin/ulogd')
-rw-r--r--app-admin/ulogd/ChangeLog6
-rw-r--r--app-admin/ulogd/files/configure-fixes.patch60
-rw-r--r--app-admin/ulogd/ulogd-1.24.ebuild9
3 files changed, 72 insertions, 3 deletions
diff --git a/app-admin/ulogd/ChangeLog b/app-admin/ulogd/ChangeLog
index 83e8ebce0c7f..66d419f4ed81 100644
--- a/app-admin/ulogd/ChangeLog
+++ b/app-admin/ulogd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/ulogd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ChangeLog,v 1.39 2007/01/17 19:40:37 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ChangeLog,v 1.40 2007/01/23 03:03:22 antarus Exp $
+
+ 23 Jan 2007; Alec Warner <antarus@gentoo.org>
+ +files/configure-fixes.patch, ulogd-1.24.ebuild:
+ patch the configure.in thanks to code from steven debock and bug # 144154
*ulogd-1.24 (17 Jan 2007)
diff --git a/app-admin/ulogd/files/configure-fixes.patch b/app-admin/ulogd/files/configure-fixes.patch
new file mode 100644
index 000000000000..206404445ece
--- /dev/null
+++ b/app-admin/ulogd/files/configure-fixes.patch
@@ -0,0 +1,60 @@
+--- configure.in.orig 2007-01-21 15:37:46.000000000 +0100
++++ configure.in 2007-01-22 21:23:34.000000000 +0100
+@@ -34,14 +34,14 @@
+ dnl
+ dnl test for MySQL
+ dnl
+-AC_ARG_WITH(mysql,
+- --with-mysql=<directory> mysql installed in <directory>,[
+-if test $withval != yes
+-then
++AC_ARG_WITH(mysql, AS_HELP_STRING([--with-mysql=<directory>],[mysql installed in <directory>]),[with_mysql=$withval
++],[with_mysql=no])
++if test $withval != yes -a $withval != no ; then
+ dir=$withval
+ else
+ dir="/usr/local"
+ fi
++if test $withval != no; then
+ mysqldir=""
+ AC_MSG_CHECKING(for MySQL files)
+ for d in $dir /usr /usr/local /usr/local/mysql /opt/mysql /opt/packages/mysql
+@@ -108,8 +108,7 @@
+ fi
+
+ fi
+-])
+-
++fi
+
+ dnl
+ dnl Check whether the user wants log IP-addresses as strings rather
+@@ -130,14 +129,16 @@
+ dnl
+ dnl test for PostgreSQL
+ dnl
+-AC_ARG_WITH(pgsql,
+- --with-pgsql=<directory> pgsql installed in <directory>,[
+-if test $withval != yes
++
++AC_ARG_WITH(pgsql, AS_HELP_STRING([--with-pgsql=<directory>],[pgsql installed in <directory>]),[with_mysql=$withval],[with_mysql=no])
++if test $withval != yes -a $withval != no
+ then
+ dir=$withval
+ else
+ dir="/usr/local"
+ fi
++if test $withval = yes
++then
+ pgsqldir=""
+ AC_MSG_CHECKING(for PGSQL files)
+ for d in $dir /usr /usr/local /usr/local/pgsql /opt/pgsql /opt/packages/pgsql
+@@ -181,7 +182,7 @@
+ AC_SUBST(PGSQL_LIB)
+
+ fi
+-])
++fi
+
+ dnl
+ dnl Check whether the user wants to log IP-addresses as strings rather
diff --git a/app-admin/ulogd/ulogd-1.24.ebuild b/app-admin/ulogd/ulogd-1.24.ebuild
index 390ee1e7aa28..4ed0ec249614 100644
--- a/app-admin/ulogd/ulogd-1.24.ebuild
+++ b/app-admin/ulogd/ulogd-1.24.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-1.24.ebuild,v 1.1 2007/01/17 19:40:37 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-1.24.ebuild,v 1.2 2007/01/23 03:03:22 antarus Exp $
-inherit eutils flag-o-matic
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils flag-o-matic autotools
DESCRIPTION="A userspace logging daemon for netfilter/iptables related logging"
SRC_URI="http://ftp.netfilter.org/pub/ulogd/${P}.tar.bz2"
@@ -21,6 +23,9 @@ src_compile() {
# enables logfiles over 2G (#74924)
append-lfs-flags
+ epatch "${FILESDIR}/configure-fixes.patch"
+ ewarn "Regenerating build system (this may take a bit)..."
+ eautoconf || die "Autoreconf failed"
econf \
$(use_with mysql) \
$(use_with postgres pgsql) \