summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2015-02-13 17:55:18 +0000
committerJosé María Alonso <nimiux@gentoo.org>2015-02-13 17:55:18 +0000
commit891cd7d9a81d0a92b8d5f70cd64c976f8ea39e01 (patch)
tree28a1f76b36e5a8baa274e61d8fd67a27bd456d7a /app-admin/tripwire
parentRevert the new USE flags, fix a Changelog typo. (diff)
downloadgentoo-2-891cd7d9a81d0a92b8d5f70cd64c976f8ea39e01.tar.gz
gentoo-2-891cd7d9a81d0a92b8d5f70cd64c976f8ea39e01.tar.bz2
gentoo-2-891cd7d9a81d0a92b8d5f70cd64c976f8ea39e01.zip
Bump to fix bug #495204. Thank to Gabriel Marcano
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key F253DB15)
Diffstat (limited to 'app-admin/tripwire')
-rw-r--r--app-admin/tripwire/ChangeLog10
-rw-r--r--app-admin/tripwire/files/tripwire-2.4.2.2-exception-shadowing.patch13
-rw-r--r--app-admin/tripwire/tripwire-2.4.2.2-r3.ebuild82
3 files changed, 103 insertions, 2 deletions
diff --git a/app-admin/tripwire/ChangeLog b/app-admin/tripwire/ChangeLog
index d2f0fd7c98c8..03dde216c95f 100644
--- a/app-admin/tripwire/ChangeLog
+++ b/app-admin/tripwire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/tripwire
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/ChangeLog,v 1.56 2014/08/03 18:34:45 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/ChangeLog,v 1.57 2015/02/13 17:55:18 nimiux Exp $
+
+*tripwire-2.4.2.2-r3 (13 Feb 2015)
+
+ 13 Feb 2015; Chema Alonso <nimiux@gentoo.org> +tripwire-2.4.2.2-r3.ebuild,
+ +files/tripwire-2.4.2.2-exception-shadowing.patch:
+ Bump to fix bug #495204. Thank to Gabriel Marcano
03 Aug 2014; Agostino Sarubbo <ago@gentoo.org> tripwire-2.4.2.2-r2.ebuild:
Stable for ppc, wrt bug #509764
diff --git a/app-admin/tripwire/files/tripwire-2.4.2.2-exception-shadowing.patch b/app-admin/tripwire/files/tripwire-2.4.2.2-exception-shadowing.patch
new file mode 100644
index 000000000000..1347590ef462
--- /dev/null
+++ b/app-admin/tripwire/files/tripwire-2.4.2.2-exception-shadowing.patch
@@ -0,0 +1,13 @@
+--- a/src/core/archive.cpp
++++ b/src/core/archive.cpp
+@@ -886,8 +886,8 @@ void cLockedTemporaryFileArchive::OpenReadWrite( const TCHAR* filename, uint32 o
+ catch( eFSServices& e)
+ {
+ TSTRING errStr = TSS_GetString( cCore, core::STR_BAD_TEMPDIRECTORY );
+- eArchiveOpen e(strTempFile, errStr);
+- throw e;
++ eArchiveOpen ex(strTempFile, errStr);
++ throw ex;
+ }
+ }
+ ///////////////////////////////////////////////////////////////////////////////
diff --git a/app-admin/tripwire/tripwire-2.4.2.2-r3.ebuild b/app-admin/tripwire/tripwire-2.4.2.2-r3.ebuild
new file mode 100644
index 000000000000..6041a46a1ec6
--- /dev/null
+++ b/app-admin/tripwire/tripwire-2.4.2.2-r3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/tripwire-2.4.2.2-r3.ebuild,v 1.1 2015/02/13 17:55:18 nimiux Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Open Source File Integrity Checker and IDS"
+HOMEPAGE="http://www.tripwire.org/"
+SRC_URI="mirror://sourceforge/tripwire/tripwire-${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="ssl static +tools"
+
+DEPEND="sys-devel/automake
+ sys-devel/autoconf
+ ssl? ( dev-libs/openssl )"
+RDEPEND="virtual/cron
+ virtual/mta
+ ssl? ( dev-libs/openssl )"
+PDEPEND="tools? ( app-admin/mktwpol )"
+
+S="${WORKDIR}"/tripwire-"${PV}"-src
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-fix-configure.patch
+ epatch "${FILESDIR}"/"${P}"-buildnum.patch
+ epatch "${FILESDIR}"/"${P}"-gcc-4.7.patch
+ epatch "${FILESDIR}"/"${PN}"-twpol-GENERIC.patch
+ epatch "${FILESDIR}"/"${P}"-exception-shadowing.patch
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # tripwire can be sensitive to compiler optimisation.
+ # see #32613, #45823, and others.
+ # -taviso@gentoo.org
+ strip-flags
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
+ econf $(use_enable ssl openssl) $(use_enable static)
+}
+
+src_install() {
+ dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
+ doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
+ dodir /etc/tripwire /var/lib/tripwire{,/report}
+ keepdir /var/lib/tripwire{,/report}
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/tripwire
+
+ dodoc ChangeLog policy/policyguide.txt TRADEMARK \
+ "${FILESDIR}"/tripwire.txt
+
+ insinto /etc/tripwire
+ doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt
+
+ fperms 750 /etc/cron.daily/tripwire
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Tripwire needs to be configured before its first run. You can"
+ elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
+ elog "the package to suit your needs. A quickstart guide is provided"
+ elog "in tripwire.txt file to help you with this."
+ elog "To configure tripwire automatically, you can use the twsetup.sh"
+ elog "script provided by the app-admin/mktwpol package. This package is"
+ elog "installed for you by the \"tools\" USE flag (which is enabled by"
+ elog "default."
+else
+ elog "Maintenance of tripwire policy files as packages are added"
+ elog "and deleted from your system can be automated by the mktwpol.sh"
+ elog "script provided by the app-admin/mktwpol package. This package"
+ elog "is installed for you if you append \"tools\" to your USE flags"
+ fi
+}