summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-16 20:50:08 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-16 20:50:08 +0000
commitd90c3892a5af13cc88211a4ff404f3fe20c98626 (patch)
tree78699d7bb4dd19ef3ba481842466f147cd195f67 /app-admin/sysstat
parentStable on sparc (diff)
downloadgentoo-2-d90c3892a5af13cc88211a4ff404f3fe20c98626.tar.gz
gentoo-2-d90c3892a5af13cc88211a4ff404f3fe20c98626.tar.bz2
gentoo-2-d90c3892a5af13cc88211a4ff404f3fe20c98626.zip
Version bump; added gcc4 patch.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-admin/sysstat')
-rw-r--r--app-admin/sysstat/ChangeLog8
-rw-r--r--app-admin/sysstat/Manifest7
-rw-r--r--app-admin/sysstat/files/digest-sysstat-6.0.01
-rw-r--r--app-admin/sysstat/files/sysstat-6.0.0-gcc4.diff169
-rw-r--r--app-admin/sysstat/sysstat-6.0.0.ebuild47
5 files changed, 229 insertions, 3 deletions
diff --git a/app-admin/sysstat/ChangeLog b/app-admin/sysstat/ChangeLog
index d86a6095ee90..d01decd07ecf 100644
--- a/app-admin/sysstat/ChangeLog
+++ b/app-admin/sysstat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sysstat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.33 2005/03/31 20:11:02 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.34 2005/05/16 20:50:08 ka0ttic Exp $
+
+*sysstat-6.0.0 (16 May 2005)
+
+ 16 May 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/sysstat-6.0.0-gcc4.diff, +sysstat-6.0.0.ebuild:
+ Version bump; added gcc4 patch.
31 Mar 2005; <blubb@gentoo.org> sysstat-5.0.5-r1.ebuild:
stable on amd64
diff --git a/app-admin/sysstat/Manifest b/app-admin/sysstat/Manifest
index 719392352ae9..bd165590756a 100644
--- a/app-admin/sysstat/Manifest
+++ b/app-admin/sysstat/Manifest
@@ -1,7 +1,10 @@
-MD5 2f23bd8f738efe39265d1ff9129b1daf ChangeLog 3921
-MD5 675ff477bc1593491723b612471e4e54 sysstat-5.0.2.ebuild 961
MD5 a5e6fc5b53b896faeab070b389a14532 sysstat-5.0.4.ebuild 961
MD5 780588a0027af9f06a2f5a040b3cdb31 sysstat-5.0.5-r1.ebuild 1123
+MD5 7e91f4ac5a1d785b8db0c20e5e0a1965 sysstat-6.0.0.ebuild 1180
+MD5 675ff477bc1593491723b612471e4e54 sysstat-5.0.2.ebuild 961
+MD5 43ea8bb226b09b7b334a3dc69e64af75 ChangeLog 4092
MD5 fb5bff216a55ef8704f4946af00ed172 files/digest-sysstat-5.0.2 65
MD5 53d6bd1111ffa77e7b53d51b96b5d812 files/digest-sysstat-5.0.4 65
+MD5 524d1ab101c324db0a21cff67ded4fa3 files/digest-sysstat-6.0.0 65
+MD5 ddf73fe10757e3b706c377f8fad79245 files/sysstat-6.0.0-gcc4.diff 6647
MD5 d63e5ccba8489c1875bb404a477ed9f0 files/digest-sysstat-5.0.5-r1 65
diff --git a/app-admin/sysstat/files/digest-sysstat-6.0.0 b/app-admin/sysstat/files/digest-sysstat-6.0.0
new file mode 100644
index 000000000000..e29bd3d50c5a
--- /dev/null
+++ b/app-admin/sysstat/files/digest-sysstat-6.0.0
@@ -0,0 +1 @@
+MD5 f94347f3010996a44e55bb209dbed09c sysstat-6.0.0.tar.gz 150024
diff --git a/app-admin/sysstat/files/sysstat-6.0.0-gcc4.diff b/app-admin/sysstat/files/sysstat-6.0.0-gcc4.diff
new file mode 100644
index 000000000000..6a9f570a55dd
--- /dev/null
+++ b/app-admin/sysstat/files/sysstat-6.0.0-gcc4.diff
@@ -0,0 +1,169 @@
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/iostat.c sysstat-6.0.0/iostat.c
+--- sysstat-6.0.0.orig/iostat.c 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/iostat.c 2005-05-16 16:48:06.000000000 -0400
+@@ -958,7 +958,7 @@
+
+ /* Print time stamp */
+ if (DISPLAY_TIMESTAMP(flags)) {
+- strftime(timestamp, sizeof(timestamp), "%X", loc_time);
++ strftime((char *)timestamp, sizeof(timestamp), "%X", loc_time);
+ printf(_("Time: %s\n"), timestamp);
+ }
+
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sa_common.c sysstat-6.0.0/sa_common.c
+--- sysstat-6.0.0.orig/sa_common.c 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sa_common.c 2005-05-16 16:42:31.000000000 -0400
+@@ -380,7 +380,7 @@
+ mktime(loc_time);
+ }
+ else
+- loc_time = localtime(&(file_hdr->sa_ust_time));
++ loc_time = localtime((time_t *)(&(file_hdr->sa_ust_time)));
+
+ if (!format)
+ /* No output format (we are not using sadf) */
+@@ -406,7 +406,7 @@
+
+ while (index < file_hdr->sa_iface) {
+ st_net_dev_j = st_net_dev[ref] + index;
+- if (!strcmp(st_net_dev_i->interface, st_net_dev_j->interface)) {
++ if (!strcmp((char *)st_net_dev_i->interface, (char *)st_net_dev_j->interface)) {
+ /*
+ * Network interface found.
+ * If a counter has decreased, then we may assume that the
+@@ -465,7 +465,7 @@
+ if (!ovfw) {
+ /* OK: assume here that the device was actually unregistered */
+ memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+- strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++ strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+ }
+ }
+ return index;
+@@ -476,9 +476,9 @@
+ /* Network interface not found: Look for the first free structure */
+ for (index = 0; index < file_hdr->sa_iface; index++) {
+ st_net_dev_j = st_net_dev[ref] + index;
+- if (!strcmp(st_net_dev_j->interface, "?")) {
++ if (!strcmp((char *)st_net_dev_j->interface, "?")) {
+ memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+- strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++ strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+ break;
+ }
+ }
+@@ -489,7 +489,7 @@
+ st_net_dev_j = st_net_dev[ref] + index;
+ /* Since the name is not the same, reset all the structure */
+ memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+- strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++ strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+
+ return index;
+ }
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sadc.c sysstat-6.0.0/sadc.c
+--- sysstat-6.0.0.orig/sadc.c 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sadc.c 2005-05-16 16:33:19.000000000 -0400
+@@ -1419,7 +1419,7 @@
+ * old file with more interfaces than are actually available now.
+ */
+ st_net_dev_i = st_net_dev + dev++;
+- strcpy(st_net_dev_i->interface, "?");
++ strcpy((char *)(st_net_dev_i->interface), "?");
+ }
+ }
+ }
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sadf.c sysstat-6.0.0/sadf.c
+--- sysstat-6.0.0.orig/sadf.c 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sadf.c 2005-05-16 16:47:18.000000000 -0400
+@@ -136,10 +136,10 @@
+ if (PRINT_TRUE_TIME(flags) &&
+ ((format == S_O_DB_OPTION) || (format == S_O_XML_OPTION)))
+ /* '-d -t' or '-x -t' */
+- ltm = localtime(&file_stats[curr].ust_time);
++ ltm = localtime((time_t *)(&file_stats[curr].ust_time));
+ else
+ /* '-p' or '-p -t' or '-d' or '-x' */
+- ltm = gmtime(&file_stats[curr].ust_time);
++ ltm = gmtime((time_t *)(&file_stats[curr].ust_time));
+
+ loc_time = *ltm;
+ }
+@@ -675,7 +675,7 @@
+
+ for (i = 0; i < file_hdr.sa_iface; i++, ++sndi) {
+
+- if (!strcmp((ifc = sndi->interface), "?"))
++ if (!strcmp((ifc = (char *)sndi->interface), "?"))
+ continue;
+
+ j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+@@ -722,7 +722,7 @@
+
+ for (i = 0; i < file_hdr.sa_iface; i++, ++sndi) {
+
+- if (!strcmp((ifc = sndi->interface), "?"))
++ if (!strcmp((ifc = (char *)sndi->interface), "?"))
+ continue;
+
+ j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+@@ -1231,7 +1231,7 @@
+
+ for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+
+- if (!strcmp(sndi->interface, "?"))
++ if (!strcmp((char *)sndi->interface, "?"))
+ continue;
+ j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+ sndj = st_net_dev[!curr] + j;
+@@ -1411,7 +1411,7 @@
+ {
+ printf("File: %s (%#x)\n", dfile, file_hdr->sa_magic);
+
+- print_gal_header(localtime(&(file_hdr->sa_ust_time)), file_hdr->sa_sysname,
++ print_gal_header(localtime((time_t *)(&(file_hdr->sa_ust_time))), file_hdr->sa_sysname,
+ file_hdr->sa_release, file_hdr->sa_nodename);
+
+ printf("Activity flag: %#x\n", file_hdr->sa_actflag);
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sa.h sysstat-6.0.0/sa.h
+--- sysstat-6.0.0.orig/sa.h 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sa.h 2005-05-16 16:38:10.000000000 -0400
+@@ -489,7 +489,7 @@
+ struct stats_one_cpu *);
+ extern char *get_devname(unsigned int, unsigned int, int);
+ extern void init_bitmap(unsigned char [], unsigned char, unsigned int);
+-extern void init_stats(struct file_stats [], unsigned int [][]);
++extern void init_stats(struct file_stats [], unsigned int [DIM][NR_IRQS]);
+ extern int next_slice(unsigned long long, unsigned long long,
+ struct file_hdr *, int, long);
+ extern int parse_sar_opt(char * [], int, unsigned int *,
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sar.c sysstat-6.0.0/sar.c
+--- sysstat-6.0.0.orig/sar.c 2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sar.c 2005-05-16 16:43:19.000000000 -0400
+@@ -213,7 +213,7 @@
+ loc_time.tm_sec = file_stats[curr].second;
+ }
+ else {
+- ltm = localtime(&file_stats[curr].ust_time);
++ ltm = localtime((time_t *)(&file_stats[curr].ust_time));
+ loc_time = *ltm;
+ }
+ }
+@@ -577,7 +577,7 @@
+
+ for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+
+- if (!strcmp(sndi->interface, "?"))
++ if (!strcmp((char *)sndi->interface, "?"))
+ continue;
+ j = check_iface_reg(&file_hdr, st_net_dev, curr, prev, i);
+ sndj = st_net_dev[prev] + j;
+@@ -608,7 +608,7 @@
+
+ for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+
+- if (!strcmp(sndi->interface, "?"))
++ if (!strcmp((char *)sndi->interface, "?"))
+ continue;
+ j = check_iface_reg(&file_hdr, st_net_dev, curr, prev, i);
+ sndj = st_net_dev[prev] + j;
diff --git a/app-admin/sysstat/sysstat-6.0.0.ebuild b/app-admin/sysstat/sysstat-6.0.0.ebuild
new file mode 100644
index 000000000000..f3ac93586770
--- /dev/null
+++ b/app-admin/sysstat/sysstat-6.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-6.0.0.ebuild,v 1.1 2005/05/16 20:50:08 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
+SRC_URI="http://perso.wanadoo.fr/sebastien.godard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="virtual/libc"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2:${CFLAGS}:" Makefile
+ sed -i -e '1d;2i # Crontab sample for app-admin/sysstat' -e '2d;3d;s:PREFIX:/usr:' crontab.sample
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ yes '' | make config
+ use nls || sed -i 's/\(ENABLE_NLS\ =\ \)y/\1n/g' build/CONFIG
+ make PREFIX=/usr || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man{1,8}
+ dodir /var/log/sa
+ keepdir /var/log/sa
+ dodir /etc/cron.d
+ cp ./crontab.sample ${D}/etc/cron.d/sysstat
+
+ make \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MAN_DIR=/usr/share/man \
+ DOC_DIR=/usr/share/doc/${PF} \
+ install || die
+}