summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-04-10 18:35:08 +0000
committerSebastian Pipping <sping@gentoo.org>2011-04-10 18:35:08 +0000
commit0980d193e75ac9a4c73649e1b6f0d2b973681b34 (patch)
treebec6f3c114bc717e03fc8362e7e10271f3a6ade6 /app-admin/smolt
parentAdd blocker for kdelibs >=4.6, bug 357545 (diff)
downloadgentoo-2-0980d193e75ac9a4c73649e1b6f0d2b973681b34.tar.gz
gentoo-2-0980d193e75ac9a4c73649e1b6f0d2b973681b34.tar.bz2
gentoo-2-0980d193e75ac9a4c73649e1b6f0d2b973681b34.zip
app-admin/smolt: Bump to 1.4.3 (bug #313423)
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/smolt')
-rw-r--r--app-admin/smolt/ChangeLog13
-rw-r--r--app-admin/smolt/files/smolt-1.4.3-disable-distro-data.patch11
-rw-r--r--app-admin/smolt/files/smolt-1.4.3-hwdata-dir.patch22
-rw-r--r--app-admin/smolt/files/smolt-1.4.3-makefile-py-files.patch26
-rw-r--r--app-admin/smolt/smolt-1.4.3.ebuild93
5 files changed, 164 insertions, 1 deletions
diff --git a/app-admin/smolt/ChangeLog b/app-admin/smolt/ChangeLog
index 59cca89bc33d..dff53c0c6cbe 100644
--- a/app-admin/smolt/ChangeLog
+++ b/app-admin/smolt/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-admin/smolt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/smolt/ChangeLog,v 1.6 2011/04/05 05:11:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/smolt/ChangeLog,v 1.7 2011/04/10 18:35:08 sping Exp $
+
+*smolt-1.4.3 (10 Apr 2011)
+
+ 10 Apr 2011; Sebastian Pipping <sping@gentoo.org> +smolt-1.4.3.ebuild,
+ +files/smolt-1.4.3-disable-distro-data.patch,
+ +files/smolt-1.4.3-hwdata-dir.patch,
+ +files/smolt-1.4.3-makefile-py-files.patch:
+ Bump to 1.4.3 which is using udev, not HAL. Add dependencies udev, usbutils,
+ pciutils, sed. Collection of gentoo-specific data is disabled until the
+ server machine can actually handle such data. Many thanks to Alexandre
+ Rostovtsev for research and patches. (bug #313423)
05 Apr 2011; Ulrich Mueller <ulm@gentoo.org> smolt-1.2.ebuild,
smolt-1.4.ebuild, smolt-1.4.2.ebuild:
diff --git a/app-admin/smolt/files/smolt-1.4.3-disable-distro-data.patch b/app-admin/smolt/files/smolt-1.4.3-disable-distro-data.patch
new file mode 100644
index 000000000000..04d9cfbfd261
--- /dev/null
+++ b/app-admin/smolt/files/smolt-1.4.3-disable-distro-data.patch
@@ -0,0 +1,11 @@
+--- client/distros/gentoo/main.py 2011-04-10 20:15:47.957683728 +0200
++++ client/distros/gentoo/main.py 2011-04-10 20:16:52.504183850 +0200
+@@ -61,7 +61,7 @@
+ """
+ Returns True if we run on top of Gentoo, else False.
+ """
+- return os.path.exists('/etc/gentoo-release')
++ return False # sping: Too early to enable
+
+ def gather(self, debug=False):
+ def _stage(text):
diff --git a/app-admin/smolt/files/smolt-1.4.3-hwdata-dir.patch b/app-admin/smolt/files/smolt-1.4.3-hwdata-dir.patch
new file mode 100644
index 000000000000..1820f8207a73
--- /dev/null
+++ b/app-admin/smolt/files/smolt-1.4.3-hwdata-dir.patch
@@ -0,0 +1,22 @@
+--- a/client/config.py
++++ b/client/config.py
+@@ -14,6 +14,7 @@ PUB_UUID = "/etc/smolt/pub-uuid"
+ PUB_UUID = "/etc/smolt/pub-uuid"
+ #UUID_DB = "/etc/smolt/uuiddb.cfg"
+ #ADMIN_TOKEN = "/etc/sysconfig/smolt-token"
++#HWDATA_DIR = "/usr/share/hwdata"
+
+
+ #These are the defaults taken from the source code.
+--- a/client/hwdata.py
++++ b/client/hwdata.py
+@@ -20,7 +20,8 @@ class DeviceMap:
+ self.vendors['usb'] = self.device_map('usb')
+
+ def device_map(self, bus='pci'):
+- fn = "/usr/share/hwdata/%s.ids" % bus
++ from smolt import get_config_attr
++ fn = "%s/%s.ids" % (get_config_attr("HWDATA_DIR", "/usr/share/hwdata"), bus)
+ fo = open(fn, 'r')
+ vendors = {}
+ curvendor = None
diff --git a/app-admin/smolt/files/smolt-1.4.3-makefile-py-files.patch b/app-admin/smolt/files/smolt-1.4.3-makefile-py-files.patch
new file mode 100644
index 000000000000..33f5f8a57b8a
--- /dev/null
+++ b/app-admin/smolt/files/smolt-1.4.3-makefile-py-files.patch
@@ -0,0 +1,26 @@
+From dd41ac17a04d4689583aa5ec8b3bb467b43a24ce Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Tue, 29 Mar 2011 00:11:34 -0400
+Subject: [PATCH] Add devicelist.py and hwdata.py to client Makefile
+
+Signed-off-by: Alexandre Rostovtsev <tetromino@gmail.com>
+---
+ client/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/client/Makefile b/client/Makefile
+index 2164bf7..8bd5f1c 100644
+--- a/client/Makefile
++++ b/client/Makefile
+@@ -1,7 +1,7 @@
+ PO_FILES=$(wildcard po/*.po)
+ MO_FILES=$(patsubst %.po,%.mo,$(PO_FILES))
+ # echo PY_FILES=$(ls -1 *.py | grep -v '^\(create_monthly\|getLink\|haldump\|hammer_add\|makeuuid\|starhscale\).py$' | sort)
+-PY_FILES=config.py deleteProfile.py fs_util.py gate.py gui.py i18n.py __init__.py MultipartPostHandler.py os_detect.py privacypolicy.py scan.py sendProfile.py smolt_config.py smoltFirstBoot.py smoltGui.py smolt_mythtv.py smolt.py software.py uuiddb.py
++PY_FILES=config.py deleteProfile.py devicelist.py fs_util.py gate.py gui.py hwdata.py i18n.py __init__.py MultipartPostHandler.py os_detect.py privacypolicy.py scan.py sendProfile.py smolt_config.py smoltFirstBoot.py smoltGui.py smolt_mythtv.py smolt.py software.py uuiddb.py
+ DIRED_MO_FILES=$(patsubst po/%.mo,mo/%/LC_MESSAGES/$(NAME).mo,$(MO_FILES))
+
+
+--
+1.7.4.1
+
diff --git a/app-admin/smolt/smolt-1.4.3.ebuild b/app-admin/smolt/smolt-1.4.3.ebuild
new file mode 100644
index 000000000000..8f282c5a2ba2
--- /dev/null
+++ b/app-admin/smolt/smolt-1.4.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/smolt/smolt-1.4.3.ebuild,v 1.1 2011/04/10 18:35:08 sping Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="The Fedora hardware profiler"
+HOMEPAGE="https://fedorahosted.org/smolt/"
+SRC_URI="https://fedorahosted.org/releases/s/m/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+COMMON_DEPS="sys-devel/gettext"
+
+DEPEND="${COMMON_DEPS}
+ sys-apps/sed"
+
+RDEPEND="${COMMON_DEPS}
+ >=dev-python/rhpl-0.213
+ >=dev-python/urlgrabber-3.0.0
+ >=dev-python/simplejson-1.7.1
+ sys-apps/pciutils
+ sys-apps/usbutils
+ sys-fs/udev
+ qt4? ( dev-python/PyQt4 )"
+
+S="${S}/client"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ epatch "${FILESDIR}/${P}-makefile-py-files.patch" \
+ "${FILESDIR}/${P}-hwdata-dir.patch" \
+ "${FILESDIR}/${P}-disable-distro-data.patch"
+
+ # Make it use {usb,pci}.ids of pciutils/usbutils
+ sed -e "s:^#HWDATA_DIR = .*:HWDATA_DIR = \"${ROOT}/usr/share/misc\":" -i config.py || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" \
+ || die "Install failed"
+ insinto "/usr/share/smolt/client"
+ doins -r distros
+
+ if ! use qt4; then
+ rm "${D}"/usr/bin/smoltGui \
+ "${D}"/usr/share/smolt/client/{gui,smoltGui}.py \
+ "${D}"/usr/share/applications/smolt.desktop \
+ "${D}"/usr/share/man/man1/smoltGui.1.* \
+ || die "rm failed"
+ rmdir "${D}"/usr/share/applications || die "rmdir failed"
+ fi
+
+ bzip2 -9 "${D}"/usr/share/doc/${PF}/PrivacyPolicy || die "bzip2 failed"
+ dodoc ../README ../TODO || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN} || die "newinitd failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+
+ if ! [ -f "${ROOT}"/etc/smolt/hw-uuid ]; then
+ elog "Creating this machines UUID in ${ROOT}etc/smolt/hw-uuid"
+ cat /proc/sys/kernel/random/uuid > "${ROOT}"/etc/smolt/hw-uuid
+ fi
+ chmod 0444 "${ROOT}"/etc/smolt/hw-uuid
+ UUID=$(cat "${ROOT}"/etc/smolt/hw-uuid)
+ echo
+ elog "Your UUID is: ${UUID}"
+ echo
+ elog "Call smoltSendProfile as root in order to initialize your profile."
+ echo
+ elog "You can withdraw it from the server if you wish to with"
+ elog " smoltDeleteProfile any time later on."
+ echo
+
+ if use qt4 && has_version "<dev-lang/python-2.5"; then
+ elog "If you want to view your profile on the web from within smoltGui,"
+ elog "you should have a link mozilla-firefox -> firefox in your path."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}