summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-15 16:23:04 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-15 16:23:04 +0000
commit1c51bed5bca47e14da35526c7f6f17c9233fd910 (patch)
tree7c883394b0b9fd001b2ffb2b41d0b5bc827e705d /app-admin/realpath/realpath-1.9.16.ebuild
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-1c51bed5bca47e14da35526c7f6f17c9233fd910.tar.gz
gentoo-2-1c51bed5bca47e14da35526c7f6f17c9233fd910.tar.bz2
gentoo-2-1c51bed5bca47e14da35526c7f6f17c9233fd910.zip
New version. Added shell-tools herd as maintainer
Diffstat (limited to 'app-admin/realpath/realpath-1.9.16.ebuild')
-rw-r--r--app-admin/realpath/realpath-1.9.16.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/realpath/realpath-1.9.16.ebuild b/app-admin/realpath/realpath-1.9.16.ebuild
new file mode 100644
index 000000000000..34c420785d30
--- /dev/null
+++ b/app-admin/realpath/realpath-1.9.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/realpath/realpath-1.9.16.ebuild,v 1.1 2004/12/15 16:23:04 ciaranm Exp $
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath.html"
+SRC_URI="mirror://debian/pool/main/d/dwww/dwww_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~amd64 ~ppc64 ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/dwww-${PV}
+
+src_unpack() {
+ if use ppc-macos; then
+ local dirname="dwww-${PV}"
+ tar xzf ${DISTDIR}/${A} \
+ ${dirname}/Makefile \
+ ${dirname}/realpath.c \
+ ${dirname}/README \
+ ${dirname}/TODO \
+ ${dirname}/BUGS \
+ ${dirname}/man/realpath.1 || die "unpack failed."
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ make LIBS='' VERSION=$PV realpath || die
+}
+
+src_install() {
+ dobin realpath || die
+ doman man/realpath.1
+ dodoc README TODO BUGS
+}