summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-12-13 02:08:54 +0000
committerDror Levin <spatz@gentoo.org>2009-12-13 02:08:54 +0000
commitd8ef65388114f5f07f94b5096a950a0bc19e194b (patch)
tree5e2c393afb16d390dd644c6437be5b64026fdf10 /app-admin/keepassx
parentSimplify src_test(). (diff)
downloadgentoo-2-d8ef65388114f5f07f94b5096a950a0bc19e194b.tar.gz
gentoo-2-d8ef65388114f5f07f94b5096a950a0bc19e194b.tar.bz2
gentoo-2-d8ef65388114f5f07f94b5096a950a0bc19e194b.zip
Backport patch from trunk to fix compilation with Qt-4.6, bug 295466.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/ChangeLog6
-rw-r--r--app-admin/keepassx/files/keepassx-0.4.1-compile-with-qt-4.6.patch11
-rw-r--r--app-admin/keepassx/keepassx-0.4.1.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index 93970806e89a..70ffacb7954c 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.42 2009/11/17 22:35:37 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.43 2009/12/13 02:08:53 spatz Exp $
+
+ 13 Dec 2009; Dror Levin <spatz@gentoo.org> keepassx-0.4.1.ebuild,
+ +files/keepassx-0.4.1-compile-with-qt-4.6.patch:
+ Backport patch from trunk to fix compilation with Qt-4.6, bug 295466.
17 Nov 2009; Dror Levin <spatz@gentoo.org> keepassx-0.4.1.ebuild:
Fix pch USE flag handling, bug 271658.
diff --git a/app-admin/keepassx/files/keepassx-0.4.1-compile-with-qt-4.6.patch b/app-admin/keepassx/files/keepassx-0.4.1-compile-with-qt-4.6.patch
new file mode 100644
index 000000000000..26aa51dc0836
--- /dev/null
+++ b/app-admin/keepassx/files/keepassx-0.4.1-compile-with-qt-4.6.patch
@@ -0,0 +1,11 @@
+--- trunk/src/Database.h 2009/12/12 23:06:47 349
++++ trunk/src/Database.h 2009/12/12 23:28:46 350
+@@ -233,7 +233,7 @@
+ /*!
+ This is the common base interface for databases. Every database class must implement this interface necessarily.
+ */
+-class IDatabase:public QObject{
++class IDatabase{
+ public:
+ virtual ~IDatabase(){};
+
diff --git a/app-admin/keepassx/keepassx-0.4.1.ebuild b/app-admin/keepassx/keepassx-0.4.1.ebuild
index 9f195244214e..eab0658cc6f7 100644
--- a/app-admin/keepassx/keepassx-0.4.1.ebuild
+++ b/app-admin/keepassx/keepassx-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.4.1.ebuild,v 1.3 2009/11/17 22:35:37 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.4.1.ebuild,v 1.4 2009/12/13 02:08:53 spatz Exp $
EAPI="2"
@@ -20,6 +20,8 @@ DEPEND="x11-libs/qt-core:4
x11-libs/qt-xmlpatterns:4"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-compile-with-qt-4.6.patch" )
+
src_configure() {
local conf_pch
use pch && conf_pch="PRECOMPILED=1" || conf_pch="PRECOMPILED=0"