summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-01-22 07:13:19 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-01-22 07:13:19 +0000
commit4b36da8c3048e61daeefa1dce8694649f2c97d1e (patch)
tree88f7400c6db23e0dfb9a5d923e56bc19300392e2 /app-admin/eselect-wxwidgets/files
parentVersion bump. (diff)
downloadgentoo-2-4b36da8c3048e61daeefa1dce8694649f2c97d1e.tar.gz
gentoo-2-4b36da8c3048e61daeefa1dce8694649f2c97d1e.tar.bz2
gentoo-2-4b36da8c3048e61daeefa1dce8694649f2c97d1e.zip
Remove old.
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-wxwidgets/files')
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wx-config-1.138
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wxrc-1.138
-rw-r--r--app-admin/eselect-wxwidgets/files/wxwidgets.eselect-0.8246
-rw-r--r--app-admin/eselect-wxwidgets/files/wxwin.m4366
4 files changed, 0 insertions, 688 deletions
diff --git a/app-admin/eselect-wxwidgets/files/wx-config-1.1 b/app-admin/eselect-wxwidgets/files/wx-config-1.1
deleted file mode 100755
index 03f20f3bad7f..000000000000
--- a/app-admin/eselect-wxwidgets/files/wx-config-1.1
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh -
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wx-config-1.1,v 1.1 2009/07/19 02:56:08 dirtyepic Exp $
-#
-# /usr/bin/wx-config
-#
-# a lame wx-config wrapper (bugs to wxwidgets@gentoo.org)
-
-_wxerror() {
- cat >&2 <<- EOF
- An error occurred while calling wx-config:
-
- ${1}
-
- Please use \`eselect wxwidgets\` to select an available profile and try again.
- EOF
- exit 1
-}
-
-if [ -n "${WX_ECLASS_CONFIG}" ]; then
- ${WX_ECLASS_CONFIG} "$@"
- exit 0
-else
- if [ -e /var/lib/wxwidgets/current ]; then
- source /var/lib/wxwidgets/current
- else
- _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
- fi
-
- [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
-
- if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
- /usr/lib/wx/config/${WXCONFIG} "$@"
- else
- _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
- fi
- exit 0
-fi
-
diff --git a/app-admin/eselect-wxwidgets/files/wxrc-1.1 b/app-admin/eselect-wxwidgets/files/wxrc-1.1
deleted file mode 100755
index 9cca21e3d5ca..000000000000
--- a/app-admin/eselect-wxwidgets/files/wxrc-1.1
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh -
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wxrc-1.1,v 1.1 2009/07/19 02:56:08 dirtyepic Exp $
-#
-# /usr/bin/wxrc
-#
-# a lame wxrc wrapper (bugs to wxwidgets@gentoo.org)
-
-_wxerror() {
- cat >&2 <<- EOF
- An error occurred while calling wxrc:
-
- ${1}
-
- Please use \`eselect wxwidgets\` to select an available profile and try again.
- EOF
- exit 1
-}
-
-if [ -n "${WX_ECLASS_CONFIG}" ]; then
- $(${WX_ECLASS_CONFIG} --utility=wxrc) "$@"
- exit 0
-else
- if [ -e /var/lib/wxwidgets/current ]; then
- source /var/lib/wxwidgets/current
- else
- _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
- fi
-
- [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
-
- if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
- $(/usr/lib/wx/config/${WXCONFIG} --utility=wxrc) "$@"
- else
- _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
- fi
- exit 0
-fi
-
diff --git a/app-admin/eselect-wxwidgets/files/wxwidgets.eselect-0.8 b/app-admin/eselect-wxwidgets/files/wxwidgets.eselect-0.8
deleted file mode 100644
index 2be0a6500a2a..000000000000
--- a/app-admin/eselect-wxwidgets/files/wxwidgets.eselect-0.8
+++ /dev/null
@@ -1,246 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wxwidgets.eselect-0.8,v 1.2 2008/02/08 01:08:07 dirtyepic Exp $
-
-inherit config
-
-DESCRIPTION="Manage the system default wxWidgets profile."
-MAINTAINER="dirtyepic@gentoo.org"
-VERSION=0.8
-
-WXCONFFILE=/var/lib/wxwidgets/current
-WXCONFDIR=/usr/lib/wx/config
-
-find_targets() {
- local conf
- for conf in ${WXCONFDIR}/*; do
- [[ -f ${conf} && -x ${conf} ]] && basename ${conf}
- done
-}
-
-set_config() {
- local target="${1}" targets
-
- # selected by number
- if is_number "${target}"; then
- targets=( $(find_targets) )
- [[ ${1} -ge 1 && ${1} -le ${#targets[@]} ]] \
- || die -q "Number out of range: ${1}"
- target=${targets[$(( ${target} - 1 ))]}
- fi
-
- if [[ ${target} == "none" ]]; then
- # none is a special case
- :
- else
- [[ ! -f ${WXCONFDIR}/${target} ]] && \
- die -q "\"${1}\" doesn't appear to be a valid profile name"
- fi
-
- echo
- echo "Setting wxWidgets profile to ${target}"
- echo
- store_config ${WXCONFFILE} WXCONFIG ${target}
-
- if [[ ! ${target} == "none" ]]; then
- # expose the slot number of the selected target for various uses
- local wxslot
- OIFS=${IFS}
- IFS=-
- set -- ${target}
- wxslot=${4}
- IFS=${OIFS}
- fi
-
- # symlink bakefile presets to current slot (Bug #209150)
- local f
- pushd /usr/share/bakefile/presets/ &> /dev/null
- for f in .bkl _unix.bkl _win32.bkl; do
- if [[ -e wx${f} || -L wx${f} ]]; then
- rm -f wx${f} || die -q "Error removing wx${f}"
- fi
- if [[ ! ${target} == "none" ]]; then
- ln -sf wx${wxslot/./}${f} wx${f} \
- || die -q "Error symlinking wx${wxslot/./}${f}"
- fi
- done
- popd &> /dev/null
-}
-
-### show action ###
-
-describe_show() {
- echo "Show the currently selected profile"
-}
-
-do_show() {
- [[ ${#@} -gt 0 ]] && die -q "Too many parameters"
-
- write_list_start "Current wxWidgets profile:"
- if [[ -e ${WXCONFFILE} ]]; then
- write_kv_list_entry "$(load_config ${WXCONFFILE} WXCONFIG)" ""
- else
- write_kv_list_entry "(none)" ""
- fi
-}
-
-### list action ###
-
-describe_list() {
- echo "List available profiles"
-}
-
-do_list() {
- local i targets
- # targets is an array containing names of available configs
- targets=( $(find_targets) )
-
- if [[ -n ${targets[@]} ]]; then
- for (( i = 0; i < ${#targets[@]}; i++ )); do
- if [[ -e ${WXCONFFILE} ]]; then
- # highlight current version
- [[ ${targets[${i}]} == $(load_config ${WXCONFFILE} WXCONFIG) ]] \
- && targets[${i}]="$(highlight ${targets[${i}]}) *"
- fi
- done
- write_list_start "Available wxWidgets profiles:"
- write_numbered_list "${targets[@]}"
- else
- write_kv_list_entry "(none found)" ""
- fi
-}
-
-### set action ###
-
-describe_set() {
- echo "Set the system wxWidgets profile"
-}
-
-describe_set_options() {
- echo "target: profile name or number (gotten from 'list')"
-}
-
-describe_set_parameters() {
- echo "<target>"
-}
-
-do_set() {
- [[ ! ${#@} -eq 1 ]] \
- && die -q "You must specify a profile name or number"
-
- [[ -w "${ROOT}"/var/lib ]] \
- || die -q "You need proper write permissions. Please run as root."
-
- set_config "${1}"
-}
-
-describe_update() {
- echo "Check current profile and update it if invalid (internal use only)"
-}
-
-do_update() {
- [[ ! -e ${WXCONFFILE} ]] && do_set none
-
- currconf=$(load_config ${WXCONFFILE} WXCONFIG)
-
- # if current config is "none" leave it alone
- [[ ${currconf} == none ]] && return 0
-
- # if current config is valid leave it alone
- [[ -e ${WXCONFDIR}/${currconf} ]] && return 0
-
- # split the config string into components
- OIFS=${IFS}
- IFS=-
- set -- ${currconf}
- IFS=${OIFS}
-
- declare -a wxtoolkit wxchar wxdebug wxver
-
- # put selected components into the first element of the array
- wxtoolkit=(${1})
- wxchar=(${2})
- wxdebug=(${3})
- wxver=(${4})
-
- # put available components into next element(s) of array
- local component toolkit char debug ver element opt
-
- for component in toolkit char debug ver; do
- element=1
- case ${component} in
- toolkit)
- for opt in base gtk2; do
- if [[ ${opt} == ${wxtoolkit[0]} ]]; then
- continue
- else
- wxtoolkit[${element}]=${opt}
- (( element++ ))
- fi
- done
- ;;
-
- char)
- for opt in ansi unicode; do
- if [[ ${opt} == ${wxchar[0]} ]]; then
- continue
- else
- wxchar[${element}]=${opt}
- (( element++ ))
- fi
- done
- ;;
-
- debug)
- for opt in release debug; do
- if [[ ${opt} == ${wxdebug[0]} ]]; then
- continue
- else
- wxdebug[${element}]=${opt}
- (( element++ ))
- fi
- done
- ;;
-
- ver)
- for opt in 2.10 2.8 2.6; do
- if [[ ${opt} == ${wxver[0]} ]]; then
- continue
- else
- wxver[${element}]=${opt}
- (( element++ ))
- fi
- done
- ;;
- esac
- done
-
- # Now we iterate through the installed wx-configs and find the closest match
- # ( debug > char > toolkit > ver )
-
- local d c t v checkconf foundconf
-
- for (( v = 0 ; v < ${#wxver[@]} ; v++ )); do
- for (( t = 0 ; t < ${#wxtoolkit[@]} ; t++ )); do
- for (( c = 0 ; c < ${#wxchar[@]} ; c++ )); do
- for (( d = 0 ; d < ${#wxdebug[@]} ; d++ )); do
- checkconf="${wxtoolkit[$t]}-${wxchar[$c]}-${wxdebug[$d]}-${wxver[$v]}"
- [[ -e ${WXCONFDIR}/${checkconf} ]] || continue
- foundconf=${checkconf}
- break 4
- done
- done
- done
- done
-
- [[ -z ${foundconf} ]] && foundconf="none"
-
- echo
- write_warning_msg "Your currently selected wxWidgets profile: ( ${currconf} )"
- write_warning_msg "is no longer available."
- write_warning_msg
- write_warning_msg "The closest matching profile: ( ${foundconf} )"
- write_warning_msg "will be activated in its place."
-
- do_set ${foundconf}
-}
diff --git a/app-admin/eselect-wxwidgets/files/wxwin.m4 b/app-admin/eselect-wxwidgets/files/wxwin.m4
deleted file mode 100644
index 52c55e2e6e6b..000000000000
--- a/app-admin/eselect-wxwidgets/files/wxwin.m4
+++ /dev/null
@@ -1,366 +0,0 @@
-dnl ---------------------------------------------------------------------------
-dnl Macros for wxWidgets detection. Typically used in configure.in as:
-dnl
-dnl AC_ARG_ENABLE(...)
-dnl AC_ARG_WITH(...)
-dnl ...
-dnl AM_OPTIONS_WXCONFIG
-dnl ...
-dnl ...
-dnl AM_PATH_WXCONFIG(2.6.0, wxWin=1)
-dnl if test "$wxWin" != 1; then
-dnl AC_MSG_ERROR([
-dnl wxWidgets must be installed on your system
-dnl but wx-config script couldn't be found.
-dnl
-dnl Please check that wx-config is in path, the directory
-dnl where wxWidgets libraries are installed (returned by
-dnl 'wx-config --libs' command) is in LD_LIBRARY_PATH or
-dnl equivalent variable and wxWidgets version is 2.3.4 or above.
-dnl ])
-dnl fi
-dnl CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
-dnl CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
-dnl CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
-dnl
-dnl LIBS="$LIBS $WX_LIBS"
-dnl ---------------------------------------------------------------------------
-
-dnl ---------------------------------------------------------------------------
-dnl AM_OPTIONS_WXCONFIG
-dnl
-dnl adds support for --wx-prefix, --wx-exec-prefix, --with-wxdir and
-dnl --wx-config command line options
-dnl ---------------------------------------------------------------------------
-
-AC_DEFUN([AM_OPTIONS_WXCONFIG],
-[
- AC_ARG_WITH(wxdir,
- [ --with-wxdir=PATH Use uninstalled version of wxWidgets in PATH],
- [ wx_config_name="$withval/wx-config"
- wx_config_args="--inplace"])
- AC_ARG_WITH(wx-config,
- [ --with-wx-config=CONFIG wx-config script to use (optional)],
- wx_config_name="$withval" )
- AC_ARG_WITH(wx-prefix,
- [ --with-wx-prefix=PREFIX Prefix where wxWidgets is installed (optional)],
- wx_config_prefix="$withval", wx_config_prefix="")
- AC_ARG_WITH(wx-exec-prefix,
- [ --with-wx-exec-prefix=PREFIX
- Exec prefix where wxWidgets is installed (optional)],
- wx_config_exec_prefix="$withval", wx_config_exec_prefix="")
-])
-
-dnl Helper macro for checking if wx version is at least $1.$2.$3, set's
-dnl wx_ver_ok=yes if it is:
-AC_DEFUN([_WX_PRIVATE_CHECK_VERSION],
-[
- wx_ver_ok=""
- if test "x$WX_VERSION" != x ; then
- if test $wx_config_major_version -gt $1; then
- wx_ver_ok=yes
- else
- if test $wx_config_major_version -eq $1; then
- if test $wx_config_minor_version -gt $2; then
- wx_ver_ok=yes
- else
- if test $wx_config_minor_version -eq $2; then
- if test $wx_config_micro_version -ge $3; then
- wx_ver_ok=yes
- fi
- fi
- fi
- fi
- fi
- fi
-])
-
-dnl ---------------------------------------------------------------------------
-dnl AM_PATH_WXCONFIG(VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND
-dnl [, WX-LIBS [, ADDITIONAL-WX-CONFIG-FLAGS]]]])
-dnl
-dnl Test for wxWidgets, and define WX_C*FLAGS, WX_LIBS and WX_LIBS_STATIC
-dnl (the latter is for static linking against wxWidgets). Set WX_CONFIG_NAME
-dnl environment variable to override the default name of the wx-config script
-dnl to use. Set WX_CONFIG_PATH to specify the full path to wx-config - in this
-dnl case the macro won't even waste time on tests for its existence.
-dnl
-dnl Optional WX-LIBS argument contains comma- or space-separated list of
-dnl wxWidgets libraries to link against (it may include contrib libraries). If
-dnl it is not specified then WX_LIBS and WX_LIBS_STATIC will contain flags to
-dnl link with all of the core wxWidgets libraries.
-dnl
-dnl Optional ADDITIONAL-WX-CONFIG-FLAGS argument is appended to wx-config
-dnl invocation command in present. It can be used to fine-tune lookup of
-dnl best wxWidgets build available.
-dnl
-dnl Example use:
-dnl AM_PATH_WXCONFIG([2.6.0], [wxWin=1], [wxWin=0], [html,core,net]
-dnl [--unicode --debug])
-dnl ---------------------------------------------------------------------------
-
-dnl
-dnl Get the cflags and libraries from the wx-config script
-dnl
-AC_DEFUN([AM_PATH_WXCONFIG],
-[
- dnl do we have wx-config name: it can be wx-config or wxd-config or ...
- if test x${WX_CONFIG_NAME+set} != xset ; then
- WX_CONFIG_NAME=wx-config
- fi
-
- if test "x$wx_config_name" != x ; then
- WX_CONFIG_NAME="$wx_config_name"
- fi
-
- dnl deal with optional prefixes
- if test x$wx_config_exec_prefix != x ; then
- wx_config_args="$wx_config_args --exec-prefix=$wx_config_exec_prefix"
- WX_LOOKUP_PATH="$wx_config_exec_prefix/bin"
- fi
- if test x$wx_config_prefix != x ; then
- wx_config_args="$wx_config_args --prefix=$wx_config_prefix"
- WX_LOOKUP_PATH="$WX_LOOKUP_PATH:$wx_config_prefix/bin"
- fi
- if test "$cross_compiling" = "yes"; then
- wx_config_args="$wx_config_args --host=$host_alias"
- fi
-
- dnl don't search the PATH if WX_CONFIG_NAME is absolute filename
- if test -x "$WX_CONFIG_NAME" ; then
- AC_MSG_CHECKING(for wx-config)
- WX_CONFIG_PATH="$WX_CONFIG_NAME"
- AC_MSG_RESULT($WX_CONFIG_PATH)
- else
- AC_PATH_PROG(WX_CONFIG_PATH, $WX_CONFIG_NAME, no, "$WX_LOOKUP_PATH:$PATH")
- fi
-
- if test "$WX_CONFIG_PATH" != "no" ; then
- WX_VERSION=""
-
- min_wx_version=ifelse([$1], ,2.2.1,$1)
- if test -z "$5" ; then
- AC_MSG_CHECKING([for wxWidgets version >= $min_wx_version])
- else
- AC_MSG_CHECKING([for wxWidgets version >= $min_wx_version ($5)])
- fi
-
- WX_CONFIG_WITH_ARGS="$WX_CONFIG_PATH $wx_config_args $5 $4"
-
- WX_VERSION=`$WX_CONFIG_WITH_ARGS --version 2>/dev/null`
- wx_config_major_version=`echo $WX_VERSION | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
- wx_config_minor_version=`echo $WX_VERSION | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
- wx_config_micro_version=`echo $WX_VERSION | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-
- wx_requested_major_version=`echo $min_wx_version | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
- wx_requested_minor_version=`echo $min_wx_version | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
- wx_requested_micro_version=`echo $min_wx_version | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-
- _WX_PRIVATE_CHECK_VERSION([$wx_requested_major_version],
- [$wx_requested_minor_version],
- [$wx_requested_micro_version])
-
- if test -n "$wx_ver_ok"; then
-
- AC_MSG_RESULT(yes (version $WX_VERSION))
- WX_LIBS=`$WX_CONFIG_WITH_ARGS --libs`
-
- dnl is this even still appropriate? --static is a real option now
- dnl and WX_CONFIG_WITH_ARGS is likely to contain it if that is
- dnl what the user actually wants, making this redundant at best.
- dnl For now keep it in case anyone actually used it in the past.
- AC_MSG_CHECKING([for wxWidgets static library])
- WX_LIBS_STATIC=`$WX_CONFIG_WITH_ARGS --static --libs 2>/dev/null`
- if test "x$WX_LIBS_STATIC" = "x"; then
- AC_MSG_RESULT(no)
- else
- AC_MSG_RESULT(yes)
- fi
-
- dnl starting with version 2.2.6 wx-config has --cppflags argument
- wx_has_cppflags=""
- if test $wx_config_major_version -gt 2; then
- wx_has_cppflags=yes
- else
- if test $wx_config_major_version -eq 2; then
- if test $wx_config_minor_version -gt 2; then
- wx_has_cppflags=yes
- else
- if test $wx_config_minor_version -eq 2; then
- if test $wx_config_micro_version -ge 6; then
- wx_has_cppflags=yes
- fi
- fi
- fi
- fi
- fi
-
- dnl starting with version 2.7.0 wx-config has --rescomp option
- wx_has_rescomp=""
- if test $wx_config_major_version -gt 2; then
- wx_has_rescomp=yes
- else
- if test $wx_config_major_version -eq 2; then
- if test $wx_config_minor_version -ge 7; then
- wx_has_rescomp=yes
- fi
- fi
- fi
- if test "x$wx_has_rescomp" = x ; then
- dnl cannot give any useful info for resource compiler
- WX_RESCOMP=
- else
- WX_RESCOMP=`$WX_CONFIG_WITH_ARGS --rescomp`
- fi
-
- if test "x$wx_has_cppflags" = x ; then
- dnl no choice but to define all flags like CFLAGS
- WX_CFLAGS=`$WX_CONFIG_WITH_ARGS --cflags`
- WX_CPPFLAGS=$WX_CFLAGS
- WX_CXXFLAGS=$WX_CFLAGS
-
- WX_CFLAGS_ONLY=$WX_CFLAGS
- WX_CXXFLAGS_ONLY=$WX_CFLAGS
- else
- dnl we have CPPFLAGS included in CFLAGS included in CXXFLAGS
- WX_CPPFLAGS=`$WX_CONFIG_WITH_ARGS --cppflags`
- WX_CXXFLAGS=`$WX_CONFIG_WITH_ARGS --cxxflags`
- WX_CFLAGS=`$WX_CONFIG_WITH_ARGS --cflags`
-
- WX_CFLAGS_ONLY=`echo $WX_CFLAGS | sed "s@^$WX_CPPFLAGS *@@"`
- WX_CXXFLAGS_ONLY=`echo $WX_CXXFLAGS | sed "s@^$WX_CFLAGS *@@"`
- fi
-
- ifelse([$2], , :, [$2])
-
- else
-
- if test "x$WX_VERSION" = x; then
- dnl no wx-config at all
- AC_MSG_RESULT(no)
- else
- AC_MSG_RESULT(no (version $WX_VERSION is not new enough))
- fi
-
- WX_CFLAGS=""
- WX_CPPFLAGS=""
- WX_CXXFLAGS=""
- WX_LIBS=""
- WX_LIBS_STATIC=""
- WX_RESCOMP=""
- ifelse([$3], , :, [$3])
-
- fi
- else
-
- WX_CFLAGS=""
- WX_CPPFLAGS=""
- WX_CXXFLAGS=""
- WX_LIBS=""
- WX_LIBS_STATIC=""
- WX_RESCOMP=""
-
- ifelse([$3], , :, [$3])
-
- fi
-
- AC_SUBST(WX_CPPFLAGS)
- AC_SUBST(WX_CFLAGS)
- AC_SUBST(WX_CXXFLAGS)
- AC_SUBST(WX_CFLAGS_ONLY)
- AC_SUBST(WX_CXXFLAGS_ONLY)
- AC_SUBST(WX_LIBS)
- AC_SUBST(WX_LIBS_STATIC)
- AC_SUBST(WX_VERSION)
- AC_SUBST(WX_RESCOMP)
-])
-
-dnl ---------------------------------------------------------------------------
-dnl Get information on the wxrc program for making C++, Python and xrs
-dnl resource files.
-dnl
-dnl AC_ARG_ENABLE(...)
-dnl AC_ARG_WITH(...)
-dnl ...
-dnl AM_OPTIONS_WXCONFIG
-dnl ...
-dnl AM_PATH_WXCONFIG(2.6.0, wxWin=1)
-dnl if test "$wxWin" != 1; then
-dnl AC_MSG_ERROR([
-dnl wxWidgets must be installed on your system
-dnl but wx-config script couldn't be found.
-dnl
-dnl Please check that wx-config is in path, the directory
-dnl where wxWidgets libraries are installed (returned by
-dnl 'wx-config --libs' command) is in LD_LIBRARY_PATH or
-dnl equivalent variable and wxWidgets version is 2.6.0 or above.
-dnl ])
-dnl fi
-dnl
-dnl AM_PATH_WXRC([HAVE_WXRC=1], [HAVE_WXRC=0])
-dnl if test "x$HAVE_WXRC" != x1; then
-dnl AC_MSG_ERROR([
-dnl The wxrc program was not installed or not found.
-dnl
-dnl Please check the wxWidgets installation.
-dnl ])
-dnl fi
-dnl
-dnl CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
-dnl CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
-dnl CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
-dnl
-dnl LDFLAGS="$LDFLAGS $WX_LIBS"
-dnl ---------------------------------------------------------------------------
-
-
-
-dnl ---------------------------------------------------------------------------
-dnl AM_PATH_WXRC([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
-dnl
-dnl Test for wxWidgets' wxrc program for creating either C++, Python or XRS
-dnl resources. The variable WXRC will be set and substituted in the configure
-dnl script and Makefiles.
-dnl
-dnl Example use:
-dnl AM_PATH_WXRC([wxrc=1], [wxrc=0])
-dnl ---------------------------------------------------------------------------
-
-dnl
-dnl wxrc program from the wx-config script
-dnl
-AC_DEFUN([AM_PATH_WXRC],
-[
- AC_ARG_VAR([WXRC], [Path to wxWidget's wxrc resource compiler])
-
- if test "x$WX_CONFIG_NAME" = x; then
- AC_MSG_ERROR([The wxrc tests must run after wxWidgets test.])
- else
-
- AC_MSG_CHECKING([for wxrc])
-
- if test "x$WXRC" = x ; then
- dnl wx-config --utility is a new addition to wxWidgets:
- _WX_PRIVATE_CHECK_VERSION(2,5,3)
- if test -n "$wx_ver_ok"; then
- WXRC=`$WX_CONFIG_WITH_ARGS --utility=wxrc`
- fi
- fi
-
- if test "x$WXRC" = x ; then
- AC_MSG_RESULT([not found])
- ifelse([$2], , :, [$2])
- else
- AC_MSG_RESULT([$WXRC])
- ifelse([$1], , :, [$1])
- fi
-
- AC_SUBST(WXRC)
- fi
-])