summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-06-05 17:56:48 +0000
committerMike Gilbert <floppym@gentoo.org>2014-06-05 17:56:48 +0000
commita86928234614c7bbd369e422d386f5933f32ea3e (patch)
treecbb80af146d24633f17fb71e817147639159e51c /app-admin/eselect-python
parentVersion bump. Update SRC_URI. (diff)
downloadgentoo-2-a86928234614c7bbd369e422d386f5933f32ea3e.tar.gz
gentoo-2-a86928234614c7bbd369e422d386f5933f32ea3e.tar.bz2
gentoo-2-a86928234614c7bbd369e422d386f5933f32ea3e.zip
Remove EAPI 1 ebuilds per QA request, bug 512124.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/ChangeLog6
-rw-r--r--app-admin/eselect-python/eselect-python-20091230.ebuild52
-rw-r--r--app-admin/eselect-python/eselect-python-20100321.ebuild52
3 files changed, 5 insertions, 105 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index f40bdb4ff224..96d7bfc4f06a 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.85 2014/02/02 16:32:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.86 2014/06/05 17:56:48 floppym Exp $
+
+ 05 Jun 2014; Mike Gilbert <floppym@gentoo.org>
+ -eselect-python-20091230.ebuild, -eselect-python-20100321.ebuild:
+ Remove EAPI 1 ebuilds per QA request, bug 512124.
02 Feb 2014; Fabian Groffen <grobian@gentoo.org>
eselect-python-20140125.ebuild, eselect-python-99999999.ebuild:
diff --git a/app-admin/eselect-python/eselect-python-20091230.ebuild b/app-admin/eselect-python/eselect-python-20091230.ebuild
deleted file mode 100644
index 13b74c62d703..000000000000
--- a/app-admin/eselect-python/eselect-python-20091230.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20091230.ebuild,v 1.9 2013/03/22 03:09:50 vapier Exp $
-
-EAPI="1"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- >=sys-devel/gcc-3.4"
-
-pkg_setup() {
- if [[ $(gcc-major-version) -lt 3 || ($(gcc-major-version) -eq 3 && $(gcc-minor-version) -lt 4) ]]; then
- die "GCC >=3.4 is required"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- ./autogen.sh || die "autogen.sh failed"
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-20090804" || ! has_version "${CATEGORY}/${PN}"; then
- run_eselect_python_update="1"
- fi
-}
-
-pkg_postinst() {
- if [[ "${run_eselect_python_update}" == "1" ]]; then
- ebegin "Running \`eselect python update\`"
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
- eend "$?"
- fi
-}
diff --git a/app-admin/eselect-python/eselect-python-20100321.ebuild b/app-admin/eselect-python/eselect-python-20100321.ebuild
deleted file mode 100644
index 7056c75a4c64..000000000000
--- a/app-admin/eselect-python/eselect-python-20100321.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20100321.ebuild,v 1.7 2013/03/22 03:09:50 vapier Exp $
-
-EAPI="1"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- >=sys-devel/gcc-3.4"
-
-pkg_setup() {
- if [[ $(gcc-major-version) -lt 3 || ($(gcc-major-version) -eq 3 && $(gcc-minor-version) -lt 4) ]]; then
- die "GCC >=3.4 is required"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- ./autogen.sh || die "autogen.sh failed"
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-20090804" || ! has_version "${CATEGORY}/${PN}"; then
- run_eselect_python_update="1"
- fi
-}
-
-pkg_postinst() {
- if [[ "${run_eselect_python_update}" == "1" ]]; then
- ebegin "Running \`eselect python update\`"
- eselect python update --python2 > /dev/null
- eend "$?"
- fi
-}