summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-06-07 02:36:16 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-06-07 02:36:16 +0000
commit51b3602f00fef2a5a848b0c41980ca5b7641d4da (patch)
tree517d6be716fac433b8b062ed66bbbcb7a0234135 /app-admin/eselect-compiler
parentStable on amd64 wrt security Bug #123022. (diff)
downloadgentoo-2-51b3602f00fef2a5a848b0c41980ca5b7641d4da.tar.gz
gentoo-2-51b3602f00fef2a5a848b0c41980ca5b7641d4da.tar.bz2
gentoo-2-51b3602f00fef2a5a848b0c41980ca5b7641d4da.zip
Make sure /lib/cpp is installed. Right now, the ebuild is just copying the wrapper to that location, but I'll have this handled properly by compiler.eselect in a later release.
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'app-admin/eselect-compiler')
-rw-r--r--app-admin/eselect-compiler/ChangeLog11
-rw-r--r--app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild6
-rw-r--r--app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r5.ebuild165
-rw-r--r--app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r53
4 files changed, 183 insertions, 2 deletions
diff --git a/app-admin/eselect-compiler/ChangeLog b/app-admin/eselect-compiler/ChangeLog
index 18221e01f17a..6c49f573aa10 100644
--- a/app-admin/eselect-compiler/ChangeLog
+++ b/app-admin/eselect-compiler/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/eselect-compiler
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/ChangeLog,v 1.19 2006/06/02 22:01:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/ChangeLog,v 1.20 2006/06/07 02:36:16 eradicator Exp $
+
+*eselect-compiler-2.0.0_rc1-r5 (07 Jun 2006)
+
+ 07 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ eselect-compiler-2.0.0_rc1-r4.ebuild,
+ +eselect-compiler-2.0.0_rc1-r5.ebuild:
+ Make sure /lib/cpp is installed. Right now, the ebuild is just copying the
+ wrapper to that location, but I'll have this handled properly by
+ compiler.eselect in a later release.
02 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
eselect-compiler-2.0.0_rc1-r4.ebuild:
diff --git a/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild
index 4199c72d1aa2..7404c15b52ec 100644
--- a/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild
+++ b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild,v 1.4 2006/06/02 22:17:20 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r4.ebuild,v 1.5 2006/06/07 02:36:16 eradicator Exp $
inherit eutils multilib toolchain-funcs
@@ -129,6 +129,10 @@ src_install() {
dodoc README
make DESTDIR="${D}" install || die
+ # For bug #135749
+ exeinto /lib
+ newexe ${D}/usr/libexec/eselect/compiler/compiler-wrapper cpp
+
doenvd ${FILESDIR}/25eselect-compiler
# This is installed by sys-devel/gcc-config
diff --git a/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r5.ebuild b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r5.ebuild
new file mode 100644
index 000000000000..5006c5420c4a
--- /dev/null
+++ b/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r5.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-compiler/eselect-compiler-2.0.0_rc1-r5.ebuild,v 1.1 2006/06/07 02:36:16 eradicator Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to configure the active toolchain compiler"
+HOMEPAGE="http://www.gentoo.org/"
+
+MY_PN="compiler-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI=" http://dev.gentoo.org/~eradicator/toolchain/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hardened"
+
+RDEPEND=">=app-admin/eselect-1.0_rc1"
+
+# We want to verify that compiler profiles exist for our toolchain
+pkg_setup() {
+ delete_invalid_profiles
+
+ local abi
+ for abi in $(get_all_abis) ; do
+ local ctarget=$(get_abi_CHOST ${abi})
+ if ! grep -q "^[[:space:]]*ctarget=${ctarget}$" ${ROOT}/etc/eselect/compiler/*.conf ; then
+ eerror "We weren't able to find a valid eselect compiler profile for ${abi}."
+ eerror "Please do the following to re-emerge gcc, then retry emerging"
+ eerror "eselect-compiler:"
+ eerror "# emerge -v --oneshot sys-devel/gcc"
+
+ die "Missing eselect-compiler profile for ${abi}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ # Activate the profiles
+ if [[ ! -f "${ROOT}/etc/eselect/compiler/selection.conf" ]] ; then
+ ewarn "This looks like the first time you are installing eselect-compiler. We are"
+ ewarn "activating toolchain profiles for the CTARGETs needed by your portage"
+ ewarn "profile. You should have profiles installed from compilers that you emerged"
+ ewarn "after October, 2005. If a compiler you have installed is missing an"
+ ewarn "eselect-compiler profile, you can either re-emerge the compiler, create the"
+ ewarn "profile yourself, or you can migrate profiles from gcc-config-1.x by doing:"
+ ewarn "# eselect compiler migrate"
+ ewarn
+ ewarn "Note that if you use the migration tool, your current profiles will be"
+ ewarn "replaced, so you should backup the data in /etc/eselect/compiler first."
+ echo
+ einfo "The following profiles have been activated. If an incorrect profile is"
+ einfo "chosen or an error is reported, please use 'eselect compiler set' to"
+ einfo "manually choose it"
+
+ local abi
+ for abi in $(get_all_abis) ; do
+ local ctarget=$(get_abi_CHOST ${abi})
+ local extra_options=""
+
+ if [[ ${abi} == ${DEFAULT_ABI} ]] ; then
+ extra_options="-n"
+ fi
+
+ local spec
+ if use hardened ; then
+ spec="hardened"
+ else
+ spec="vanilla"
+ fi
+
+ local isset=0
+ local tuple
+ for tuple in "${CHOST}" "${CTARGET}" "${ctarget}" ; do
+ local version
+ for version in "$(gcc-fullversion)" ; do
+ local profile
+ for profile in "${abi}-${spec}" "${spec}" "${abi}-default" "default" "${abi}-vanilla" "vanilla" ; do
+ if eselect compiler set ${tuple}-${version}/${profile} ${extra_options} &> /dev/null ; then
+ einfo "${abi}: ${tuple}-${version}/${profile}"
+
+ isset=1
+ break
+ fi
+ done
+ [[ ${isset} == 1 ]] && break
+ done
+ [[ ${isset} == 1 ]] && break
+ done
+
+ if [[ ${isset} == 0 ]] ; then
+ eerror "${abi}: Unable to determine an appropriate profile. Please set manually."
+ fi
+ done
+ else
+ eselect compiler update
+ fi
+
+ local file
+ local resource_profile=0
+ for file in ${ROOT}/etc/env.d/05gcc* ; do
+ if [[ -f ${file} ]] ; then
+ ewarn "Removing env.d entry which was used by gcc-config:"
+ ewarn " ${file}"
+
+ rm -f ${file}
+
+ resource_profile=1
+ fi
+ done
+
+ if [[ ${resource_profile} == 1 ]] ; then
+ echo
+ ewarn "You should source /etc/profile in your open shells."
+
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-inherit.patch
+}
+
+src_install() {
+ dodoc README
+ make DESTDIR="${D}" install || die
+
+ # For bug #135749
+ exeinto /lib
+ newexe ${D}/usr/libexec/eselect/compiler/compiler-wrapper cpp
+
+ doenvd ${FILESDIR}/25eselect-compiler
+
+ # This is installed by sys-devel/gcc-config
+ rm ${D}/usr/bin/gcc-config
+}
+
+# The profiles are protected by CONFIG_PROJECT until eselect-compiler is installed, so we need to clean out
+# the invalid profiles when eselect-compiler is first installed
+delete_invalid_profiles() {
+ # Some toolchain.eclass installed confs had some bugs in them. We
+ # could just use sed to update them, but then portage won't remove
+ # them automatically on unmerge.
+ local file
+ for file in $(grep "^[[:space:]]*chost=" ${ROOT}/etc/eselect/compiler/*.conf | cut -f1 -d:) ; do
+ rm ${file}
+ done
+ for file in $(grep "^[[:space:]]*spec=" ${ROOT}/etc/eselect/compiler/*.conf | cut -f1 -d:) ; do
+ rm ${file}
+ done
+
+ # First we need to clean out /etc/eselect/compiler as there may
+ # be some profiles in there which were not unmerged with gcc.
+ local item
+ for item in $(grep "^[[:space:]]*binpath=" ${ROOT}/etc/eselect/compiler/*.conf | sed 's/:.*binpath=/:/') ; do
+ local file=${item%:*}
+ local binpath=${item#*:}
+ [[ -d ${binpath} ]] || rm ${file}
+ done
+}
+
diff --git a/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r5 b/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r5
new file mode 100644
index 000000000000..e5670a7296b1
--- /dev/null
+++ b/app-admin/eselect-compiler/files/digest-eselect-compiler-2.0.0_rc1-r5
@@ -0,0 +1,3 @@
+MD5 b67d2f339f159da455d19c49e4868d9c compiler-config-2.0.0_rc1.tar.gz 117180
+RMD160 dbcd8120139c75f40ae2405746ab2a5f26e810b4 compiler-config-2.0.0_rc1.tar.gz 117180
+SHA256 a911a7b0a1184c576500df8530e77823f976dce387001c581ba89ac8edfe30c2 compiler-config-2.0.0_rc1.tar.gz 117180