summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-06-12 03:54:08 +0000
committerDonny Davies <woodchip@gentoo.org>2003-06-12 03:54:08 +0000
commit5c635e9793293b87265eef9630b0570b71d7ee25 (patch)
tree109e7578eef7827ae25f2db246b1508001af0541 /app-admin/bacula
parentbump. (diff)
downloadgentoo-2-5c635e9793293b87265eef9630b0570b71d7ee25.tar.gz
gentoo-2-5c635e9793293b87265eef9630b0570b71d7ee25.tar.bz2
gentoo-2-5c635e9793293b87265eef9630b0570b71d7ee25.zip
bump.
Diffstat (limited to 'app-admin/bacula')
-rw-r--r--app-admin/bacula/ChangeLog9
-rw-r--r--app-admin/bacula/Manifest6
-rw-r--r--app-admin/bacula/bacula-1.31.ebuild127
-rw-r--r--app-admin/bacula/files/bacula-init20
-rw-r--r--app-admin/bacula/files/digest-bacula-1.311
5 files changed, 152 insertions, 11 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
index 6edac58bf5bf..56e9778e30e7 100644
--- a/app-admin/bacula/ChangeLog
+++ b/app-admin/bacula/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/bacula
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.4 2003/03/28 09:18:02 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.5 2003/06/12 03:54:00 woodchip Exp $
+
+*bacula-1.31 (11 Jun 2003)
+
+ 11 Jun 2003; Donny Davies <woodchip@gentoo.org> bacula-1.31.ebuild,
+ files/bacula-init:
+ Update to latest release. Thanks to Rob de Beir <wakunga@hotmail.com>
+ for fixing various bugs, including: #17059, #21607.
*bacula-1.29 (29 Jan 2003)
diff --git a/app-admin/bacula/Manifest b/app-admin/bacula/Manifest
index 0231cb5b75bb..6cf55e38ac73 100644
--- a/app-admin/bacula/Manifest
+++ b/app-admin/bacula/Manifest
@@ -1,6 +1,6 @@
MD5 d0b027bb4191c0fe4933e37885720606 bacula-1.29.ebuild 3182
-MD5 0dceb58cc69e61482e56199e61e9fcb4 bacula-1.31.ebuild 3506
-MD5 78ee9b0b9fae3a7550c06088be1248a7 ChangeLog 835
-MD5 3db06c7a9aa4b834fc3f6b35f7d0b0a0 files/bacula-init 1826
+MD5 7157561ee7763ecedfc085d6ad988a2c bacula-1.31.ebuild 3606
+MD5 13266e753d07d6d50f50d0359c3ed11f ChangeLog 835
+MD5 6c389eb1976a8e1131b6af4bdde9b6f3 files/bacula-init 1925
MD5 6bd8611e451dde617342c14501fc36ba files/digest-bacula-1.29 64
MD5 91ecc1b976fb0c99c2797d4c9bece479 files/digest-bacula-1.31 72
diff --git a/app-admin/bacula/bacula-1.31.ebuild b/app-admin/bacula/bacula-1.31.ebuild
new file mode 100644
index 000000000000..a6bde50ea62a
--- /dev/null
+++ b/app-admin/bacula/bacula-1.31.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.31.ebuild,v 1.1 2003/06/12 03:54:00 woodchip Exp $
+
+DESCRIPTION="Bacula is a featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+
+NEWP=${P}-04Jun03
+S=${WORKDIR}/${NEWP}
+SRC_URI="mirror://sourceforge/${PN}/${NEWP}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+IUSE="readline tcpd ssl gnome mysql sqlite X static"
+
+#theres a local sqlite use flag. use it -OR- mysql, not both.
+#mysql is the reccomended choice ...
+DEPEND="sys-libs/libtermcap-compat
+ >=sys-libs/zlib-1.1.4
+ readline? >=sys-libs/readline-4.3
+ tcpd? >=sys-apps/tcp-wrappers-7.6
+ ssl? >=dev-libs/openssl-0.9.6
+ gnome? gnome-base/gnome-libs
+ sqlite? >=dev-db/sqlite-2.7
+ mysql? >=dev-db/mysql-3.23
+ X? virtual/x11"
+RDEPEND="${DEPEND} sys-apps/mtx app-arch/mt-st"
+
+src_compile() {
+ local myconf
+
+ #define this to skip building the other daemons ...
+ [ -n "$BUILD_CLIENT_ONLY" ] \
+ && myconf="${myconf} --enable-client-only"
+
+ #might be handy to have static bins in certain situations ...
+ use static \
+ && myconf="${myconf} --enable-static-tools \
+ --enable-static-fd --enable-static-sd \
+ --enable-static-dir --enable-static-cons"
+
+ use readline \
+ && myconf="${myconf} --enable-readline" \
+ || myconf="${myconf} --disable-readline"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use tcpd \
+ && myconf="${myconf} --enable-tcpd" \
+ || myconf="${myconf} --disable-tcpd"
+
+ use mysql \
+ && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ use sqlite \
+ && myconf="${myconf} --with-sqlite" \
+ || myconf="${myconf} --without-sqlite"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ #not ./configure'able
+ #use ssl \
+ # && myconf="${myconf} --enable-ssl" \
+ # || myconf="${myconf} --disable-ssl"
+
+ #mysql is the reccomended choice ...
+ if use mysql && use sqlite
+ then
+ #needs one or the either, nuke '--with-sqlite'
+ myconf=${myconf/--with-sqlite/}
+ fi
+
+ einfo "\$myconf is: $myconf"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lib/bacula \
+ --with-working-dir=/var/lib/bacula \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ rm -rf ${D}/var #empty dir
+
+ dodoc ABOUT-NLS COPYING ChangeLog CheckList INSTALL \
+ README ReleaseNotes kernstodo doc/bacula.pdf
+ cp -a examples ${D}/usr/share/doc/${PF}
+ chown -R root.root ${D}/usr/share/doc/${PF} #hrmph :\
+ dohtml -r doc/html-manual doc/home-page
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bacula-init bacula
+}
+
+pkg_postinst() {
+ # empty dir ...
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/bacula
+ einfo
+ einfo "If this is a new install and you plan to use mysql for your"
+ einfo "catalog database, then you should now create it by doing"
+ einfo "these commands:"
+ einfo " sh /etc/bacula/grant_mysql_privileges"
+ einfo " sh /etc/bacula/create_mysql_database"
+ einfo " sh /etc/bacula/make_mysql_tables"
+ einfo
+ einfo "Then setup your configuration files in /etc/bacula and"
+ einfo "start the daemons:"
+ einfo " /etc/init.d/bacula start"
+ einfo
+ einfo "If upgrading from version 1.30 or below, please note that"
+ einfo "the database format has changed. Please read the"
+ einfo "release notes for how to upgrade your database!!!"
+ einfo
+}
diff --git a/app-admin/bacula/files/bacula-init b/app-admin/bacula/files/bacula-init
index 2e283be3a155..32a98027d538 100644
--- a/app-admin/bacula/files/bacula-init
+++ b/app-admin/bacula/files/bacula-init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/files/bacula-init,v 1.2 2003/02/14 22:01:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/files/bacula-init,v 1.3 2003/06/12 03:54:00 woodchip Exp $
depend() {
need net
@@ -14,15 +14,21 @@ opts="test"
# case for this machine just comment the other two out below here...
start() {
ebegin "Starting bacula storage daemon"
- start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- -c /etc/bacula/bacula-sd.conf
result=$?
+
ebegin "Starting bacula file daemon"
- start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- -c /etc/bacula/bacula-fd.conf
result=$(( $result + $? ))
sleep 2
+
ebegin "Starting bacula director"
- start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- -c /etc/bacula/bacula-dir.conf
result=$(( $result + $? ))
+
eend $result
}
@@ -44,13 +50,13 @@ stop() {
test() {
ebegin "Testing bacula storage daemon configuration"
- /usr/sbin/bacula-sd -t
+ /usr/sbin/bacula-sd -t -c /etc/bacula/bacula-sd.conf
result=$?
ebegin "Testing bacula file daemon configuration"
- /usr/sbin/bacula-fd -t
+ /usr/sbin/bacula-fd -t -c /etc/bacula/bacula-fd.conf
result=$(( $result + $? ))
ebegin "Testing bacula director configuration"
- /usr/sbin/bacula-dir -t
+ /usr/sbin/bacula-dir -t -c /etc/bacula/bacula-dir.conf
result=$(( $result + $? ))
eend $result
}
diff --git a/app-admin/bacula/files/digest-bacula-1.31 b/app-admin/bacula/files/digest-bacula-1.31
new file mode 100644
index 000000000000..092e1775c8f5
--- /dev/null
+++ b/app-admin/bacula/files/digest-bacula-1.31
@@ -0,0 +1 @@
+MD5 d627c5d5e235c4061ab01df7d5a5eb05 bacula-1.31-04Jun03.tar.gz 2896906