summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-10-06 12:43:36 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-10-06 12:43:36 +0000
commitea2efb75f18e7e33186b7b4c4bcc78109db50a58 (patch)
tree78e0bc4a63d8b3071059d566ad575fe11b5ed131 /app-admin/apache-tools
parentDrop fuse-fix-lazy-binding.patch wrt #226935, thanks to Rafał Mużyło for r... (diff)
downloadgentoo-2-ea2efb75f18e7e33186b7b4c4bcc78109db50a58.tar.gz
gentoo-2-ea2efb75f18e7e33186b7b4c4bcc78109db50a58.tar.bz2
gentoo-2-ea2efb75f18e7e33186b7b4c4bcc78109db50a58.zip
version bump wrt #283729
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.14.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index adfe7028632d..758ddffecc55 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.62 2009/10/04 14:38:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.63 2009/10/06 12:43:35 hollow Exp $
+
+*apache-tools-2.2.14 (06 Oct 2009)
+
+ 06 Oct 2009; Benedikt Böhm <hollow@gentoo.org>
+ +apache-tools-2.2.14.ebuild:
+ version bump wrt #283729
04 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
apache-tools-2.2.11.ebuild, apache-tools-2.2.12.ebuild,
diff --git a/app-admin/apache-tools/apache-tools-2.2.14.ebuild b/app-admin/apache-tools/apache-tools-2.2.14.ebuild
new file mode 100644
index 000000000000..169b637591dc
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.14.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.14.ebuild,v 1.1 2009/10/06 12:43:36 hollow Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags $(no-as-needed)
+
+ if use ssl ; then
+ myconf="${myconf} --with-ssl=/usr --enable-ssl"
+ fi
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}