summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-01 00:39:48 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-01 00:39:48 +0000
commitbd4ff6b634fecd0ca7f0d61a8be912a2979ad6fe (patch)
tree1ec3a89b17359255c82e6d066e12f7dfdb5139c5 /app-admin/analog
parentdoesn't put multiple entries in bin/wm now, new version of bbkeys as well (diff)
downloadgentoo-2-bd4ff6b634fecd0ca7f0d61a8be912a2979ad6fe.tar.gz
gentoo-2-bd4ff6b634fecd0ca7f0d61a8be912a2979ad6fe.tar.bz2
gentoo-2-bd4ff6b634fecd0ca7f0d61a8be912a2979ad6fe.zip
Made a package for analog, a logfile analyzer. Can be used to analyze
webserver logs and ftpserver logs, probably even other stuff. It creates spiffy HTML reports of such, complete with pie charts and JPEG graphics, etc. Configuration file is probably pretty icky, so Ill look into easing that later. Maybe Ill make a pkg_config to setup report generation for Gentoo's apache package, complete with a cron stub.. Hmm, maybe thats overkill, will think about it. Now Im off to make a package for fwanalog. It makes reports of your packet firewall using analog to first convert the kernel logfile into a format analog can use.
Diffstat (limited to 'app-admin/analog')
-rw-r--r--app-admin/analog/analog-5.03.ebuild50
-rw-r--r--app-admin/analog/files/digest-analog-5.031
2 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/analog/analog-5.03.ebuild b/app-admin/analog/analog-5.03.ebuild
new file mode 100644
index 000000000000..ac066ae4c3be
--- /dev/null
+++ b/app-admin/analog/analog-5.03.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/analog/analog-5.03.ebuild,v 1.1 2001/10/01 00:39:48 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The most popular logfile analyser in the world"
+SRC_URI="http://www.analog.cx/${P}.tar.gz"
+HOMEPAGE="http://www.analog.cx/"
+
+DEPEND="virtual/glibc
+ >=dev-libs/libpcre-3.4
+ >=media-libs/libgd-1.8.3
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv src/Makefile src/Makefile.orig
+ sed -e "s/CFLAGS = -O2 /CFLAGS = ${CFLAGS}/" \
+ -e "s/DEFS = /DEFS = -DHAVE_GD -DHAVE_PCRE/" \
+ -e "s/LIBS = -lm/LIBS = -lgd -lpng -ljpeg -lz -lpcre -lm/" \
+ src/Makefile.orig > src/Makefile
+}
+
+src_compile() {
+ cd src ; emake ; assert "couldnt compile :("
+}
+
+src_install () {
+ dobin analog ; newman analog.man analog.1
+
+ dodoc README.txt Licence.txt analog.cfg
+
+ docinto html_manual
+ # dont want these gzipped
+ cp docs/favicon.ico docs/*.{html,gif,css} ${D}/usr/share/doc/${P}/html_manual
+
+ docinto cgi_interface
+ dodoc anlgform.html anlgform.pl
+
+ docinto sample_configs
+ dodoc examples/*
+
+ # dont want these gzipped
+ cp -a how-to ${D}/usr/share/doc/${P}
+
+ docinto report_images
+ # dont want these gzipped
+ cp images/* ${D}/usr/share/doc/${P}/report_images
+}
diff --git a/app-admin/analog/files/digest-analog-5.03 b/app-admin/analog/files/digest-analog-5.03
new file mode 100644
index 000000000000..c2fc0e074b69
--- /dev/null
+++ b/app-admin/analog/files/digest-analog-5.03
@@ -0,0 +1 @@
+MD5 6a7b77615419e9a8ee1b78e90b88df34 analog-5.03.tar.gz