summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <cbrannon@gentoo.org>2011-03-28 20:05:10 +0000
committerChristopher Brannon <cbrannon@gentoo.org>2011-03-28 20:05:10 +0000
commitf7c45d50e7022b334a65962620f91e5e984cd744 (patch)
treea98147d73b63da54666033a4fd78012ed763b1e7 /app-accessibility
parentRemove old version which depended on non-existant gluezilla version. Reported... (diff)
downloadgentoo-2-f7c45d50e7022b334a65962620f91e5e984cd744.tar.gz
gentoo-2-f7c45d50e7022b334a65962620f91e5e984cd744.tar.bz2
gentoo-2-f7c45d50e7022b334a65962620f91e5e984cd744.zip
Fix dependencies, and various administrivia.
* Make it possible to build with either dev-lang/spidermonkey-1.7.x or dev-lang/spidermonkey-1.9.x (fixes bug #359035). * I am now upstream for this package. HOMEPAGE and SRC_URI were changed accordingly. * Change maintainer to myself (after discussion with WilliamH). (Portage version: 2.1.9.45/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/edbrowse/ChangeLog11
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.4.6.ebuild16
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch16
-rw-r--r--app-accessibility/edbrowse/metadata.xml2
4 files changed, 35 insertions, 10 deletions
diff --git a/app-accessibility/edbrowse/ChangeLog b/app-accessibility/edbrowse/ChangeLog
index 6be1f2c0b090..bd12b70e7d56 100644
--- a/app-accessibility/edbrowse/ChangeLog
+++ b/app-accessibility/edbrowse/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/edbrowse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.2 2011/03/16 04:11:22 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.3 2011/03/28 20:05:10 cbrannon Exp $
+
+ 28 Mar 2011; Christopher Brannon <cbrannon@gentoo.org>
+ edbrowse-3.4.6.ebuild, files/edbrowse-3.4.6-fix-makefile.patch,
+ metadata.xml:
+ * Make it possible to build with either dev-lang/spidermonkey-1.7.x or
+ dev-lang/spidermonkey-1.9.x (fixes bug #359035).
+ * I am now upstream for this package. HOMEPAGE and SRC_URI were changed
+ accordingly.
+ * Change maintainer to myself (after discussion with WilliamH).
16 Mar 2011; William Hubbs <williamh@gentoo.org> edbrowse-3.4.6.ebuild:
fix dependency on dev-lang/spidermonkey for #359035.
diff --git a/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild b/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
index cedbbe52b9ce..0aa9a56725aa 100644
--- a/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
+++ b/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild,v 1.2 2011/03/16 04:11:22 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild,v 1.3 2011/03/28 20:05:10 cbrannon Exp $
EAPI="4"
inherit eutils
DESCRIPTION="editor, browser, and mail client using the /bin/ed interface"
-HOMEPAGE="http://edbrowse.sourceforge.net/"
-SRC_URI="http://www.eklhad.net/${PN}/${P}.zip"
+HOMEPAGE="http://the-brannons.com/edbrowse/"
+SRC_URI="http://the-brannons.com/${PN}/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="linguas_fr odbc"
-COMMON_DEPEND="<dev-lang/spidermonkey-1.9
+COMMON_DEPEND="dev-lang/spidermonkey
>=sys-libs/readline-6.0
>=net-misc/curl-7.17.0
>=dev-libs/libpcre-7.8
@@ -28,7 +28,13 @@ src_prepare() {
}
src_compile() {
- emake prefix=/usr
+ local JSLIB=-ljs
+
+ if has_version ">=dev-lang/spidermonkey-1.9"; then
+ JSLIB=-lmozjs
+ fi
+
+ emake prefix=/usr JSLIB="${JSLIB}"
if use odbc; then
# Top-level makefile doesn't have this target.
cd src
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
index 4e573474beb4..e44710210645 100644
--- a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
+++ b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
@@ -1,6 +1,6 @@
diff -Naur edbrowse-3.4.6/src/makefile edbrowse-3.4.6-new/src/makefile
--- edbrowse-3.4.6/src/makefile 2011-01-20 10:38:24.000000000 +0000
-+++ edbrowse-3.4.6-new/src/makefile 2011-01-26 13:50:10.000000000 +0000
++++ edbrowse-3.4.6-new/src/makefile 2011-03-28 14:02:25.000000000 +0000
@@ -23,12 +23,15 @@
STRIP=-s
endif
@@ -19,7 +19,17 @@ diff -Naur edbrowse-3.4.6/src/makefile edbrowse-3.4.6-new/src/makefile
# Normal load flags
LFLAGS = $(STRIP)
-@@ -59,11 +62,11 @@
+@@ -45,7 +48,8 @@
+ # Or you can use the target jslink below.
+ # Some folks need to add -lcrypto to this list.
+
+-LIBS = -lpcre -lm -lssl -ljs -lcurl -lreadline
++JSLIB = -ljs
++LIBS = -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline
+
+ # Make the dynamically linked executable program by default.
+ # Edbrowse executable.
+@@ -59,11 +63,11 @@
$(EBOBJS) : eb.h eb.p messages.h tcp.h
edbrowse: $(EBOBJS) tcp.o dbstubs.o
@@ -33,7 +43,7 @@ diff -Naur edbrowse-3.4.6/src/makefile edbrowse-3.4.6-new/src/makefile
# If you had to build the javascript library yourself,
# link it into /usr/lib.
-@@ -87,7 +90,7 @@
+@@ -87,7 +91,7 @@
# odbc access
edbrowseodbc: $(EBOBJS) tcp.o dbops.o dbodbc.o
diff --git a/app-accessibility/edbrowse/metadata.xml b/app-accessibility/edbrowse/metadata.xml
index c169e3e65062..b48015680a0e 100644
--- a/app-accessibility/edbrowse/metadata.xml
+++ b/app-accessibility/edbrowse/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>accessibility</herd>
<maintainer>
- <email>williamh@gentoo.org</email>
+ <email>cbrannon@gentoo.org</email>
</maintainer>
<longdescription>
edbrowse is a line editor, web browser and email client using the /bin/ed