summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-07-09 02:25:08 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-07-09 02:25:08 +0000
commiteaf7f7e942606ecddf62047d92915ab05ac0517b (patch)
tree20387eb97f22bb714274f5a6c47ff2b28b2eb2e0 /app-accessibility
parentBump (diff)
downloadgentoo-2-eaf7f7e942606ecddf62047d92915ab05ac0517b.tar.gz
gentoo-2-eaf7f7e942606ecddf62047d92915ab05ac0517b.tar.bz2
gentoo-2-eaf7f7e942606ecddf62047d92915ab05ac0517b.zip
Version bump for bug #476188. Thanks to Chris Brannon. Also sync live ebuild.
(Portage version: 2.2.0_alpha187/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/emacspeak/ChangeLog10
-rw-r--r--app-accessibility/emacspeak/emacspeak-38.0.ebuild62
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild31
3 files changed, 89 insertions, 14 deletions
diff --git a/app-accessibility/emacspeak/ChangeLog b/app-accessibility/emacspeak/ChangeLog
index b6a054a680ab..f8bc75024734 100644
--- a/app-accessibility/emacspeak/ChangeLog
+++ b/app-accessibility/emacspeak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/emacspeak
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.47 2010/12/03 18:35:56 williamh Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.48 2013/07/09 02:25:08 williamh Exp $
+
+*emacspeak-38.0 (09 Jul 2013)
+
+ 09 Jul 2013; William Hubbs <williamh@gentoo.org> +emacspeak-38.0.ebuild,
+ emacspeak-9999.ebuild:
+ Version bump for bug #476188. Thanks to Chris Brannon. Also sync live ebuild.
03 Dec 2010; William Hubbs <williamh@gentoo.org> emacspeak-33.0.ebuild,
emacspeak-9999.ebuild:
diff --git a/app-accessibility/emacspeak/emacspeak-38.0.ebuild b/app-accessibility/emacspeak/emacspeak-38.0.ebuild
new file mode 100644
index 000000000000..64554489d576
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-38.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-38.0.ebuild,v 1.1 2013/07/09 02:25:08 williamh Exp $
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+DEPEND=">=virtual/emacs-22
+ espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+}
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
index a24b85b5b7a6..6f55decd9357 100644
--- a/app-accessibility/emacspeak/emacspeak-9999.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.5 2010/12/03 18:35:56 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.6 2013/07/09 02:25:08 williamh Exp $
-EAPI="2"
+EAPI=5
inherit eutils
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
inherit subversion
- KEYWORDS=""
else
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
@@ -33,23 +32,31 @@ src_prepare() {
}
src_configure() {
- make config || die
+ emake config
}
src_compile() {
- make emacspeak || die
+ emake emacspeak
if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
cd servers/linux-espeak
- make TCL_VERSION=8.5 || die
+ emake TCL_VERSION="${tcl_version}"
fi
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
- dohtml -r install-guide user-guide
+ emake DESTDIR="${D}" install
if use espeak; then
- cd servers/linux-espeak
- make DESTDIR="${D}" install
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
}