summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-03-28 04:03:22 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-03-28 04:03:22 +0000
commite1906512ab7f1445dbb031e1d0918232aa14120e (patch)
tree800354e695c14b4ed0de2fcd4c75c954300d62c4 /app-accessibility
parentunmasking the newer version of boinc, as I've gotten about 10 positives for i... (diff)
downloadgentoo-2-e1906512ab7f1445dbb031e1d0918232aa14120e.tar.gz
gentoo-2-e1906512ab7f1445dbb031e1d0918232aa14120e.tar.bz2
gentoo-2-e1906512ab7f1445dbb031e1d0918232aa14120e.zip
Added a startup script -- this closes #171591.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog8
-rw-r--r--app-accessibility/brltty/brltty-3.7.2-r1.ebuild64
-rw-r--r--app-accessibility/brltty/files/brltty.rc21
-rw-r--r--app-accessibility/brltty/files/digest-brltty-3.7.2-r13
4 files changed, 95 insertions, 1 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index a7de14579cee..16a03e4da41f 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.51 2007/02/22 00:04:30 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.52 2007/03/28 04:03:22 williamh Exp $
+
+*brltty-3.7.2-r1 (28 Mar 2007)
+
+ 28 Mar 2007; William Hubbs <williamh@gentoo.org> +files/brltty.rc,
+ +brltty-3.7.2-r1.ebuild:
+ Add a startup script (closes #171591).
22 Feb 2007; Doug Goldstein <cardoe@gentoo.org> ChangeLog, Manifest:
Manifest2 fix
diff --git a/app-accessibility/brltty/brltty-3.7.2-r1.ebuild b/app-accessibility/brltty/brltty-3.7.2-r1.ebuild
new file mode 100644
index 000000000000..905f02bf5106
--- /dev/null
+++ b/app-accessibility/brltty/brltty-3.7.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.7.2-r1.ebuild,v 1.1 2007/03/28 04:03:22 williamh Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
+SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gpm usb X"
+
+RDEPEND="virtual/libc
+ gpm? ( >=sys-libs/gpm-1.20 )
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( x11-proto/xextproto virtual/x11 ) )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${PN}-3.7.2-nostrip.patch
+}
+
+src_compile() {
+ econf `use_enable gpm` \
+ `use_with X x` \
+ `use_enable usb usb-support` \
+ --prefix=/ \
+ --includedir=/usr/include || die
+ make || die
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+ TMPDIR=../../Programs scanelf -RBXr ${D} -o /dev/null
+ libdir="$(get_libdir)"
+ mkdir -p ${D}/usr/${libdir}/
+ mv ${D}/${libdir}/*.a ${D}/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+ cd Documents
+ rm *.made
+ dodoc ChangeLog README* Manual.* TODO brltty.conf
+ dohtml -r Manual-HTML
+ newinit ${FILESDIR}/brltty.rc brltty
+ if use doc; then
+ dodoc BrlAPI.* BrlAPIref.doxy
+ dohtml -r BrlAPI-HTML BrlAPIref-HTML
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog There is a sample config file in /usr/share/doc/${P}/brltty.conf.
+ elog To use this file, uncompress it into /etc/brltty
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
new file mode 100644
index 000000000000..414f9e948481
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/files/brltty.rc,v 1.1 2007/03/28 04:03:22 williamh Exp $
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting brltty"
+ start-stop-daemon --start --exec /bin/brltty -- -P /var/run/brltty.pid -q
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping brltty"
+ start-stop-daemon --stop --pidfile /var/run/brltty.pid
+ eend $?
+}
diff --git a/app-accessibility/brltty/files/digest-brltty-3.7.2-r1 b/app-accessibility/brltty/files/digest-brltty-3.7.2-r1
new file mode 100644
index 000000000000..84f84bf77bcb
--- /dev/null
+++ b/app-accessibility/brltty/files/digest-brltty-3.7.2-r1
@@ -0,0 +1,3 @@
+MD5 0ae3da8252783a4d20e1ed4e55cede5b brltty-3.7.2.tar.gz 1193139
+RMD160 30b9df4243ce7f0140e1bdcdf53b6bacea135f88 brltty-3.7.2.tar.gz 1193139
+SHA256 1f39a08947833299c6ca6c6dbbc84f6b27a375bb7efe62cf9eebd8d5cdaa6934 brltty-3.7.2.tar.gz 1193139