summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-09-06 22:05:21 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-09-06 22:05:21 +0000
commitc549bfbb66d3ca15ed86d732fdcd4c667ac3e939 (patch)
tree3df5ea42bc06a8b7dbb031b63d404153a0f50701 /app-accessibility
parentNew release with updated versions of included libs. (diff)
downloadgentoo-2-c549bfbb66d3ca15ed86d732fdcd4c667ac3e939.tar.gz
gentoo-2-c549bfbb66d3ca15ed86d732fdcd4c667ac3e939.tar.bz2
gentoo-2-c549bfbb66d3ca15ed86d732fdcd4c667ac3e939.zip
New release: 3.2.18
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog8
-rw-r--r--app-accessibility/dasher/Manifest3
-rw-r--r--app-accessibility/dasher/dasher-3.2.18.ebuild63
-rw-r--r--app-accessibility/dasher/files/digest-dasher-3.2.181
4 files changed, 74 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 38e653bfabb3..5ee9d39f3af7 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.46 2005/08/29 04:13:19 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.47 2005/09/06 22:05:21 leonardop Exp $
+
+*dasher-3.2.18 (06 Sep 2005)
+
+ 06 Sep 2005; Leonardo Boshell <leonardop@gentoo.org>
+ +dasher-3.2.18.ebuild:
+ New version.
*dasher-3.2.17 (29 Aug 2005)
diff --git a/app-accessibility/dasher/Manifest b/app-accessibility/dasher/Manifest
index 9c8f3263962e..8bcc713011c0 100644
--- a/app-accessibility/dasher/Manifest
+++ b/app-accessibility/dasher/Manifest
@@ -2,9 +2,12 @@ MD5 35c08c9a34cbe36bd7edce02513de550 ChangeLog 5882
MD5 b36aedb6555c20ac2d20f53dbeb30989 dasher-3.2.16.ebuild 1738
MD5 993cd40f1be659a5450be19014171459 dasher-3.2.17.ebuild 1738
MD5 645aac23c66d08fa6064bdb7c95c76ef metadata.xml 420
+MD5 852c860ffbd387f2a9fd5faa3e1c8f6e dasher-3.2.18.ebuild 1748
MD5 266e95dffa745c00a8fa6f0d5c4ba811 dasher-3.2.15.ebuild 1512
+MD5 17a5409557738171c2f767ad54460ac4 .dasher-3.2.18.ebuild.swp 12288
MD5 8f98c5422486b58fc0d6850e20582140 files/digest-dasher-3.2.16 67
MD5 9fcdb2723451b2020f4736773717c62b files/digest-dasher-3.2.17 67
MD5 497bed8a975cd29705cb0e9b41f45d76 files/dasher-3.2.11-xtst_fix.patch 872
+MD5 ec3cb701a9f3f224e16cc88cb09f810b files/digest-dasher-3.2.18 67
MD5 5b4b3e17b421919e17bc182404ffa36c files/digest-dasher-3.2.15 67
MD5 29b515c44bcfdd79db45f38f65879994 files/dasher-3.2.15-buildwindowtree.patch 499
diff --git a/app-accessibility/dasher/dasher-3.2.18.ebuild b/app-accessibility/dasher/dasher-3.2.18.ebuild
new file mode 100644
index 000000000000..f3ee15363cd8
--- /dev/null
+++ b/app-accessibility/dasher/dasher-3.2.18.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.18.ebuild,v 1.1 2005/09/06 22:05:21 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND="dev-libs/expat
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2
+ >=x11-libs/libwnck-1
+ virtual/x11
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper"
+
+USE_DESTDIR="1"
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ # cairo switch disabled until gtk+ 2.7 or better is available and
+ # not hard-masked
+ G2CONF="$(use_with gnome) \
+ $(use_with accessibility a11y) \
+ $(use_with accessibility speech) \
+ --without-cairo"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Poor pointer management causes segfault at startup
+ epatch ${FILESDIR}/${PN}-3.2.15-buildwindowtree.patch
+
+ gnome2_omf_fix Data/Help/Gnome/*/Makefile.in
+}
diff --git a/app-accessibility/dasher/files/digest-dasher-3.2.18 b/app-accessibility/dasher/files/digest-dasher-3.2.18
new file mode 100644
index 000000000000..21cf4d52369b
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-3.2.18
@@ -0,0 +1 @@
+MD5 f724113d3148a3c7f888b9e830ae75af dasher-3.2.18.tar.bz2 4758337