summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-07-09 11:17:02 +0000
committerMichael Januszewski <spock@gentoo.org>2004-07-09 11:17:02 +0000
commit9ad44062598754de0d6ceb5727c0874fdba36fa6 (patch)
tree6344609276e740b19230e4e90d51173448a417eb /app-accessibility
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-9ad44062598754de0d6ceb5727c0874fdba36fa6.tar.gz
gentoo-2-9ad44062598754de0d6ceb5727c0874fdba36fa6.tar.bz2
gentoo-2-9ad44062598754de0d6ceb5727c0874fdba36fa6.zip
Initial commit.
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/powiedz/ChangeLog12
-rw-r--r--app-accessibility/powiedz/Manifest2
-rw-r--r--app-accessibility/powiedz/files/digest-powiedz-1.01
-rw-r--r--app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch13
-rw-r--r--app-accessibility/powiedz/files/powiedz.desktop9
-rw-r--r--app-accessibility/powiedz/metadata.xml9
-rw-r--r--app-accessibility/powiedz/powiedz-1.0.ebuild50
7 files changed, 96 insertions, 0 deletions
diff --git a/app-accessibility/powiedz/ChangeLog b/app-accessibility/powiedz/ChangeLog
new file mode 100644
index 000000000000..d3661d6a6cac
--- /dev/null
+++ b/app-accessibility/powiedz/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-accessibility/powiedz
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/powiedz/ChangeLog,v 1.1 2004/07/09 11:17:02 spock Exp $
+
+*powiedz-1.0 (09 Jul 2004)
+
+ 09 Jul 2004; Michal Januszewski <spock@gentoo.org>
+ +files/powiedz-dsp-handle-fix.patch, +files/powiedz.desktop,
+ +powiedz-1.0.ebuild:
+ Initial commit, ebuild submitted by Przemyslaw Maciag <p_maciag@wp.pl> in bug
+ #54572. Thanks!
+
diff --git a/app-accessibility/powiedz/Manifest b/app-accessibility/powiedz/Manifest
new file mode 100644
index 000000000000..e2842ff3c36f
--- /dev/null
+++ b/app-accessibility/powiedz/Manifest
@@ -0,0 +1,2 @@
+MD5 a5888da3f5f13f46a3d8b80601227820 powiedz-1.0.ebuild 941
+MD5 4526d1e4265ddf9722695c2191433c44 files/digest-powiedz-1.0 59
diff --git a/app-accessibility/powiedz/files/digest-powiedz-1.0 b/app-accessibility/powiedz/files/digest-powiedz-1.0
new file mode 100644
index 000000000000..2389497d4b3c
--- /dev/null
+++ b/app-accessibility/powiedz/files/digest-powiedz-1.0
@@ -0,0 +1 @@
+MD5 e41665cc88c096473d48ff2fd32c4646 powiedz-1.0.tgz 68672
diff --git a/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
new file mode 100644
index 000000000000..f18761aff89e
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
@@ -0,0 +1,13 @@
+diff -urN aaa/powiedz/aufile.c powiedz/aufile.c
+--- aaa/powiedz/aufile.c 2003-08-30 20:57:37.000000000 +0200
++++ powiedz/aufile.c 2003-08-31 14:02:42.000000000 +0200
+@@ -217,8 +217,7 @@
+ audio_open(int samp_rate,int disp)
+ {
+ int i;
+-// esd_fd = open(dev_file, O_WRONLY | O_NDELAY);
+- esd_fd = open(audio_dsp, O_WRONLY);
++ esd_fd = open(audio_dsp, O_WRONLY | O_NDELAY);
+ if (esd_fd < 0)
+ {
+ if (disp) perror(audio_dsp);
diff --git a/app-accessibility/powiedz/files/powiedz.desktop b/app-accessibility/powiedz/files/powiedz.desktop
new file mode 100644
index 000000000000..13aca56ecf36
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Powiedz
+Comment=Polish speak synthesizer
+Comment[pl]=Polski syntezator mowy
+Exec=powiedz
+Type=Application
+Encoding=UTF-8
+Terminal=0
+Categories=Application;Audio;
diff --git a/app-accessibility/powiedz/metadata.xml b/app-accessibility/powiedz/metadata.xml
new file mode 100644
index 000000000000..c5e95f0f5075
--- /dev/null
+++ b/app-accessibility/powiedz/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>sound</herd>
+<maintainer>
+ <email>spock@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/powiedz/powiedz-1.0.ebuild b/app-accessibility/powiedz/powiedz-1.0.ebuild
new file mode 100644
index 000000000000..e542aec85fac
--- /dev/null
+++ b/app-accessibility/powiedz/powiedz-1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/powiedz/powiedz-1.0.ebuild,v 1.1 2004/07/09 11:17:02 spock Exp $
+
+inherit eutils
+
+IUSE="arts esd"
+
+DESCRIPTION="Polish speak synthesizer based on rsynth"
+HOMEPAGE="http://kadu.net/index.php?page=download&lang=en"
+SRC_URI="http://kadu.net/download/additions/powiedz-1.0.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="esd? ( media-sound/esound )
+ arts? ( kde-base/arts )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cflags=${CFLAGS}
+
+ if use esd; then
+ ldlibs="${ldlibs} -lesd"
+ defs="${defs} -DUSE_ESD=1"
+ fi
+
+ if use arts; then
+ ldlibs="${ldlibs} `artsc-config --libs`"
+ defs="${defs} -DUSE_ARTS=1"
+ cflags="${cflags} `artsc-config --cflags`"
+ fi
+
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-dsp-handle-fix.patch || die "patching failed"
+ emake -f Makefile_plain LDLIBS="${ldlibs}" CFLAGS="${cflags}" DEFS="${defs}" || die "make failed"
+}
+
+src_install() {
+ cd ${S}
+
+ exeinto /usr/bin
+ doexe powiedz
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}