summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-10-27 15:51:51 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-10-27 15:51:51 +0000
commit73e2fb088f6e117ac5c0eb3e6328d89d79e465cd (patch)
tree87feb4f49f6efb64d89228d37dc60cb2ba50925c /app-accessibility
parentInitial commit: needed for net-misc/bfgminer (diff)
downloadgentoo-2-73e2fb088f6e117ac5c0eb3e6328d89d79e465cd.tar.gz
gentoo-2-73e2fb088f6e117ac5c0eb3e6328d89d79e465cd.tar.bz2
gentoo-2-73e2fb088f6e117ac5c0eb3e6328d89d79e465cd.zip
Add a patch to allow building with automake 1.13.4.
Closes bug #469504. The patch is from upstream's svn repo, so it can go away with the next release. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/sphinxbase/ChangeLog6
-rw-r--r--app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch25
-rw-r--r--app-accessibility/sphinxbase/sphinxbase-0.8.ebuild7
3 files changed, 35 insertions, 3 deletions
diff --git a/app-accessibility/sphinxbase/ChangeLog b/app-accessibility/sphinxbase/ChangeLog
index 4beb7938fc12..f086de9e40cc 100644
--- a/app-accessibility/sphinxbase/ChangeLog
+++ b/app-accessibility/sphinxbase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/sphinxbase
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.8 2013/06/27 18:20:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.9 2013/10/27 15:51:51 teiresias Exp $
+
+ 27 Oct 2013; Christopher Brannon <teiresias@gentoo.org>
+ sphinxbase-0.8.ebuild, +files/sphinxbase-0.8-automake113.patch:
+ Add a patch to allow building with automake 1.13.4. Closes bug #469504.
27 Jun 2013; Agostino Sarubbo <ago@gentoo.org> sphinxbase-0.8.ebuild:
Stable for x86, wrt bug #474436
diff --git a/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
new file mode 100644
index 000000000000..11031918ee68
--- /dev/null
+++ b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
@@ -0,0 +1,25 @@
+diff -Naur sphinxbase-0.8/test/regression/Makefile.am sphinxbase-0.8.new/test/regression/Makefile.am
+--- sphinxbase-0.8/test/regression/Makefile.am 2012-12-05 06:05:39.000000000 -0800
++++ sphinxbase-0.8.new/test/regression/Makefile.am 2013-10-08 13:05:15.498853962 -0700
+@@ -33,9 +33,19 @@
+
+ # Disable sphinx_fe tests for now if fixed-point due to imprecision
+ if FIXED_POINT
+-TESTS = $(srcdir)/test-cepview.sh $(srcdir)/test-sphinx_pitch.sh
++TESTS = test-cepview.sh test-sphinx_pitch.sh
+ else
+-TESTS = $(srcdir)/test-*.sh
++TESTS = \
++ test-cepview.sh \
++ test-sphinx_fe-ctl.sh \
++ test-sphinx_fe-dct.sh \
++ test-sphinx_fe-dither-seed.sh \
++ test-sphinx_fe-logspec2cep.sh \
++ test-sphinx_fe-logspec.sh \
++ test-sphinx_fe.sh \
++ test-sphinx_fe-smoothspec.sh \
++ test-sphinx_jsgf2fsg.sh \
++ test-sphinx_pitch.sh
+ endif
+
+ EXTRA_DIST += $(TESTS)
diff --git a/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild b/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild
index 4b9d5b9fc12b..b54e79e0b783 100644
--- a/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild
+++ b/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild,v 1.4 2013/06/27 18:20:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild,v 1.5 2013/10/27 15:51:51 teiresias Exp $
EAPI=5
@@ -30,7 +30,10 @@ DEPEND="${RDEPEND}
# Due to generated Python setup.py.
AUTOTOOLS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${P}-unbundle-lapack.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-unbundle-lapack.patch
+ "${FILESDIR}"/${P}-automake113.patch
+)
src_configure() {
local myeconfargs=(