summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-07-30 03:31:46 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-07-30 03:31:46 +0000
commit73adc0351df528ca0f94887fa8a352d3a07e872d (patch)
tree0a85ca926369f98f4dccbd4579c756c27b243fd3 /app-accessibility
parentAdd upstream CPE tag (security info) from ChromiumOS. (diff)
downloadgentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.tar.gz
gentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.tar.bz2
gentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.zip
Version bump (bug 451836). Also, removed an old version.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speechd-el/ChangeLog10
-rw-r--r--app-accessibility/speechd-el/speechd-el-1.0.ebuild35
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.5.ebuild42
3 files changed, 50 insertions, 37 deletions
diff --git a/app-accessibility/speechd-el/ChangeLog b/app-accessibility/speechd-el/ChangeLog
index 57ebeacfb5bf..abd33a2cec20 100644
--- a/app-accessibility/speechd-el/ChangeLog
+++ b/app-accessibility/speechd-el/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speechd-el
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speechd-el/ChangeLog,v 1.18 2012/10/19 19:54:09 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speechd-el/ChangeLog,v 1.19 2013/07/30 03:31:46 teiresias Exp $
+
+*speechd-el-2.5 (30 Jul 2013)
+
+ 30 Jul 2013; Christopher Brannon <teiresias@gentoo.org>
+ -speechd-el-1.0.ebuild, +speechd-el-2.5.ebuild:
+ Version bump (bug 451836). Also removed an old version.
19 Oct 2012; Agostino Sarubbo <ago@gentoo.org> speechd-el-2.4.ebuild:
Add ~amd64, wrt bug #438866
diff --git a/app-accessibility/speechd-el/speechd-el-1.0.ebuild b/app-accessibility/speechd-el/speechd-el-1.0.ebuild
deleted file mode 100644
index 91b5e8c09d47..000000000000
--- a/app-accessibility/speechd-el/speechd-el-1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speechd-el/speechd-el-1.0.ebuild,v 1.4 2009/10/17 22:01:46 halcy0n Exp $
-
-inherit elisp
-
-DESCRIPTION="Emacs speech support"
-HOMEPAGE="http://www.freebsoft.org/speechd-el"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd-el/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE=""
-
-DEPEND=">=app-emacs/elib-1.0
- >=app-accessibility/speech-dispatcher-0.5"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- einfo "Nothing to compile"
-}
-
-src_install() {
- elisp-install ${PN} *.el
- exeinto /usr/bin
- doexe speechd-log-extractor
- dodoc ANNOUNCE ChangeLog EMACSPEAK* NEWS README speechd-speak.pdf
- doinfo speechd-el.info
-}
-
-pkg_postinst() {
- elog "Execute the following command from within emacs to get it to speak:"
- elog " M-x load-library RET speechd-speak RET"
-}
diff --git a/app-accessibility/speechd-el/speechd-el-2.5.ebuild b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
new file mode 100644
index 000000000000..a5b04d37750a
--- /dev/null
+++ b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speechd-el/speechd-el-2.5.ebuild,v 1.1 2013/07/30 03:31:46 teiresias Exp $
+
+EAPI="4"
+NEED_EMACS=23
+inherit elisp
+
+DESCRIPTION="Emacs speech support"
+HOMEPAGE="http://www.freebsoft.org/speechd-el"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd-el/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="brltty"
+
+DEPEND=""
+RDEPEND=">=app-accessibility/speech-dispatcher-0.7
+ brltty? ( app-accessibility/brltty )"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ dobin speechd-log-extractor
+ dodoc ANNOUNCE NEWS README speechd-speak.pdf
+ doinfo speechd-el.info
+}
+
+pkg_postinst() {
+ elog "Execute the following commands from within emacs to get it to speak:"
+ elog " M-x load-library RET speechd-speak RET"
+ elog " M-x speechd-speak RET"
+ elog
+ elog "or add the following to your ~/.emacs file:"
+ elog
+ elog "(autoload 'speechd-speak \"speechd-speak\" nil t)"
+ elog '(speechd-speak)'
+}