summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-05-07 14:11:52 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-05-07 14:11:52 +0000
commit50066861098833e963a6a6002df6705c23d9d6a1 (patch)
tree6c2be4c2435481060390f6d1e17b311d87490260 /app-accessibility
parentstable amd64 (diff)
downloadgentoo-2-50066861098833e963a6a6002df6705c23d9d6a1.tar.gz
gentoo-2-50066861098833e963a6a6002df6705c23d9d6a1.tar.bz2
gentoo-2-50066861098833e963a6a6002df6705c23d9d6a1.zip
apply patch to fix #132562
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/gok/ChangeLog6
-rw-r--r--app-accessibility/gok/files/gok-1.0.7-spy_accessible.patch47
-rw-r--r--app-accessibility/gok/gok-1.0.7.ebuild9
3 files changed, 60 insertions, 2 deletions
diff --git a/app-accessibility/gok/ChangeLog b/app-accessibility/gok/ChangeLog
index c7963b87e39d..7c300e07973a 100644
--- a/app-accessibility/gok/ChangeLog
+++ b/app-accessibility/gok/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/gok
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/ChangeLog,v 1.63 2006/03/18 13:01:22 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/ChangeLog,v 1.64 2006/05/07 14:11:52 allanonjl Exp $
+
+ 07 May 2006; John N. Laliberte <allanonjl@gentoo.org>
+ +files/gok-1.0.7-spy_accessible.patch, gok-1.0.7.ebuild:
+ apply patch to fix #132562
*gok-1.0.7 (18 Mar 2006)
diff --git a/app-accessibility/gok/files/gok-1.0.7-spy_accessible.patch b/app-accessibility/gok/files/gok-1.0.7-spy_accessible.patch
new file mode 100644
index 000000000000..7e14c33023e5
--- /dev/null
+++ b/app-accessibility/gok/files/gok-1.0.7-spy_accessible.patch
@@ -0,0 +1,47 @@
+Index: gok/gok-spy.c
+===================================================================
+RCS file: /cvs/gnome/gok/gok/gok-spy.c,v
+retrieving revision 1.170
+diff -u -r1.170 gok-spy.c
+--- gok/gok-spy.c 31 Mar 2006 20:32:58 -0000 1.170
++++ gok/gok-spy.c 3 Apr 2006 13:54:21 -0000
+@@ -264,39 +264,6 @@
+ gok_log_leave ();
+ }
+
+-extern SPIBoolean cspi_accessible_is_a (Accessible *accessible, const char *interface_name);
+-
+-gboolean gok_spy_accessible_is_okay(Accessible* accessible)
+-{
+- gboolean returncode = FALSE;
+- gok_log_enter();
+- if (accessible != NULL)
+- {
+- /* FIXME: we should have a better way of doing this! */
+- returncode = cspi_accessible_is_a (accessible, "IDL:Accessibility/Accessible:1.0");
+- /*
+- if (Accessible_isApplication(accessible) ||
+- Accessible_isComponent(accessible))
+- {
+- returncode = TRUE;
+- }
+- */
+- /*
+- if (gok_spy_accessible_is_desktopChild(accessible) == FALSE)
+- {
+- accessible = NULL;
+- }
+- else
+- {
+- returncode = TRUE;
+- }
+- */
+- }
+- gok_log("returning: %d",returncode);
+- gok_log_leave();
+- return returncode;
+-}
+-
+ static gboolean
+ gok_spy_idle_handler (gpointer data)
+ {
diff --git a/app-accessibility/gok/gok-1.0.7.ebuild b/app-accessibility/gok/gok-1.0.7.ebuild
index 9628186af1ca..ac5fb4431a1f 100644
--- a/app-accessibility/gok/gok-1.0.7.ebuild
+++ b/app-accessibility/gok/gok-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/gok-1.0.7.ebuild,v 1.1 2006/03/18 13:01:22 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/gok-1.0.7.ebuild,v 1.2 2006/05/07 14:11:52 allanonjl Exp $
inherit virtualx gnome2
@@ -52,3 +52,10 @@ src_test() {
addpredict /
Xmake check || die
}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #132562
+ epatch ${FILESDIR}/${P}-spy_accessible.patch
+}