summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-05-27 13:43:44 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-05-27 13:43:44 +0000
commit27262670156049a3d20c421db5965a897cca2867 (patch)
tree185ab7158654cbcd698a092e29d0fbacc4fc7654 /app-accessibility
parentVersion bump. (diff)
downloadgentoo-2-27262670156049a3d20c421db5965a897cca2867.tar.gz
gentoo-2-27262670156049a3d20c421db5965a897cca2867.tar.bz2
gentoo-2-27262670156049a3d20c421db5965a897cca2867.zip
apply patch from upstream bug to fix #134410
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog6
-rw-r--r--app-accessibility/dasher/dasher-4.0.2.ebuild13
-rw-r--r--app-accessibility/dasher/files/dasher-4.0.2-fix_enable_flags.patch30
3 files changed, 42 insertions, 7 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index ca7decc116c1..a593914becfb 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.61 2006/05/10 02:16:59 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.62 2006/05/27 13:43:44 allanonjl Exp $
+
+ 27 May 2006; John N. Laliberte <allanonjl@gentoo.org>
+ +files/dasher-4.0.2-fix_enable_flags.patch, dasher-4.0.2.ebuild:
+ apply patch from upstream bug to fix #134410
*dasher-4.0.2 (10 May 2006)
diff --git a/app-accessibility/dasher/dasher-4.0.2.ebuild b/app-accessibility/dasher/dasher-4.0.2.ebuild
index ea8be62bc5f3..6bdd419ae445 100644
--- a/app-accessibility/dasher/dasher-4.0.2.ebuild
+++ b/app-accessibility/dasher/dasher-4.0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.0.2.ebuild,v 1.1 2006/05/10 02:16:59 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.0.2.ebuild,v 1.2 2006/05/27 13:43:44 allanonjl Exp $
-inherit eutils gnome2
+inherit eutils gnome2 autotools
DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
@@ -59,12 +59,13 @@ pkg_setup() {
}
src_unpack() {
- unpack "${A}"
- cd "${S}"
+ gnome2_src_unpack
# Fix compilation with USE=-gnome (bug #132510)
epatch "${FILESDIR}"/${P}-without_gnome.patch
- gnome2_omf_fix
- sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am ./Data/Makefile.in
+ # fix configure flags
+ epatch "${FILESDIR}"/${P}-fix_enable_flags.patch
+
+ eautoreconf
}
diff --git a/app-accessibility/dasher/files/dasher-4.0.2-fix_enable_flags.patch b/app-accessibility/dasher/files/dasher-4.0.2-fix_enable_flags.patch
new file mode 100644
index 000000000000..3304ee617fb5
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.0.2-fix_enable_flags.patch
@@ -0,0 +1,30 @@
+diff -NurdB dasher-4.0.2/configure.in dasher-4.0.2-patched/configure.in
+--- dasher-4.0.2/configure.in 2006-04-01 15:33:33.000000000 -0500
++++ dasher-4.0.2-patched/configure.in 2006-05-27 03:07:26.000000000 -0500
+@@ -46,7 +46,7 @@
+
+ AC_ARG_ENABLE([speech],
+ AC_HELP_STRING([--enable-speech],[build with speech support (default is NO)]),
+- if test $withval = "no"; then
++ if test $enableval = "no"; then
+ WITHSPEECH=false;
+ else
+ WITHSPEECH=true;
+@@ -73,7 +73,7 @@
+
+ AC_ARG_ENABLE([a11y],
+ AC_HELP_STRING([--enable-a11y],[build with support for the GNOME accessibility framework (default is YES)]),
+- if test $withval = "no"; then
++ if test $enableval = "no"; then
+ WITHA11Y=false;
+ else
+ WITHA11Y=true;
+@@ -82,7 +82,7 @@
+
+ AC_ARG_ENABLE([japanese],
+ AC_HELP_STRING([--enable-japanese],[build with support for Japanese Kanji entry (experimental -- default is NO)]),
+- if test $withval = "no"; then
++ if test $enableval = "no"; then
+ WITHJAPANESE=false;
+ else
+ AC_CHECK_LIB(canna, RkBgnBun,, AC_MSG_ERROR([Canna library not found.]))